emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: John Hendy <jw.hendy@gmail.com>
To: Justin Gordon <justin.gordon@gmail.com>
Cc: emacs-orgmode <emacs-orgmode@gnu.org>
Subject: Re: mixed orgmode installation
Date: Fri, 3 Jan 2014 12:49:39 -0600	[thread overview]
Message-ID: <CA+M2ft-cgQ=Q9GfMid-_KN0c7h3qqCmnJ4TZ1g36LkTtx5m+gg@mail.gmail.com> (raw)
In-Reply-To: <loom.20140102T090001-824@post.gmane.org>

On Thu, Jan 2, 2014 at 2:06 AM, Justin Gordon <justin.gordon@gmail.com> wrote:
> Achim Gratz <Stromeko <at> nexgo.de> writes:
>> John Hendy writes:
>> > Then again, is Worg saying that if `M-x org-version` outputs the
>> > "correct" answer... we're all set and there's nothing to worry about?
>> The output of org-version is determined essentially by checking for two
>> files from the installation and comparing where they would be loaded
>> from.  This catches the most common problems, but certainly not all.  In
>> particular, it won't see when the load-path has been changed after some
>> parts of Org have already been loaded from someplace else (but
>> org-reload will give a warning for this case).
>> Regards,
>> Achim.
> If I byte compile a file, I get this message:
> In org-jekyll-publish-to-html:
> ox-jekyll.el:280:4:Warning: org-publish-org-to called with 5 arguments, but
>     accepts only 4
> This is because my installation is pointing to the emacs default version rather
> than my version  from git. If I do C-h f and look up this function, I get pointed
> to the emacs default version.

I had this issue on Windows the other day and had a draft composed
asking for help before I realized it was my own issue. I got all kinds
of errors like that when I was trying to byte compile via the "Compile
without make tools" section on Worg [1]. Turned out I had my load-path
pointed to the wrong location after I wiped the old git repo and just
cloned a new one in what I thought was a "better/saner" location,
forgetting to update .emacs after doing so.

It might help if you could respond with the following information
(with my example answers provided):

1) how did you download Org and where is the directory located?
- I did `git clone http://orgmode.org/org-mode.git`
- The dir is at /home/jwhendy/.emacs.d/org.git

2) Please post a minimal emacs config you're trying to use

#+begin_src emacs-min

(add-to-list 'load-path "~/.emacs.d/org.git/lisp")
(add-to-list 'load-path "~/.emacs.d/org.git/contrib/lisp")
(add-to-list 'load-path "~/.emacs.d/ess-13.05/lisp")
(add-to-list 'load-path "~/.emacs.d/site-lisp")


3) What happens when you start emacs with `emacs -Q` from
terminal/cmd, then run `M-x load-file` and enter the path to your
minimal config from above, and then:
- `M-x org-version`:
"Org-mode version 8.2.4 (8.2.4-fake @

- `M-x org-reload`:
"Successfully reloaded Org
Org-mode version 8.2.4 (8.2.4-fake @

There might be other pertinent questions, but those are what's coming
to mind for me right now. Perhaps your emacs version?

> However, if I do org-version, I get the proper new version.
> However, if I do list-load-path-shadows, I can verify that org-publish is not
> shadowed, and that's probably due to the fact that the new file is called
> ox-publish.

I agree it sounds like you have something mixed going on.

One other possibility... see this thread from when the new exporter
was first being pushed out with Org 8.0:
- http://lists.gnu.org/archive/html/emacs-orgmode/2013-05/msg00333.html

There are two ways to load backends, which are both listed clearly in
the documentation. During my own setup, however, what I did *not* find
anywhere in the documentation is how their treatment affects things
available in the environment. For example, since adding the backend to
the variable org-export-backends doesn't load it until you actually
use it... the help for the variables (or at least auto-completing)
also isn't available. I ran into this using method 1 originally, then
wanting to customize a variable related to, say, ox-odt or other, and
Org not finding anything when I did `M-x help RET v RET org-odt-TAB`.

Not sure that's what's going on at all, but it might be worth showing
us how you are bringing backends in to Org as well. Someone else would
know better, but I'm wondering if by chance it could be possible not
to have loaded ox-publish (since you haven't published yet), for Org
not to find it, and then to resort to searching in the Emacs-bundled
Org instead? Far-fetched, but came to mind.

[1] http://orgmode.org/worg/org-hacks.html#compiling-org-without-make

Best regards,

> How do I fix this???
> I've tried

  parent reply	other threads:[~2014-01-03 18:49 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-09-04 13:52 mixed orgmode installation Johannes Rainer
2013-09-04 14:19 ` Thorsten Jolitz
2013-09-04 14:52   ` Johannes Rainer
2013-09-04 15:07     ` Suvayu Ali
2013-09-08  5:40       ` adam
2013-09-08 14:37         ` John Hendy
2013-09-08 15:10           ` Suvayu Ali
2013-09-08 15:26             ` John Hendy
2013-09-08 16:52               ` Achim Gratz
2014-01-02  8:06                 ` Justin Gordon
2014-01-03  8:43                   ` Sharon Kimble
2014-01-03 18:08                     ` Justin Gordon
2014-01-03 18:49                   ` John Hendy [this message]
2013-09-04 19:20 ` Achim Gratz
2013-09-08 14:31   ` John Hendy
2013-09-08 16:41     ` Achim Gratz
2013-09-08 17:52       ` John Hendy
2013-09-08 18:39         ` Achim Gratz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CA+M2ft-cgQ=Q9GfMid-_KN0c7h3qqCmnJ4TZ1g36LkTtx5m+gg@mail.gmail.com' \
    --to=jw.hendy@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --cc=justin.gordon@gmail.com \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).