emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Bug: SETUPFILE directive not working [8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)]
@ 2013-04-04 12:51 Marcel van der Boom
  2013-04-04 13:22 ` Carsten Dominik
  0 siblings, 1 reply; 8+ messages in thread
From: Marcel van der Boom @ 2013-04-04 12:51 UTC (permalink / raw)
  To: emacs-orgmode


Remember to cover the basics, that is, what you expected to happen and
what in fact did happen.  You don't know how to make a good report?  See

     http://orgmode.org/manual/Feedback.html#Feedback

Your bug report will be posted to the Org-mode mailing list.
------------------------------------------------------------------------

Using the #+SETUPFILE directive has stopped working for me in version
8.x. I use a line at the bottom of moste of my org files like so:

  #+SETUPFILE: ~/etc/org-config.org

This works fine in 7.9.4.


Emacs  : GNU Emacs 24.3.4 (x86_64-unknown-linux-gnu, GTK+ Version 3.6.0)
 of 2013-03-30 on mrb
Package: Org-mode version 8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)
-- 
Marcel van der Boom  -- http://hsdev.com/mvdb.vcf
HS-Development BV    -- http://www.hsdev.com
We use bitcoin!      -- http://bitcoin.org

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Bug: SETUPFILE directive not working [8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)]
  2013-04-04 12:51 Bug: SETUPFILE directive not working [8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)] Marcel van der Boom
@ 2013-04-04 13:22 ` Carsten Dominik
  2013-04-04 13:34   ` Marcel van der Boom
  2013-04-04 16:55   ` Nicolas Goaziou
  0 siblings, 2 replies; 8+ messages in thread
From: Carsten Dominik @ 2013-04-04 13:22 UTC (permalink / raw)
  To: Marcel van der Boom; +Cc: emacs-orgmode


On 4 apr. 2013, at 14:51, Marcel van der Boom <marcel@hsdev.com> wrote:

> 
> Remember to cover the basics, that is, what you expected to happen and
> what in fact did happen.  You don't know how to make a good report?  See
> 
>     http://orgmode.org/manual/Feedback.html#Feedback
> 
> Your bug report will be posted to the Org-mode mailing list.
> ------------------------------------------------------------------------
> 
> Using the #+SETUPFILE directive has stopped working for me in version
> 8.x. I use a line at the bottom of moste of my org files like so:
> 
>  #+SETUPFILE: ~/etc/org-config.org
> 
> This works fine in 7.9.4.


I think the change is that you now need to put the file names into quotes.
I am not entirely sure why, but I guess Nicolas had a reason for it.

- Carsten

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Bug: SETUPFILE directive not working [8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)]
  2013-04-04 13:22 ` Carsten Dominik
@ 2013-04-04 13:34   ` Marcel van der Boom
  2013-04-04 16:57     ` Nicolas Goaziou
  2013-04-04 16:55   ` Nicolas Goaziou
  1 sibling, 1 reply; 8+ messages in thread
From: Marcel van der Boom @ 2013-04-04 13:34 UTC (permalink / raw)
  To: emacs-orgmode



On do 04-apr-2013 15:22
Carsten Dominik <carsten.dominik@gmail.com> wrote:

> I think the change is that you now need to put the file names into
> quotes. I am not entirely sure why, but I guess Nicolas had a reason
> for it.

This does not make a difference for me. I should have been added that
in the first place in the bug report.

marcel
-- 
Marcel van der Boom  -- http://hsdev.com/mvdb.vcf
HS-Development BV    -- http://www.hsdev.com
We use bitcoin!      -- http://bitcoin.org

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Bug: SETUPFILE directive not working [8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)]
  2013-04-04 13:22 ` Carsten Dominik
  2013-04-04 13:34   ` Marcel van der Boom
@ 2013-04-04 16:55   ` Nicolas Goaziou
  1 sibling, 0 replies; 8+ messages in thread
From: Nicolas Goaziou @ 2013-04-04 16:55 UTC (permalink / raw)
  To: Carsten Dominik; +Cc: Marcel van der Boom, emacs-orgmode

Hello,

Carsten Dominik <carsten.dominik@gmail.com> writes:

> On 4 apr. 2013, at 14:51, Marcel van der Boom <marcel@hsdev.com> wrote:
>
>> 
>> Remember to cover the basics, that is, what you expected to happen and
>> what in fact did happen.  You don't know how to make a good report?  See
>> 
>>     http://orgmode.org/manual/Feedback.html#Feedback
>> 
>> Your bug report will be posted to the Org-mode mailing list.
>> ------------------------------------------------------------------------
>> 
>> Using the #+SETUPFILE directive has stopped working for me in version
>> 8.x. I use a line at the bottom of moste of my org files like so:
>> 
>>  #+SETUPFILE: ~/etc/org-config.org
>> 
>> This works fine in 7.9.4.
>
>
> I think the change is that you now need to put the file names into quotes.
> I am not entirely sure why, but I guess Nicolas had a reason for it.

IIRC, it was so SETUPFILE and INCLUDE keywords would be more alike
(quotes are mandatory in include keyword).


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Bug: SETUPFILE directive not working [8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)]
  2013-04-04 13:34   ` Marcel van der Boom
@ 2013-04-04 16:57     ` Nicolas Goaziou
  2013-04-04 17:12       ` Marcel van der Boom
  0 siblings, 1 reply; 8+ messages in thread
From: Nicolas Goaziou @ 2013-04-04 16:57 UTC (permalink / raw)
  To: Marcel van der Boom; +Cc: emacs-orgmode

Hello,

Marcel van der Boom <marcel@hsdev.com> writes:

> On do 04-apr-2013 15:22
> Carsten Dominik <carsten.dominik@gmail.com> wrote:
>
>> I think the change is that you now need to put the file names into
>> quotes. I am not entirely sure why, but I guess Nicolas had a reason
>> for it.
>
> This does not make a difference for me. I should have been added that
> in the first place in the bug report.

Also, "#+SETUPFILE directive has stopped working for me" isn't very
informative. Would you care to elaborate?


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Bug: SETUPFILE directive not working [8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)]
  2013-04-04 16:57     ` Nicolas Goaziou
@ 2013-04-04 17:12       ` Marcel van der Boom
  2013-04-05  7:20         ` Bastien
  0 siblings, 1 reply; 8+ messages in thread
From: Marcel van der Boom @ 2013-04-04 17:12 UTC (permalink / raw)
  To: emacs-orgmode



On do 04-apr-2013 18:57
Nicolas Goaziou <n.goaziou@gmail.com> wrote:

> Also, "#+SETUPFILE directive has stopped working for me" isn't very
> informative. Would you care to elaborate?

Given the line:
  #+SETUPFILE: "/path/to/settings.org"

in an orgmode buffer.

C-c C-c on that line says "Local setup has been refreshed" but at least
some of the settings do not get applied. Notably i have several lines
in that 'settings.org' file like this:

  #+TAGS: { buy(b) sell(s) } build(u) fix(f) clean(n) 

or

  #+TAGS: call(c) check(e) mail(m) read(r) write(w)  learn(l)


The shortcuts nor grouping is available after refreshing the config.
Also reloading org-mode or restarting Emacs does not make a difference.
Trying the same setup with the minimal org loading as suggested on the
Feedback page [1] shows the same behaviour.



[1] http://orgmode.org/org.html#Feedback
-- 
Marcel van der Boom  -- http://hsdev.com/mvdb.vcf
HS-Development BV    -- http://www.hsdev.com
We use bitcoin!      -- http://bitcoin.org

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Bug: SETUPFILE directive not working [8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)]
  2013-04-04 17:12       ` Marcel van der Boom
@ 2013-04-05  7:20         ` Bastien
  2013-04-05 10:08           ` Marcel van der Boom
  0 siblings, 1 reply; 8+ messages in thread
From: Bastien @ 2013-04-05  7:20 UTC (permalink / raw)
  To: Marcel van der Boom; +Cc: emacs-orgmode

Hi Marcel,

Marcel van der Boom <marcel@hsdev.com> writes:

> C-c C-c on that line says "Local setup has been refreshed" but at least
> some of the settings do not get applied. Notably i have several lines
> in that 'settings.org' file like this:
>
>   #+TAGS: { buy(b) sell(s) } build(u) fix(f) clean(n) 
>
> or
>
>   #+TAGS: call(c) check(e) mail(m) read(r) write(w)  learn(l)

This should now be fixed in master.  Thanks for reporting this
with all the details.

-- 
 Bastien

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Bug: SETUPFILE directive not working [8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)]
  2013-04-05  7:20         ` Bastien
@ 2013-04-05 10:08           ` Marcel van der Boom
  0 siblings, 0 replies; 8+ messages in thread
From: Marcel van der Boom @ 2013-04-05 10:08 UTC (permalink / raw)
  To: emacs-orgmode



On vr 05-apr-2013 09:20
Bastien <bzg@altern.org> wrote:

> This should now be fixed in master.  Thanks for reporting this
> with all the details.

Cool, thanks! This was the last hurdle for me before upgrading.

marcel
-- 
Marcel van der Boom  -- http://hsdev.com/mvdb.vcf
HS-Development BV    -- http://www.hsdev.com
We use bitcoin!      -- http://bitcoin.org

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2013-04-05 10:09 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-04-04 12:51 Bug: SETUPFILE directive not working [8.0-pre (release_8.0-pre-10873-gafb59b @ /home/mrb/dev/emacs/packages/org-mode/lisp/)] Marcel van der Boom
2013-04-04 13:22 ` Carsten Dominik
2013-04-04 13:34   ` Marcel van der Boom
2013-04-04 16:57     ` Nicolas Goaziou
2013-04-04 17:12       ` Marcel van der Boom
2013-04-05  7:20         ` Bastien
2013-04-05 10:08           ` Marcel van der Boom
2013-04-04 16:55   ` Nicolas Goaziou

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).