emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Maxima tests fail in devel on OSX
@ 2013-03-25 10:40 Neuwirth Erich
  2013-03-25 12:20 ` Nicolas Richard
  0 siblings, 1 reply; 3+ messages in thread
From: Neuwirth Erich @ 2013-03-25 10:40 UTC (permalink / raw)
  To: emacs-orgmode@gnu.org Mode

I just ran make up1 on the latest version from git and 
the tests failed on maxima.
I have not changed the configuration of maxima since the last tests I ran probably a month ago.


7 unexpected results:
   FAILED  ob-maxima/integer-input
   FAILED  ob-maxima/list-input
   FAILED  ob-maxima/matrix-output
   FAILED  ob-maxima/simple-list-input
   FAILED  ob-maxima/string-input
   FAILED  ob-maxima/table-input1
   FAILED  ob-maxima/table-input2

make[1]: *** [test-dirty] Error 1
make: *** [up1] Error 2

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Maxima tests fail in devel on OSX
  2013-03-25 10:40 Maxima tests fail in devel on OSX Neuwirth Erich
@ 2013-03-25 12:20 ` Nicolas Richard
  2013-04-06  0:24   ` Bastien
  0 siblings, 1 reply; 3+ messages in thread
From: Nicolas Richard @ 2013-03-25 12:20 UTC (permalink / raw)
  To: emacs-orgmode

Neuwirth Erich <erich.neuwirth@univie.ac.at> writes:
> I have not changed the configuration of maxima since the last tests I
> ran probably a month ago.
>
> 7 unexpected results:
>    FAILED  ob-maxima/integer-input
[...]

I have failures too, but I'm not sure if they are related because I
*did* update maxima (compiled with ECL instead of GCL because that's
required for Sage). I think this will make it clear why there is a
problem :

: $ maxima --very-quiet -r 'batchload("tmp/max")$' 
: ;;; Loading #P"/usr/lib/ecl-12.12.1/sb-bsd-sockets.fas"
: ;;; Loading #P"/usr/lib/ecl-12.12.1/sockets.fas"
: ;;; Loading #P"/usr/lib/ecl-12.12.1/defsystem.fas"
: ;;; Loading #P"/usr/lib/ecl-12.12.1/cmp.fas"
: 4 

My attempts at finding a maxima option to avoid these lines were
unsuccessful (I mainly tried adding "(setq *load-verbose* nil)" to a
maxima-init.lisp file, but that doesn't help). I suppose that ignoring
any line that begins with ";;; Loading #P" will be the easiest way.
Here's an obvious patch in that direction :

--- a/lisp/ob-maxima.el
+++ b/lisp/ob-maxima.el
@@ -83,6 +83,7 @@ called by `org-babel-execute-src-block'."
 		     (mapcar (lambda (line)
 			       (unless (or (string-match "batch" line)
 					   (string-match "^rat: replaced .*$" line)
+					   (string-match "^;;; Loading #P" line)
 					   (= 0 (length line)))
 				 line))
 			     (split-string raw "[\r\n]"))) "\n"))


-- 
Nico.

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Maxima tests fail in devel on OSX
  2013-03-25 12:20 ` Nicolas Richard
@ 2013-04-06  0:24   ` Bastien
  0 siblings, 0 replies; 3+ messages in thread
From: Bastien @ 2013-04-06  0:24 UTC (permalink / raw)
  To: Nicolas Richard; +Cc: emacs-orgmode

Hi Nicolas,

"Nicolas Richard" <theonewiththeevillook@yahoo.fr> writes:

> My attempts at finding a maxima option to avoid these lines were
> unsuccessful (I mainly tried adding "(setq *load-verbose* nil)" to a
> maxima-init.lisp file, but that doesn't help). I suppose that ignoring
> any line that begins with ";;; Loading #P" will be the easiest way.
> Here's an obvious patch in that direction :

Applied, thanks.

-- 
 Bastien

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2013-04-06  0:50 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-03-25 10:40 Maxima tests fail in devel on OSX Neuwirth Erich
2013-03-25 12:20 ` Nicolas Richard
2013-04-06  0:24   ` Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).