emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Ken Mankoff <mankoff@gmail.com>
To: emacs-orgmode@gnu.org
Subject: Bug: org-babel-ref-resolve does not find refs in a COMMENT'ed section [9.3.7 (9.3.7-elpaplus @ /home/kdm/.emacs.d/DEBUG/elpa/org-plus-contrib-20200602/)]
Date: Fri, 05 Jun 2020 09:05:04 -0700	[thread overview]
Message-ID: <873679fqhb.fsf@gmail.com> (raw)

Hello,

I think this is a recent change in behavior. I can no longer eval Babel blocks that expect table inputs via :var when they are in a section with a COMMENT status.



Here is an MWE org file:

=== BEGIN ===

* COMMENT Tables not found when section is commented

#+NAME: table
| foo |

(org-babel-ref-resolve "table")

=== END ===




When I try to eval (org-babel-ref-resolve "table"), Org reports:

org-babel-ref-resolve: Reference ‘table’ not found in this buffer

If I remove the "COMMENT" state on the heading, then the table is found.

I do not recall this happening in earlier versions of Org, but does now with the latest version from melpa.





Tested with /usr/bin/emacs -Q -l ~/.emacs.d/DEBUG.el ~/.emacs.d/DEBUG.org with DEBUG.org above and DEBUG.el containing:


(setq package-user-dir (expand-file-name "elpa" "~/.emacs.d/DEBUG"))
(require 'package)
(setq package-enable-at-startup nil)
(add-to-list 'package-archives '("melpa" . "http://melpa.org/packages/") t)
(add-to-list 'package-archives '("org" . "http://orgmode.org/elpa/") t)
(package-initialize)
(unless (package-installed-p 'use-package)
  (package-refresh-contents)
  (package-install 'use-package))
(setq package-enable-at-startup nil)
(defvar use-package-verbose t)
(require 'use-package)
(setq use-package-always-ensure t)

(use-package org
  :ensure org-plus-contrib
  :config
  (setq org-confirm-babel-evaluate nil)
  (org-babel-do-load-languages
   'org-babel-load-languages
   '((shell . t))))


  -k.


             reply	other threads:[~2020-06-05 16:08 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-05 16:05 Ken Mankoff [this message]
2020-06-05 16:49 ` Nicolas Goaziou

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=873679fqhb.fsf@gmail.com \
    --to=mankoff@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --subject='Re: Bug: org-babel-ref-resolve does not find refs in a COMMENT'\''ed section [9.3.7 (9.3.7-elpaplus @ /home/kdm/.emacs.d/DEBUG/elpa/org-plus-contrib-20200602/)]' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).