emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Uwe Brauer <oub@mat.ucm.es>
To: emacs-orgmode@gnu.org
Subject: MacOS 10.15 cannot use the python-matlab engine.
Date: Sat, 05 Jun 2021 15:26:11 +0200	[thread overview]
Message-ID: <m2a6o4v3ws.fsf@mat.ucm.es> (raw)


Could use perfectly well the python-matlab engine from within emacs org
mode in Ubuntu 16.04, python 3.5 and matlab 2019b.

Now I am using 

    1. Macos 10.15 (catalina),

    2. Matlab2019b. (That only support python 2.7, 3.6, 3.7 but not 3.8,
       which the MacOs ships.

    3. So I installed fink (and python 3.7.)

    4. The installation of the python engine.

       a. In /Applications/MATLAB_R2019b.app/extern/engines/python I run

       b. sudo /opt/sw/bin/python3.7 setup.py install

       c. The installation seem fine

    5. Setting up emacs: my setting is now slightly different:

#+BEGIN_SRC emacs-lisp
(setq org-confirm-babel-evaluate nil)   ;don't prompt me to confirm everytime I want to evaluate a block
;;; display/update images in the buffer after I evaluate
(add-hook 'org-babel-after-execute-hook 'org-display-inline-images 'append)
(add-to-list 'org-src-lang-modes '("matlab" . matlab))
(setq python-shell-interpreter "/opt/sw/bin/python3.7")
;; set default headers for convenience
(setq org-babel-default-header-args:matlab
      '((:results . "output replace")
	(:session . "matlab")
	(:kernel . "matlab")
	(:exports . "code")
	(:cache .   "no")
	(:noweb . "no")
	(:hlines . "no")
	(:tangle . "no")))
(defalias 'org-babel-execute:matlab 'org-babel-execute:ipython)
(defalias 'org-babel-prep-session:matlab 'org-babel-prep-session:ipython)
(defalias 'org-babel-matlab-initiate-session 'org-babel-ipython-initiate-session)

Now, I run as an example 

#+begin_src matlab :results output latex :exports results  :eval never-export :wrap latex
x = [1, 2, 3, 4, 5];
fprintf('|%d', x)

But I obtain now the unexpected error

| Debugger entered--Lisp error: (error "There was a fatal error trying to process the requ...")
|   signal(error ("There was a fatal error trying to process the requ..."))
|   error("There was a fatal error trying to process the requ...")
|   ob-ipython--dump-error("Traceback (most recent call last):\n  File \"/Users/...")
|   ob-ipython--execute-request("x = [1, 2, 3, 4, 5];\nfprintf('|%d', x)" "matlab")
|   ob-ipython--execute-sync("x = [1, 2, 3, 4, 5];\nfprintf('|%d', x)" ((:colname-names) (:rowname-names) (:result-params "replace" "output" "latex") (:result-type . output) (:results . "replace output latex") (:exports . "results") (:session . "matlab") (:kernel . "matlab") (:cache . "no") (:noweb . "no") (:hlines . "no") (:tangle . "no") (:eval . "never-export") (:wrap . "latex")))
|   org-babel-execute:matlab("x = [1, 2, 3, 4, 5];\nfprintf('|%d', x)" ((:colname-names) (:rowname-names) (:result-params "replace" "output" "latex") (:result-type . output) (:results . "replace output latex") (:exports . "results") (:session . "matlab") (:kernel . "matlab") (:cache . "no") (:noweb . "no") (:hlines . "no") (:tangle . "no") (:eval . "never-export") (:wrap . "latex")))
|   org-babel-execute-src-block(nil ("matlab" "x = [1, 2, 3, 4, 5];\nfprintf('|%d', x)" ((:colname-names) (:rowname-names) (:result-params "latex" "output" "replace") (:result-type . output) (:results . "latex output replace") (:exports . "results") (:wrap . "latex") (:eval . "never-export") (:tangle . "no") (:hlines . "no") (:noweb . "no") (:cache . "no") (:kernel . "matlab") (:session . "matlab")) "" nil 2036 "(ref:%s)"))
|   org-ctrl-c-ctrl-c(nil)
|   funcall-interactively(org-ctrl-c-ctrl-c nil)
|   call-interactively(org-ctrl-c-ctrl-c nil nil)
|   command-execute(org-ctrl-c-ctrl-c)

I know that there some MaCOS users here in the list:

Any idea what went wrong.

Any help is strongly appreciated, since I don't have access to my Linux
machine fro the coming days.


Uwe Brauer 

             reply	other threads:[~2021-06-05 13:27 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-05 13:26 Uwe Brauer [this message]
2021-06-07 15:36 ` [native mac python3 does not work] (was: MacOS 10.15 cannot use the python-matlab engine.) Uwe Brauer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=m2a6o4v3ws.fsf@mat.ucm.es \
    --to=oub@mat.ucm.es \
    --cc=emacs-orgmode@gnu.org \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).