emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* New LaTeX exporter, problem with quotes
@ 2013-01-18  1:53 Thomas S. Dye
  2013-01-18 21:04 ` Nicolas Goaziou
  0 siblings, 1 reply; 3+ messages in thread
From: Thomas S. Dye @ 2013-01-18  1:53 UTC (permalink / raw)
  To: Org-mode

Aloha all,

I just noticed quotes aren't exporting correctly with the new LaTeX
exporter.  The old one seems to work fine.  

Does anyone else see this?  Or is this a SIMS (something in
my setup) bug?

For me, this Org mode buffer:

** Quotes
"This should have good LaTeX quotes."

Generates this LaTeX output:

% Created 2013-01-17 Thu 15:46
\documentclass[11pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{fixltx2e}
\usepackage{graphicx}
\usepackage{longtable}
\usepackage{float}
\usepackage{wrapfig}
\usepackage{soul}
\usepackage{textcomp}
\usepackage{marvosym}
\usepackage{wasysym}
\usepackage{latexsym}
\usepackage{amssymb}
\usepackage{hyperref}
\tolerance=1000
\author{Thomas Dye}
\date{\today}
\title{}
\hypersetup{
  pdfkeywords={},
  pdfsubject={},
  pdfcreator={Generated by Org mode 7.9.3b in Emacs 24.2.1.}}
\begin{document}

\tableofcontents
\vspace*{1cm}

\section{Quotes}
\label{sec-1}
"This should have good \LaTeX{} quotes."
% Generated by Org mode 7.9.3b in Emacs 24.2.1.
\end{document}

All the best,
Tom

-- 
T.S. Dye & Colleagues, Archaeologists
735 Bishop St, Suite 315, Honolulu, HI 96813
Tel: 808-529-0866, Fax: 808-529-0884
http://www.tsdye.com

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: New LaTeX exporter, problem with quotes
  2013-01-18  1:53 New LaTeX exporter, problem with quotes Thomas S. Dye
@ 2013-01-18 21:04 ` Nicolas Goaziou
  2013-01-18 21:30   ` Thomas S. Dye
  0 siblings, 1 reply; 3+ messages in thread
From: Nicolas Goaziou @ 2013-01-18 21:04 UTC (permalink / raw)
  To: Thomas S. Dye; +Cc: Org-mode

Hello,

tsd@tsdye.com (Thomas S. Dye) writes:

> I just noticed quotes aren't exporting correctly with the new LaTeX
> exporter.  The old one seems to work fine.

Did you activate smart quotes with either `org-export-with-smart-quotes'
or #+OPTIONS: ':t first?

I cannot reproduce it.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: New LaTeX exporter, problem with quotes
  2013-01-18 21:04 ` Nicolas Goaziou
@ 2013-01-18 21:30   ` Thomas S. Dye
  0 siblings, 0 replies; 3+ messages in thread
From: Thomas S. Dye @ 2013-01-18 21:30 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: Org-mode

Nicolas Goaziou <n.goaziou@gmail.com> writes:

> Hello,
>
> tsd@tsdye.com (Thomas S. Dye) writes:
>
>> I just noticed quotes aren't exporting correctly with the new LaTeX
>> exporter.  The old one seems to work fine.
>
> Did you activate smart quotes with either `org-export-with-smart-quotes'
> or #+OPTIONS: ':t first?

No I didn't.  Now that I have, the quotes are just as they should be.

Thanks!

All the best,
Tom

-- 
Thomas S. Dye
http://www.tsdye.com

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2013-01-18 21:31 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-01-18  1:53 New LaTeX exporter, problem with quotes Thomas S. Dye
2013-01-18 21:04 ` Nicolas Goaziou
2013-01-18 21:30   ` Thomas S. Dye

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).