emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org-mode fontification error when exporting to LaTeX
@ 2011-07-13  1:52 Luke J Crook
  2011-07-13  5:16 ` David O'Toole
  0 siblings, 1 reply; 4+ messages in thread
From: Luke J Crook @ 2011-07-13  1:52 UTC (permalink / raw)
  To: emacs-orgmode

I get an 'org-mode fontification error' when I export to LaTeX.
Any idea what may be causing this?

Thanks,
-Luke

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: org-mode fontification error when exporting to LaTeX
  2011-07-13  1:52 org-mode fontification error when exporting to LaTeX Luke J Crook
@ 2011-07-13  5:16 ` David O'Toole
  2011-07-13  7:47   ` Bastien
  0 siblings, 1 reply; 4+ messages in thread
From: David O'Toole @ 2011-07-13  5:16 UTC (permalink / raw)
  To: Luke J Crook; +Cc: emacs-orgmode

Hi,

try doing (setq debug-on-error t) and then re-export; this should give
you a backtrace.

but sometimes fontification stuff can have errors without backtraces.
try checking the *Messages* buffer. misbehaving font-lock rules and
improperly defined faces can also be issues.

On Tue, Jul 12, 2011 at 9:52 PM, Luke J Crook <luke@balooga.com> wrote:
> I get an 'org-mode fontification error' when I export to LaTeX.
> Any idea what may be causing this?
>
> Thanks,
> -Luke
>
>
>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: org-mode fontification error when exporting to LaTeX
  2011-07-13  5:16 ` David O'Toole
@ 2011-07-13  7:47   ` Bastien
  2011-07-13 17:53     ` Luke J Crook
  0 siblings, 1 reply; 4+ messages in thread
From: Bastien @ 2011-07-13  7:47 UTC (permalink / raw)
  To: David O'Toole; +Cc: emacs-orgmode, Luke J Crook

Hi Luke,

"David O'Toole" <dto1138@gmail.com> writes:

> try doing (setq debug-on-error t) and then re-export; this should give
> you a backtrace.
>
> but sometimes fontification stuff can have errors without backtraces.
> try checking the *Messages* buffer. misbehaving font-lock rules and
> improperly defined faces can also be issues.

Yes -- also please give more details about your setup: what version 
of Org and Emacs?  What system?

Thanks!

-- 
 Bastien

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: org-mode fontification error when exporting to LaTeX
  2011-07-13  7:47   ` Bastien
@ 2011-07-13 17:53     ` Luke J Crook
  0 siblings, 0 replies; 4+ messages in thread
From: Luke J Crook @ 2011-07-13 17:53 UTC (permalink / raw)
  To: emacs-orgmode

Bastien <bzg <at> altern.org> writes:

> Yes -- also please give more details about your setup: what version 
> of Org and Emacs?  What system?

I tracked it down to the following in my text;


- list item
  - list item
  - list item - Note :: Blah
  - list item - Note :: Blah
- list item

The error goes away when I correct this to the following;

- list item
  - list item
  - list item 
    - Note :: Blah
  - list item 
    - Note :: Blah
- list item


Thanks folks.
-Luke

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2011-07-13 17:54 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-07-13  1:52 org-mode fontification error when exporting to LaTeX Luke J Crook
2011-07-13  5:16 ` David O'Toole
2011-07-13  7:47   ` Bastien
2011-07-13 17:53     ` Luke J Crook

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).