emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Stefi <stefi@freitagsrunde.org>
To: Kyle Meyer <kyle@kyleam.com>
Cc: emacs-orgmode@gnu.org
Subject: Re: Bug: no math-mode detection for align-environment [9.3.7 (9.3.7-13-ge62ca4-elpaplus @ /home/stefi/.emacs.d/elpa/org-plus-contrib-20200713/)]
Date: Wed, 26 Aug 2020 20:05:47 +0200	[thread overview]
Message-ID: <f397c0a4-2334-9c43-7b8e-4484d8e8c833@freitagsrunde.org> (raw)
In-Reply-To: <87tuwqm5pe.fsf@kyleam.com>

I can also confirm that org-try-cdlatex-tab outputs "t" in all cases but
does not expand in align environment.

I noticed that cdlatex-env-alist-default does not include the align
environment. I tried to add it to "Cdlatex Env Alist" in the customize
browser but it did not change the behavior to what I expect.

I skimmed through cdlatex.el but did not find anything suspicious. I am
not a hardcore lisp coder though.

On 8/26/20 5:44 AM, Kyle Meyer wrote:
> Stefi writes:
>> Hi Kyle, hi mailing list,
>> I also evaluated (org-inside-LaTeX-fragment-p) and got non-nil values
>> for all blocks, however, inside the align* environment, the "fr" does
>> not get expanded on TAB whereas it does in equation environment. So
>> either the matchers do not include align/align*, or there is something
>> different now with cdlatex.
> I'm leaning towards there being something different with cdlatex.
> I've now installed cdlatex from
> <https://staff.fnwi.uva.nl/c.dominik/Tools/cdlatex/cdlatex.el>.  The
> file header says the version is 4.8, and the file's md5sum is
> 9246a4e9f30c9589406783ffd5270641.
> I tried your example file with this minimal configuration:
>     (require 'org)
>     (add-hook 'org-mode-hook (lambda () (org-cdlatex-mode 1)))
>     (require 'edebug)
>     (edebug-instrument-function 'org-try-cdlatex-tab)
> As you and Rafael report, "fr => \frac{}{}" is not expanded in the align
> or align* environments, while it is expanded in the equation
> environment.  However, stepping through the org-try-cdlatex-tab call,
> cdlatex-tab is called in all cases.  So it would seem that something has
> changed downstream.
> In line with this idea, I observed the same behavior with both the
> latest commit of the master branch (cdfc404be) and v9.2 (released in Dec
> 2018).  Also, as I mentioned in earlier in the thread, I don't see any
> recent changes on Org's side related to the cdlatex functionality.

  reply	other threads:[~2020-08-26 18:06 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-14 11:49 Bug: no math-mode detection for align-environment [9.3.7 (9.3.7-13-ge62ca4-elpaplus @ /home/stefi/.emacs.d/elpa/org-plus-contrib-20200713/)] Stefi
2020-07-29  3:12 ` Kyle Meyer
2020-08-05 20:19   ` Rafael
2020-08-10 10:50   ` Stefi
2020-08-26  3:44     ` Kyle Meyer
2020-08-26 18:05       ` Stefi [this message]
2020-08-27 11:39       ` Stefi
2020-08-28  5:08         ` Kyle Meyer
2020-08-28  6:55           ` Carsten Dominik
2020-08-29 13:27             ` Stefi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f397c0a4-2334-9c43-7b8e-4484d8e8c833@freitagsrunde.org \
    --to=stefi@freitagsrunde.org \
    --cc=emacs-orgmode@gnu.org \
    --cc=kyle@kyleam.com \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).