emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Manish <mailtomanish.sharma@gmail.com>
To: Dan Davison <davison@stats.ox.ac.uk>
Cc: emacs org-mode mailing list <emacs-orgmode@gnu.org>
Subject: Re: overzealous file link creation
Date: Wed, 12 Aug 2009 13:22:10 +0530	[thread overview]
Message-ID: <e7cdbe30908120052m9cc629doea7115784eb430aa@mail.gmail.com> (raw)
In-Reply-To: <87ws5aozzv.fsf@stats.ox.ac.uk>

On Wed, Aug 12, 2009 at 1:59 AM, Dan Davison wrote:
> Recently I've been randomly losing the string 'file' from all sorts of
> documents. Up until now I had no explanation. It's not the sort of
> question one wants to ask on public mailing lists.
> OK, so if you call org-cycle "in the vicinity" of a word that starts
> with the string 'file', then it eats up 'file' and prompts for link
> insertion. This is true in buffers that are not in org-mode or
> orgstruct*-mode. (I call org-cycle the whole time in order to use
> outline-minor-mode, but o-m-m doesn't have to be turned on to cause
> this.)
> Try putting the following fragment into python-mode, and getting rid of
> the asterisks. Then org-cycle issued with point at any of the asterisked
> locations eats the string 'file' and prompts for a link.
> --8<---------------cut here---------------start------------->8---
> def f(filepath):
>  print(
>    *filepath*)*
> *
> *def g(arg):
>  return arg
> --8<---------------cut here---------------end--------------->8---
> This is with latest git.

Tried the test with following text with numbers removed.

--8<---------------cut here---------------start------------->8---
def f(filepath):
5def g(arg):
 return arg
--8<---------------cut here---------------end--------------->8---

With buffer in python mode, I executed org-cycle at the positions marked with
numbers and got the results below:

at 1,2,3: nothing happens
at 4: inserts a tab (four spaces in my case)
at 5: eats the line with "return arg" (also can not revert this change
with undo.)

The buffer "looks" as if it ends at "def g(arg):" line but when I tried to
paste the resultant buffer with "return arg" removed, I got the following
strange result.

--8<---------------cut here---------------start------------->8---
def f(filepath):

def g(arg):
   return arg
   return arg

   return arg

--8<---------------cut here---------------end--------------->8---

I tried it several times, also tried saving the buffer and opening it in that
other editor as well.

Tested with git commit 5834ad01b617430c0207627ad425758bcf9b921a of
"Tue Aug 11 16:32:05 2009 +0200"


  parent reply	other threads:[~2009-08-12  7:52 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-08-11 20:29 overzealous file link creation Dan Davison
2009-08-11 21:36 ` Nick Dokos
2009-08-12  7:52 ` Manish [this message]
2009-08-12  8:32   ` Carsten Dominik
2009-08-12  8:30 ` Carsten Dominik
2009-08-12 16:09   ` Dan Davison
2009-08-12 16:42     ` Carsten Dominik

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e7cdbe30908120052m9cc629doea7115784eb430aa@mail.gmail.com \
    --to=mailtomanish.sharma@gmail.com \
    --cc=davison@stats.ox.ac.uk \
    --cc=emacs-orgmode@gnu.org \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).