emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Latex export - not working - more info..
@ 2009-01-07 21:00 sergio_101
  2009-01-07 23:36 ` Carsten Dominik
  0 siblings, 1 reply; 9+ messages in thread
From: sergio_101 @ 2009-01-07 21:00 UTC (permalink / raw)
  To: emacs-orgmode

os: osx 10.5
GNU Emacs 22.3.1 (powerpc-apple-darwin9.3.0, Carbon Version 1.6.0)
org-mode: Org-mode version 6.17c

i have done  the following:

removed old version (6.12-ish) of org-mode..

edited Makefile to read:

EMACS=/Applications/Emacs.app/Contents/MacOS/Emacs

did a make on the new code..

after doing this, i am still having trouble exporting to latex..

when i exported several simple files, i get:

(New file)
Loading tex...done
Loading latex...done
Loading font-latex...
Loading bytecomp...done
Loading font-latex...done
Applying style hooks... done
Sorting environment...
Removing duplicates... done
Loading tex-bar...done
Loading preview...
Loading byte-opt...done
Loading preview...done
Applying style hooks... done
Loading tabify...done

at that point, emacs just hangs..

when i do an activity monitor, i see that emacs is pegging the cpu..
but even when i let it sit for an hour or so, no dice..

the catch is... it worked previously, and i have not added anything new..

any help would be appreciated..

thanks!

-- 
___
peace,
sergio
www.village-buzz.com
photographer, journalist, visionary

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Latex export - not working - more info..
  2009-01-07 21:00 Latex export - not working - more info sergio_101
@ 2009-01-07 23:36 ` Carsten Dominik
  2009-01-08  0:14   ` sergio_101
                     ` (3 more replies)
  0 siblings, 4 replies; 9+ messages in thread
From: Carsten Dominik @ 2009-01-07 23:36 UTC (permalink / raw)
  To: sergio_101; +Cc: emacs-orgmode

Hi Sergio,

your example file exports fine in my setup.

Anyone else can reproduce Sergio's problem?

- Carsten

On Jan 7, 2009, at 10:00 PM, sergio_101 wrote:

> os: osx 10.5
> GNU Emacs 22.3.1 (powerpc-apple-darwin9.3.0, Carbon Version 1.6.0)
> org-mode: Org-mode version 6.17c
>
> i have done  the following:
>
> removed old version (6.12-ish) of org-mode..
>
> edited Makefile to read:
>
> EMACS=/Applications/Emacs.app/Contents/MacOS/Emacs
>
> did a make on the new code..
>
> after doing this, i am still having trouble exporting to latex..
>
> when i exported several simple files, i get:
>
> (New file)
> Loading tex...done
> Loading latex...done
> Loading font-latex...
> Loading bytecomp...done
> Loading font-latex...done
> Applying style hooks... done
> Sorting environment...
> Removing duplicates... done
> Loading tex-bar...done
> Loading preview...
> Loading byte-opt...done
> Loading preview...done
> Applying style hooks... done
> Loading tabify...done
>
> at that point, emacs just hangs..
>
> when i do an activity monitor, i see that emacs is pegging the cpu..
> but even when i let it sit for an hour or so, no dice..
>
> the catch is... it worked previously, and i have not added anything  
> new..
>
> any help would be appreciated..
>
> thanks!
>
> -- 
> ___
> peace,
> sergio
> www.village-buzz.com
> photographer, journalist, visionary
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Latex export - not working - more info..
  2009-01-07 23:36 ` Carsten Dominik
@ 2009-01-08  0:14   ` sergio_101
  2009-01-08  6:20     ` Carsten Dominik
  2009-01-08  0:39   ` Matthew Lundin
                     ` (2 subsequent siblings)
  3 siblings, 1 reply; 9+ messages in thread
From: sergio_101 @ 2009-01-08  0:14 UTC (permalink / raw)
  To: Carsten Dominik; +Cc: emacs-orgmode

Carsten Dominik <dominik@science.uva.nl> writes:

> Hi Sergio,
>
> your example file exports fine in my setup.
>
> Anyone else can reproduce Sergio's problem?

hi, carsten..

just one more thing that may be of use..

i can take any existing tex files (even really whacky ones) and produce
pdfs just fine..

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Latex export - not working - more info..
  2009-01-07 23:36 ` Carsten Dominik
  2009-01-08  0:14   ` sergio_101
@ 2009-01-08  0:39   ` Matthew Lundin
  2009-01-08  1:52     ` sergio_101
  2009-01-08  8:55   ` Giovanni Ridolfi
  2009-01-08 10:42   ` Manish
  3 siblings, 1 reply; 9+ messages in thread
From: Matthew Lundin @ 2009-01-08  0:39 UTC (permalink / raw)
  To: Carsten Dominik; +Cc: emacs-orgmode


Carsten Dominik <dominik@science.uva.nl> writes:

> Hi Sergio,
>
> your example file exports fine in my setup.
>
> Anyone else can reproduce Sergio's problem?
>
> - Carsten
>

LaTeX export is working fine for me with Carbon Emacs (Mac OS X) and
the most recent org from the git repository.

- Matt

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Latex export - not working - more info..
  2009-01-08  0:39   ` Matthew Lundin
@ 2009-01-08  1:52     ` sergio_101
  2009-01-08 12:42       ` Matthew Lundin
  0 siblings, 1 reply; 9+ messages in thread
From: sergio_101 @ 2009-01-08  1:52 UTC (permalink / raw)
  To: Matthew Lundin; +Cc: emacs-orgmode


hi, matt...

can you send me the relevant parts (the top) of your Makefile?

mine looks like this..

# Name of your emacs binary
EMACS=/Applications/Emacs.app/Contents/MacOS/Emacs 
# Where local software is found
prefix=/usr/local

# Where local lisp files go.
lispdir = $(prefix)/share/emacs/site-lisp

# Where info files go.
infodir = $(prefix)/share/info

thanks!

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Latex export - not working - more info..
  2009-01-08  0:14   ` sergio_101
@ 2009-01-08  6:20     ` Carsten Dominik
  0 siblings, 0 replies; 9+ messages in thread
From: Carsten Dominik @ 2009-01-08  6:20 UTC (permalink / raw)
  To: sergio_101; +Cc: emacs-orgmode


On Jan 8, 2009, at 1:14 AM, sergio_101 wrote:

> Carsten Dominik <dominik@science.uva.nl> writes:
>
>> Hi Sergio,
>>
>> your example file exports fine in my setup.
>>
>> Anyone else can reproduce Sergio's problem?
>
> hi, carsten..
>
> just one more thing that may be of use..
>
> i can take any existing tex files (even really whacky ones) and  
> produce
> pdfs just fine..
>



Hi Sergio,

one thing you can do to narrow down where things go wrong is this:

Go to the "Options" menu in Emacs and turn on "Enter debugger on Quit/ 
C-g".  The export a LaTeX file, wait until Emacs is stuck, and then  
press C-g.  The backtrace should give us information where it got  
stuck.  The backtrace will be more useful if you load uncompiled  
versions of Org, i.e. if the elc files are not present.

- Carsten

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Latex export - not working - more info..
  2009-01-07 23:36 ` Carsten Dominik
  2009-01-08  0:14   ` sergio_101
  2009-01-08  0:39   ` Matthew Lundin
@ 2009-01-08  8:55   ` Giovanni Ridolfi
  2009-01-08 10:42   ` Manish
  3 siblings, 0 replies; 9+ messages in thread
From: Giovanni Ridolfi @ 2009-01-08  8:55 UTC (permalink / raw)
  To: sergio_101, Carsten Dominik; +Cc: emacs-orgmode

--- Mer 7/1/09, Carsten Dominik <dominik@science.uva.nl> ha scritto:
> Da: Carsten Dominik <dominik@science.uva.nl>
> 
> Anyone else can reproduce Sergio's problem?
Hi Carsten,

I had the same problem with Emacs hanginig yesterday at home[1] 


Org version 6.17c,     whereas 6.17 exported fine.
Emacs 22.2
OS: Debian unstable

[1] so, sorry, I can't provide more information

cheers,

Giovanni




^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Latex export - not working - more info..
  2009-01-07 23:36 ` Carsten Dominik
                     ` (2 preceding siblings ...)
  2009-01-08  8:55   ` Giovanni Ridolfi
@ 2009-01-08 10:42   ` Manish
  3 siblings, 0 replies; 9+ messages in thread
From: Manish @ 2009-01-08 10:42 UTC (permalink / raw)
  To: Carsten Dominik; +Cc: emacs-orgmode

On Thu, Jan 8, 2009 at 5:06 AM, Carsten Dominik wrote:
> Hi Sergio,
>
> your example file exports fine in my setup.
>
> Anyone else can reproduce Sergio's problem?
>
> - Carsten

I couldn't find his file to test but Org->PDF worked fine on my files
here on Emacs 22.3 and latest Org (commit: c073d51).

-- 
Manish

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Latex export - not working - more info..
  2009-01-08  1:52     ` sergio_101
@ 2009-01-08 12:42       ` Matthew Lundin
  0 siblings, 0 replies; 9+ messages in thread
From: Matthew Lundin @ 2009-01-08 12:42 UTC (permalink / raw)
  To: sergio_101; +Cc: emacs-orgmode


Hi Sergio, 

The following Makefile settings work for me when installing with
Carbon Emacs:

---begin Makefile snippet---

# Name of your emacs binary
EMACS=/Applications/Emacs.app/Contents/MacOS/emacs

# Where local software is found
prefix=/usr/local

# Where local lisp files go.
lispdir = /Applications/Emacs.app/Contents/Resources/site-lisp 

# Where info files go.
infodir = /Applications/Emacs.app/Contents/Resources/info 

---end Makefile snippet---

- Matt

sergio_101 <sergiolist@village-buzz.com> writes:

> hi, matt...
>
> can you send me the relevant parts (the top) of your Makefile?
>
> mine looks like this..
>
> # Name of your emacs binary
> EMACS=/Applications/Emacs.app/Contents/MacOS/Emacs 
> # Where local software is found
> prefix=/usr/local
>
> # Where local lisp files go.
> lispdir = $(prefix)/share/emacs/site-lisp
>
> # Where info files go.
> infodir = $(prefix)/share/info
>
> thanks!

^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2009-01-08 12:42 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-01-07 21:00 Latex export - not working - more info sergio_101
2009-01-07 23:36 ` Carsten Dominik
2009-01-08  0:14   ` sergio_101
2009-01-08  6:20     ` Carsten Dominik
2009-01-08  0:39   ` Matthew Lundin
2009-01-08  1:52     ` sergio_101
2009-01-08 12:42       ` Matthew Lundin
2009-01-08  8:55   ` Giovanni Ridolfi
2009-01-08 10:42   ` Manish

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).