emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Charles Millar <millarc@verizon.net>
To: emacs-orgmode@gnu.org
Subject: Re: bug org-open-at-point zotero link
Date: Mon, 4 May 2020 17:44:40 -0400	[thread overview]
Message-ID: <d7d7c474-2760-80cc-442c-680dd5c4bc8c@verizon.net> (raw)
In-Reply-To: <2f1ba80f-de74-4f82-40a6-b1ed9434ea78@verizon.net>

Hi,

Re-posting.

Have I missed documentation that states that "org-open-at-point os not 
available for a Zotero (Zotxt) link?

On 4/10/20 9:45 AM, Charles Millar wrote:
> Hi,
> 
> Current versions
> 
> Org mode version 9.3.6 (release_9.3.6-472-g8e3b73 @ 
> /usr/local/share/org-mode/lisp/)
> GNU Emacs 28.0.50 (build 91, x86_64-pc-linux-gnu, GTK+ Version 3.24.14, 
> cairo version 1.16.0) of 2020-04-10
> 
>  From reading the documentation zotero is a valid link type and I would 
> expect that org-open-at-point, C-c C-o, would open the following link
> 
> [[zotero://select/items/1_XPZL74VM][Behr, Michael. “A Research Workflow 
> with Zotero and Org Mode.” mkbehr.com, September 19, 2015. 
> http://www.mkbehr.com/posts/a-research-workflow-with-zotero-and-org-mode/.]] 
> 
> 
> Instead I receive the following error
> 
> request-default-error-callback: http://127.0.0.1:23119/zotxt/select error
> 
> I saved the link in Zotero with a snapshot.
> 
> I can open the link using org-zotxt-open-attachement.
> 
> If, however I save the link without a snapshot,
> 
> [[zotero://select/items/1_3AH6WNKZ][“A Research Workflow with Zotero and 
> Org Mode | Mkbehr.Com.” Accessed April 10, 2020. 
> http://www.mkbehr.com/posts/a-research-workflow-with-zotero-and-org-mode/.]] 
> 
> 
> and try org-zotxt-open-attachment I receive the following error
> 
> No attachments for item!
> deferred error : (error "No attachments for item!")
> 
> If I org-open-at-point for the same link I receive
> 
> request-default-error-callback: http://127.0.0.1:23119/zotxt/select error
> 
> In the first instance is this a bug? Or is there a setting that I have 
> to add to my localhost?
> 
> In the second case is this a org-zotxt or Zotero issue?
> 
> Charlie Millar
> 
> 
> 
> 



  reply	other threads:[~2020-05-04 21:54 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <2f1ba80f-de74-4f82-40a6-b1ed9434ea78.ref@verizon.net>
2020-04-10 13:45 ` Charles Millar
2020-05-04 21:44   ` Charles Millar [this message]
2020-05-04 22:06     ` Nicolas Goaziou

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d7d7c474-2760-80cc-442c-680dd5c4bc8c@verizon.net \
    --to=millarc@verizon.net \
    --cc=emacs-orgmode@gnu.org \
    --subject='Re: bug org-open-at-point zotero link' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).