emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [PATCH] org-preview-latex-fragment dvipng fix for packages in org-latex-packages-alist breaking 'latex' command
@ 2020-09-20  0:29 flare
  2020-09-20  6:04 ` Sébastien Miquel
  0 siblings, 1 reply; 3+ messages in thread
From: flare @ 2020-09-20  0:29 UTC (permalink / raw)
  To: emacs-orgmode


[-- Attachment #1.1: Type: text/html, Size: 13063 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] org-preview-latex-fragment dvipng fix for packages in org-latex-packages-alist breaking 'latex' command
  2020-09-20  0:29 [PATCH] org-preview-latex-fragment dvipng fix for packages in org-latex-packages-alist breaking 'latex' command flare
@ 2020-09-20  6:04 ` Sébastien Miquel
  2020-12-14  6:17   ` Bastien
  0 siblings, 1 reply; 3+ messages in thread
From: Sébastien Miquel @ 2020-09-20  6:04 UTC (permalink / raw)
  To: flare, emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 824 bytes --]

Hi,

If I've understood your problem correctly, simply using ("" "fontspec" 
nil) in org-latex-packages-alist should fix your issue.

Per the documentation, this third argument stops the package from being 
used when compiling preview fragments.

Regards,

Sébastien



Gabriel S. X. Smith writes:
> This is where my fix starts to come in. When org mode does the small
>
> export of the latex fragment it would include the contents of
> org-latex-packages-alist in the LaTex headers. Some packages (namely
> 'fontspec,' used for xelatex) would lead to a failure to create the
> dvi file when the .tex file was compiled with the necessary
> 'latex' command.
>
> To alleviate this problem I designed this wrapper function which
> sets org-latex-packages-alist to nil just before executing the
> org-latex-preview function.
>

[-- Attachment #2: Type: text/html, Size: 2390 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] org-preview-latex-fragment dvipng fix for packages in org-latex-packages-alist breaking 'latex' command
  2020-09-20  6:04 ` Sébastien Miquel
@ 2020-12-14  6:17   ` Bastien
  0 siblings, 0 replies; 3+ messages in thread
From: Bastien @ 2020-12-14  6:17 UTC (permalink / raw)
  To: Sébastien Miquel; +Cc: flare, emacs-orgmode

Hi,

Sébastien Miquel <sebastien.miquel@posteo.eu> writes:

> If I've understood your problem correctly, simply using (""
> "fontspec" nil) in org-latex-packages-alist should fix your issue.

Since this conversation died, I'm closing this patch.

Feel free to resubmit it if needed.

-- 
 Bastien


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2020-12-14  6:18 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-20  0:29 [PATCH] org-preview-latex-fragment dvipng fix for packages in org-latex-packages-alist breaking 'latex' command flare
2020-09-20  6:04 ` Sébastien Miquel
2020-12-14  6:17   ` Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).