emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [PATCH] XEmacs format string needs "%%" to produce "%" on output.
@ 2008-12-21  0:49 Hugh Daschbach
  2008-12-21 11:49 ` Carsten Dominik
  0 siblings, 1 reply; 2+ messages in thread
From: Hugh Daschbach @ 2008-12-21  0:49 UTC (permalink / raw)
  To: emacs-orgmode

In XEmacs, The comment line at the top of LaTex output generated
by org-export-as-pdf doesn't contain the leading '%'.  This causes
latex to bark about "! LaTeX Error: Missing \begin{document}."

---
 lisp/org-export-latex.el |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/lisp/org-export-latex.el b/lisp/org-export-latex.el
index 9af4d0a..fa6a0e4 100644
--- a/lisp/org-export-latex.el
+++ b/lisp/org-export-latex.el
@@ -689,7 +689,7 @@ OPT-PLIST is the options plist for current buffer."
 	(author (plist-get opt-plist :author)))
     (concat
      (if (plist-get opt-plist :time-stamp-file)
-	 (format-time-string "% Created %Y-%m-%d %a %H:%M\n"))
+	 (format-time-string "%% Created %Y-%m-%d %a %H:%M\n"))
      ;; insert LaTeX custom header
      org-export-latex-header
      "\n"
-- 
1.5.6.3

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2008-12-21 11:49 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2008-12-21  0:49 [PATCH] XEmacs format string needs "%%" to produce "%" on output Hugh Daschbach
2008-12-21 11:49 ` Carsten Dominik

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).