emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org-roam broken for me
@ 2021-11-24 14:05 juh
  2021-11-24 18:06 ` Noboru
  0 siblings, 1 reply; 3+ messages in thread
From: juh @ 2021-11-24 14:05 UTC (permalink / raw)
  To: Org-mode Mailinglist

[-- Attachment #1: Type: text/plain, Size: 496 bytes --]

Dear all,

after straight-pull and rebuild today org-roam stops sync'ing the da with

Symbol's function definition is void: org-collect-keywords, skipping

I don't update org-roam every day. So I don't know which version works
for me.

Any hints?
juh
-- 
Autoren-Homepage: ......... http://literatur.hasecke.com
Satiren & Essays: ......... http://www.sudelbuch.de
Privater Blog: ............ http://www.hasecke.eu
Netzliteratur-Projekt: .... http://www.generationenprojekt.de



[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: org-roam broken for me
  2021-11-24 14:05 org-roam broken for me juh
@ 2021-11-24 18:06 ` Noboru
  2021-11-25 11:08   ` Jan Ulrich Hasecke
  0 siblings, 1 reply; 3+ messages in thread
From: Noboru @ 2021-11-24 18:06 UTC (permalink / raw)
  To: juh; +Cc: Org-mode Mailinglist


> Symbol's function definition is void: org-collect-keywords, skipping

You might need to update your Org. I guess you are on 9.3? This function is introduced with 9.4 if I remember correctly; it is prerequisite for Org-roam now. 

If Org version is not the cause, I have no other ideas.

Noboru


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: org-roam broken for me
  2021-11-24 18:06 ` Noboru
@ 2021-11-25 11:08   ` Jan Ulrich Hasecke
  0 siblings, 0 replies; 3+ messages in thread
From: Jan Ulrich Hasecke @ 2021-11-25 11:08 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 756 bytes --]

Am Wed, Nov 24, 2021 at 07:06:51PM +0100 schrieb Noboru:
> 
> > Symbol's function definition is void: org-collect-keywords, skipping
> 
> You might need to update your Org. I guess you are on 9.3? This function is introduced with 9.4 if I remember correctly; it is prerequisite for Org-roam now. 

Thanks. For an unknown reason I commented 
this line in init.el

(straight-use-package 'org)

so that the default org-mode was installed.

I don't recall when I did this.

Now I am on org-mode 9.5.1

juh

-- 
Autoren-Homepage: ......... http://literatur.hasecke.com
Satiren & Essays: ......... http://www.sudelbuch.de
Privater Blog: ............ http://www.hasecke.eu
Netzliteratur-Projekt: .... http://www.generationenprojekt.de



[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-11-25 11:09 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-11-24 14:05 org-roam broken for me juh
2021-11-24 18:06 ` Noboru
2021-11-25 11:08   ` Jan Ulrich Hasecke

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).