emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Bug: Texinfo export: Inline images are NOT rendered in INFO viewer [9.4.5 (release_9.4.5-354-g40b70c @ /home/rameshnedunchezian/src/org-mode/lisp/)]
@ 2021-04-30 10:04 Ramesh Nedunchezian
  0 siblings, 0 replies; 2+ messages in thread
From: Ramesh Nedunchezian @ 2021-04-30 10:04 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 763 bytes --]


Bug: Texinfo export: Inline images are NOT rendered in INFO viewer
[9.4.5 (release_9.4.5-354-g40b70c @ /home/rameshnedunchezian/src/org-mode/lisp/)]


1. Unzip the attached zip file.
2. C-x C-f doc/helm.org.  Note that it has inline image.
3. C-u C-h i doc/helm.info and rename the buffer. Note that it doesn't
   display the inline image.
4. C-u C-h i doc/helm-1.info and rename the buffer.  Note that it DOES
   display the inline image.

See the attached screenshot for what the above steps looks like.

(3) above is a bug.  (4) above is after applying the remedy.

You can do a

    ./helm.sh

to recreate the above texi files.  This file also has additional
observations.

TLDR: The presence of leading "./" in texi file's `@image ...'
creates the problem.

[-- Attachment #2: helm.zip --]
[-- Type: application/zip, Size: 243844 bytes --]

[-- Attachment #3: Screenshot from 2021-04-30 15-23-46.png --]
[-- Type: image/png, Size: 183146 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Bug: Texinfo export: Inline images are NOT rendered in INFO viewer [9.4.5 (release_9.4.5-354-g40b70c @ /home/rameshnedunchezian/src/org-mode/lisp/)]
       [not found] <4a08cf5b-b78f-7250-bdae-71753dacc809@outlook.com>
@ 2021-04-30 10:26 ` Ramesh Nedunchezian
  0 siblings, 0 replies; 2+ messages in thread
From: Ramesh Nedunchezian @ 2021-04-30 10:26 UTC (permalink / raw)
  To: emacs-orgmode



On 30/04/21 3:34 pm, Ramesh Nedunchezian wrote:

> 1. Unzip the attached zip file.

Forgot to remove '.git' folder in the root before zipping.  Sorry
about this.

So, when you unzip the file, and you see a bunch of git-ted files,
don't be confused.  The MWE is still in there.


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-04-30 12:11 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-30 10:04 Bug: Texinfo export: Inline images are NOT rendered in INFO viewer [9.4.5 (release_9.4.5-354-g40b70c @ /home/rameshnedunchezian/src/org-mode/lisp/)] Ramesh Nedunchezian
     [not found] <4a08cf5b-b78f-7250-bdae-71753dacc809@outlook.com>
2021-04-30 10:26 ` Ramesh Nedunchezian

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).