emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Re: inconsistent export of R results in orgmode 7.3
@ 2010-11-23 15:23 Ian Kennedy
  0 siblings, 0 replies; only message in thread
From: Ian Kennedy @ 2010-11-23 15:23 UTC (permalink / raw)
  To: emacs-orgmode


I just ran my example twice, the first time the data frame did not appear
in the (HTML) export; the second time it did. Both times the *R* session
buffer gave identical output, as follows:

> x <- 1:5
> y <- data.frame(A=x, B=round(sin(x/3.3),3))
> > y
  A     B
1 1 0.298
2 2 0.570
3 3 0.789
4 4 0.936
5 5 0.998
> >

I also took a look at the *Messages* buffer in emacs. In the first (failed)
export It left the message
executing R code block...
Starting evaluation...
Finished evaluation
result is (nil hline)

In the second (successful) export the equivalent lines were
executing R code block...
Starting evaluation...
Finished evaluation
result is (("A" "B") hline (1 0.298) (2 0.57) (3 0.789) (4 0.936) (5
0.998))

Erik Iverson wrote:
> What does your *R* session buffer look like
> when this does and does not work?  The same?

> Perhaps the prompt is getting confused at some point?

> Your example has worked 4 times in a row for me...

--Erik

Ian Kennedy wrote:
> Since upgrading to org-mode 7.3 I have had inconsistent export of R code
> block results. Sometimes the results appear in the exported document,
> sometimes they don't. I've included the simplest example I've been able
to
> come up with below. When I export this file the data frame is exported
> about half the time. The example below is about the shortest I've come up
> with that shows inconsistent export. I usually have the problem with more
> complex documents, which use R only, and  which have R read in data from
> external files.
>
> I do not have the problem if I use org-mode 7.01h. I am running emacs
23.2
> on Windows XP with R 2.12.0. My apologies if this has already been
> discussed (if it has, maybe somebody can point me to the discussion I
> missed).
>
> Here's the example:
> * Ditaa Example
>   #+BEGIN_SRC ditaa :file dit.png :width 300 :height 300  :exports
results
>     +-------------------------------+
>     |                               |
>     |            Block 1            |
>     |                               |
>     +---------------+---------------+
>                     |
>                     |
>                     v
>     +-------------------------------+
>     |                               |
>     |            Block 2            |
>     |                               |
>     +-------------------------------+
>
>   #+END_SRC
> * R example
> ** Something  in R
>
>    #+BEGIN_SRC R :session *R* :exports none
>      x <- 1:5
>      y <- data.frame(A=x, B=round(sin(x/3.3),3))
>    #+END_SRC
>
> ** A table which is often not exported
>    #+BEGIN_SRC R :session *R* :exports results :colnames yes
>      y
>    #+END_SRC
>
>
> Thanks,
> Ian
>

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2010-11-23 15:23 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-11-23 15:23 inconsistent export of R results in orgmode 7.3 Ian Kennedy

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).