emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite)
@ 2021-09-06 10:03 Elias Bounatirou
  2021-09-06 11:50 ` Bruce D'Arcus
  0 siblings, 1 reply; 10+ messages in thread
From: Elias Bounatirou @ 2021-09-06 10:03 UTC (permalink / raw)
  To: emacs-orgmode; +Cc: jkitchin

[-- Attachment #1: Type: text/plain, Size: 970 bytes --]

Hello,
I tried to insert a citation in a footnote using Org-ref-cite.
Unfortunately, when exporting to  LaTeX, the citation is ignored, i.e., it
is left out and does not appear in the LaTeX output. Is there a way to make
references appear in the footnotes or is there at least a work around? The
footnote itself in my case was created by C-c C-x f.
I am writing to the list, following John Kitchin's advice, who supposes
that the problem might be a limitation in Org-cite, see also my github
issue https://github.com/jkitchin/org-ref-cite/issues/22.
I am using Org-mode to write a book on a linguistic subject and I
absolutely (desperately!) need footnotes with references in them.
Therefore, if the functionality in question does not exist, my mail is also
a feature request to create it.
Many thanks for your help.

Elias

(org-version)
"9.4.6"
(emacs-version)
"GNU Emacs 27.2 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.20, cairo
version 1.16.0)
 of 2021-06-04"

[-- Attachment #2: Type: text/html, Size: 1218 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite)
  2021-09-06 10:03 Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite) Elias Bounatirou
@ 2021-09-06 11:50 ` Bruce D'Arcus
  2021-09-06 15:45   ` Bruce D'Arcus
  0 siblings, 1 reply; 10+ messages in thread
From: Bruce D'Arcus @ 2021-09-06 11:50 UTC (permalink / raw)
  To: Elias Bounatirou; +Cc: org-mode-email, John Kitchin

This works fine for me:

#+bibliography: test.bib
#+cite_export: biblatex verbose

Body text with a citation: [cite:@mcneill2011].

Footnote: [fn:1]

#+print_bibliography:

* Footnotes

[fn:1] A commentary, and then a citation: [cite:@low2001].

Results for the end is:

Body text with a citation: \autocite{mcneill2011}.

Footnote: \footnote{A commentary, and then a citation: \autocite{low2001}.}

On Mon, Sep 6, 2021 at 6:04 AM Elias Bounatirou
<elias.bounatirou@gmail.com> wrote:
>
> Hello,
> I tried to insert a citation in a footnote using Org-ref-cite. Unfortunately, when exporting to  LaTeX, the citation is ignored, i.e., it is left out and does not appear in the LaTeX output. Is there a way to make references appear in the footnotes or is there at least a work around? The footnote itself in my case was created by C-c C-x f.
> I am writing to the list, following John Kitchin's advice, who supposes that the problem might be a limitation in Org-cite, see also my github issue https://github.com/jkitchin/org-ref-cite/issues/22.
> I am using Org-mode to write a book on a linguistic subject and I absolutely (desperately!) need footnotes with references in them. Therefore, if the functionality in question does not exist, my mail is also a feature request to create it.
> Many thanks for your help.
>
> Elias
>
> (org-version)
> "9.4.6"
> (emacs-version)
> "GNU Emacs 27.2 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.20, cairo version 1.16.0)
>  of 2021-06-04"


^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite)
  2021-09-06 11:50 ` Bruce D'Arcus
@ 2021-09-06 15:45   ` Bruce D'Arcus
  2021-09-07  8:21     ` Elias Bounatirou
  0 siblings, 1 reply; 10+ messages in thread
From: Bruce D'Arcus @ 2021-09-06 15:45 UTC (permalink / raw)
  To: Elias Bounatirou; +Cc: org-mode-email, John Kitchin

It does seems there's a little bug with this; for in-footnote citation
outputs, but the second not.

Body text with a citation: [cite:@mcneill2011 with a suffix][fn:2].

Body text with a citation: [cite:@low2001; @mcneill2011; with a suffix][fn:3].

On Mon, Sep 6, 2021 at 7:50 AM Bruce D'Arcus <bdarcus@gmail.com> wrote:
>
> This works fine for me:
>
> #+bibliography: test.bib
> #+cite_export: biblatex verbose
>
> Body text with a citation: [cite:@mcneill2011].
>
> Footnote: [fn:1]
>
> #+print_bibliography:
>
> * Footnotes
>
> [fn:1] A commentary, and then a citation: [cite:@low2001].
>
> Results for the end is:
>
> Body text with a citation: \autocite{mcneill2011}.
>
> Footnote: \footnote{A commentary, and then a citation: \autocite{low2001}.}
>
> On Mon, Sep 6, 2021 at 6:04 AM Elias Bounatirou
> <elias.bounatirou@gmail.com> wrote:
> >
> > Hello,
> > I tried to insert a citation in a footnote using Org-ref-cite. Unfortunately, when exporting to  LaTeX, the citation is ignored, i.e., it is left out and does not appear in the LaTeX output. Is there a way to make references appear in the footnotes or is there at least a work around? The footnote itself in my case was created by C-c C-x f.
> > I am writing to the list, following John Kitchin's advice, who supposes that the problem might be a limitation in Org-cite, see also my github issue https://github.com/jkitchin/org-ref-cite/issues/22.
> > I am using Org-mode to write a book on a linguistic subject and I absolutely (desperately!) need footnotes with references in them. Therefore, if the functionality in question does not exist, my mail is also a feature request to create it.
> > Many thanks for your help.
> >
> > Elias
> >
> > (org-version)
> > "9.4.6"
> > (emacs-version)
> > "GNU Emacs 27.2 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.20, cairo version 1.16.0)
> >  of 2021-06-04"


^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite)
  2021-09-06 15:45   ` Bruce D'Arcus
@ 2021-09-07  8:21     ` Elias Bounatirou
  2021-10-03 22:23       ` Nicolas Goaziou
  0 siblings, 1 reply; 10+ messages in thread
From: Elias Bounatirou @ 2021-09-07  8:21 UTC (permalink / raw)
  To: Bruce D'Arcus; +Cc: org-mode-email, John Kitchin

[-- Attachment #1: Type: text/plain, Size: 2345 bytes --]

Just to clarify the BUG:
Citations in a footnote in the following environment are not exported to
LaTeX: when the footnote follows two or more citations, of which one has a
suffix, i.e. for instance in

Body text with a citation: [cite:@low2001; @mcneill2011 with a
suffix][fn:3].

Am Mo., 6. Sept. 2021 um 17:45 Uhr schrieb Bruce D'Arcus <bdarcus@gmail.com
>:

> It does seems there's a little bug with this; for in-footnote citation
> outputs, but the second not.
>
> Body text with a citation: [cite:@mcneill2011 with a suffix][fn:2].
>
> Body text with a citation: [cite:@low2001; @mcneill2011; with a
> suffix][fn:3].
>
> On Mon, Sep 6, 2021 at 7:50 AM Bruce D'Arcus <bdarcus@gmail.com> wrote:
> >
> > This works fine for me:
> >
> > #+bibliography: test.bib
> > #+cite_export: biblatex verbose
> >
> > Body text with a citation: [cite:@mcneill2011].
> >
> > Footnote: [fn:1]
> >
> > #+print_bibliography:
> >
> > * Footnotes
> >
> > [fn:1] A commentary, and then a citation: [cite:@low2001].
> >
> > Results for the end is:
> >
> > Body text with a citation: \autocite{mcneill2011}.
> >
> > Footnote: \footnote{A commentary, and then a citation:
> \autocite{low2001}.}
> >
> > On Mon, Sep 6, 2021 at 6:04 AM Elias Bounatirou
> > <elias.bounatirou@gmail.com> wrote:
> > >
> > > Hello,
> > > I tried to insert a citation in a footnote using Org-ref-cite.
> Unfortunately, when exporting to  LaTeX, the citation is ignored, i.e., it
> is left out and does not appear in the LaTeX output. Is there a way to make
> references appear in the footnotes or is there at least a work around? The
> footnote itself in my case was created by C-c C-x f.
> > > I am writing to the list, following John Kitchin's advice, who
> supposes that the problem might be a limitation in Org-cite, see also my
> github issue https://github.com/jkitchin/org-ref-cite/issues/22.
> > > I am using Org-mode to write a book on a linguistic subject and I
> absolutely (desperately!) need footnotes with references in them.
> Therefore, if the functionality in question does not exist, my mail is also
> a feature request to create it.
> > > Many thanks for your help.
> > >
> > > Elias
> > >
> > > (org-version)
> > > "9.4.6"
> > > (emacs-version)
> > > "GNU Emacs 27.2 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.20,
> cairo version 1.16.0)
> > >  of 2021-06-04"
>

[-- Attachment #2: Type: text/html, Size: 3215 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite)
  2021-09-07  8:21     ` Elias Bounatirou
@ 2021-10-03 22:23       ` Nicolas Goaziou
  2021-10-04 14:11         ` Bruce D'Arcus
  0 siblings, 1 reply; 10+ messages in thread
From: Nicolas Goaziou @ 2021-10-03 22:23 UTC (permalink / raw)
  To: Elias Bounatirou; +Cc: org-mode-email, Bruce D'Arcus, John Kitchin

Hello,

Elias Bounatirou <elias.bounatirou@gmail.com> writes:

> Just to clarify the BUG:
> Citations in a footnote in the following environment are not exported to
> LaTeX: when the footnote follows two or more citations, of which one has a
> suffix, i.e. for instance in
>
> Body text with a citation: [cite:@low2001; @mcneill2011 with a
> suffix][fn:3].

I cannot reproduce the problem. With the following document:

--8<---------------cut here---------------start------------->8---
#+bibliography: foo.bibtex
#+cite_export: biblatex authoryear

Body text with a citation: [cite:@foo; @bar with a suffix][fn:1].

* Footnotes

[fn:1] Test 
--8<---------------cut here---------------end--------------->8---

I get,

--8<---------------cut here---------------start------------->8---
Body text with a citation: \autocites{foo}[][with a suffix]{bar}\footnote{Test}.
--8<---------------cut here---------------end--------------->8---

If I write

--8<---------------cut here---------------start------------->8---
Body text with a citation: [cite:@foo; @bar; with a suffix][fn:1].
--8<---------------cut here---------------end--------------->8---

instead, I get

--8<---------------cut here---------------start------------->8---
Body text with a citation: \autocites(with a suffix){foo}[][]{bar}\footnote{Test}.
--8<---------------cut here---------------end--------------->8---

Both seem correct.

Regards,
-- 
Nicolas Goaziou


^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite)
  2021-10-03 22:23       ` Nicolas Goaziou
@ 2021-10-04 14:11         ` Bruce D'Arcus
  2021-10-04 14:26           ` Bruce D'Arcus
  0 siblings, 1 reply; 10+ messages in thread
From: Bruce D'Arcus @ 2021-10-04 14:11 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: org-mode-email, Elias Bounatirou

On Sun, Oct 3, 2021 at 6:23 PM Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>
> Hello,
>
> Elias Bounatirou <elias.bounatirou@gmail.com> writes:
>
> > Just to clarify the BUG:
> > Citations in a footnote in the following environment are not exported to
> > LaTeX: when the footnote follows two or more citations, of which one has a
> > suffix, i.e. for instance in
> >
> > Body text with a citation: [cite:@low2001; @mcneill2011 with a
> > suffix][fn:3].
>
> I cannot reproduce the problem. With the following document:
>
> --8<---------------cut here---------------start------------->8---
> #+bibliography: foo.bibtex
> #+cite_export: biblatex authoryear

Can you try with a note-based style like verbose?

Bruce


^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite)
  2021-10-04 14:11         ` Bruce D'Arcus
@ 2021-10-04 14:26           ` Bruce D'Arcus
  2021-10-05 21:08             ` Elias Bounatirou
  0 siblings, 1 reply; 10+ messages in thread
From: Bruce D'Arcus @ 2021-10-04 14:26 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: org-mode-email, Elias Bounatirou

On Mon, Oct 4, 2021 at 10:11 AM Bruce D'Arcus <bdarcus@gmail.com> wrote:
>
> On Sun, Oct 3, 2021 at 6:23 PM Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
> >
> > Hello,
> >
> > Elias Bounatirou <elias.bounatirou@gmail.com> writes:
> >
> > > Just to clarify the BUG:
> > > Citations in a footnote in the following environment are not exported to
> > > LaTeX: when the footnote follows two or more citations, of which one has a
> > > suffix, i.e. for instance in
> > >
> > > Body text with a citation: [cite:@low2001; @mcneill2011 with a
> > > suffix][fn:3].
> >
> > I cannot reproduce the problem. With the following document:
> >
> > --8<---------------cut here---------------start------------->8---
> > #+bibliography: foo.bibtex
> > #+cite_export: biblatex authoryear
>
> Can you try with a note-based style like verbose?

Now I'm not sure.

Input:

----
#+language: en
#+bibliography: test.bib
#+cite_export: biblatex verbose

Body text with a citation: [cite:@low2001; @mcneill2011; with a suffix][fn:1].

#+print_bibliography:

* Footnotes

[fn:1] Third commentary, and then a citation: [cite:@low2001].
---

LaTeX output:

---
Body text with a citation: \autocites(with a
suffix){low2001}[][]{mcneill2011}\relax[1].

\printbibliography



Footnotes
─────────

[1] Third commentary, and then a citation: \autocite{low2001}.
---

But the PDF leaves off the last citation, in the footnote.

Bruce


^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite)
  2021-10-04 14:26           ` Bruce D'Arcus
@ 2021-10-05 21:08             ` Elias Bounatirou
  2021-10-06 14:13               ` Nicolas Goaziou
  0 siblings, 1 reply; 10+ messages in thread
From: Elias Bounatirou @ 2021-10-05 21:08 UTC (permalink / raw)
  To: Bruce D'Arcus; +Cc: org-mode-email, Nicolas Goaziou

[-- Attachment #1: Type: text/plain, Size: 3282 bytes --]

Many thanks to Nicolas and Bruce for their mails and their help.
However, it appears Nicolas' MWE unfortunately does not  reproduce the
issue. It's not the footnote that is omitted/ not exported, it's the
citation in the footnote that is left out (when the footnote follows two or
more citations, of which one has a suffix). In Nicolas' MWE, there is no
citation in the footnote. What seems to me (being no export on LaTeX)
strange about Bruce's LaTeX output is that there is no command
\footnote{...} or the like. So is the footnote-part of the LaTeX output
real LaTeX? (Sorry for this naïve question.)

I've tested again.
With verbose I get the same erroneous result: the citation in the footnote
is not rendered (using the development version of org-mode, see below):
INPUT:

#+LANGUAGE: en
#+latex_header:\usepackage{minted}
#+bibliography_style: plain
#+cite_export: biblatex verbose
# Bibliography (bib file) specified within org-ref-cite in the init file

Body text [cite: @ravlic2021; @saric2010 with a SUFFIX][fn:1]
\printbibliography

#+begin_src emacs-lisp
(org-version)
#+end_src

#+RESULTS:
: 9.5

#+begin_src emacs-lisp
(emacs-version)
#+end_src

#+RESULTS:
: GNU Emacs 27.2 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.20, cairo
version 1.16.0)
:  of 2021-06-04

* Footnotes

[fn:1]Test [cite: @senker1987]

LaTeX OUTPUT (shortened):

Body text \autocites{ravlic2021}[][with a SUFFIX]{saric2010}\footnote{Test}


\printbibliography


As a work around I insert a zero width space before footnotes in the
context described.


Am Mo., 4. Okt. 2021 um 16:26 Uhr schrieb Bruce D'Arcus <bdarcus@gmail.com>:

> On Mon, Oct 4, 2021 at 10:11 AM Bruce D'Arcus <bdarcus@gmail.com> wrote:
> >
> > On Sun, Oct 3, 2021 at 6:23 PM Nicolas Goaziou <mail@nicolasgoaziou.fr>
> wrote:
> > >
> > > Hello,
> > >
> > > Elias Bounatirou <elias.bounatirou@gmail.com> writes:
> > >
> > > > Just to clarify the BUG:
> > > > Citations in a footnote in the following environment are not
> exported to
> > > > LaTeX: when the footnote follows two or more citations, of which one
> has a
> > > > suffix, i.e. for instance in
> > > >
> > > > Body text with a citation: [cite:@low2001; @mcneill2011 with a
> > > > suffix][fn:3].
> > >
> > > I cannot reproduce the problem. With the following document:
> > >
> > > --8<---------------cut here---------------start------------->8---
> > > #+bibliography: foo.bibtex
> > > #+cite_export: biblatex authoryear
> >
> > Can you try with a note-based style like verbose?
>
> Now I'm not sure.
>
> Input:
>
> ----
> #+language: en
> #+bibliography: test.bib
> #+cite_export: biblatex verbose
>
> Body text with a citation: [cite:@low2001; @mcneill2011; with a
> suffix][fn:1].
>
> #+print_bibliography:
>
> * Footnotes
>
> [fn:1] Third commentary, and then a citation: [cite:@low2001].
> ---
>
> LaTeX output:
>
> ---
> Body text with a citation: \autocites(with a
> suffix){low2001}[][]{mcneill2011}\relax[1].
>
> \printbibliography
>
>
>
> Footnotes
> ─────────
>
> [1] Third commentary, and then a citation: \autocite{low2001}.
> ---
>
> But the PDF leaves off the last citation, in the footnote.
>
> Bruce
>

[-- Attachment #2: Type: text/html, Size: 4313 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite)
  2021-10-05 21:08             ` Elias Bounatirou
@ 2021-10-06 14:13               ` Nicolas Goaziou
  2021-10-08 13:33                 ` Elias Bounatirou
  0 siblings, 1 reply; 10+ messages in thread
From: Nicolas Goaziou @ 2021-10-06 14:13 UTC (permalink / raw)
  To: Elias Bounatirou; +Cc: org-mode-email, Bruce D'Arcus

Hello,

Elias Bounatirou <elias.bounatirou@gmail.com> writes:

> However, it appears Nicolas' MWE unfortunately does not  reproduce the
> issue. It's not the footnote that is omitted/ not exported, it's the
> citation in the footnote that is left out (when the footnote follows two or
> more citations, of which one has a suffix). In Nicolas' MWE, there is no
> citation in the footnote. What seems to me (being no export on LaTeX)
> strange about Bruce's LaTeX output is that there is no command
> \footnote{...} or the like. So is the footnote-part of the LaTeX output
> real LaTeX? (Sorry for this naïve question.)

I noticed my ECM was not right. It took me a while to figure out the
issue.

> I've tested again.
> With verbose I get the same erroneous result: the citation in the footnote
> is not rendered (using the development version of org-mode, see below):
> INPUT:
>

[...]

> Body text [cite: @ravlic2021; @saric2010 with a SUFFIX][fn:1]

[...]

> [fn:1]Test [cite: @senker1987]
>
> LaTeX OUTPUT (shortened):
>
> Body text \autocites{ravlic2021}[][with a SUFFIX]{saric2010}\footnote{Test}

I think I fixed it. Could you confirm it?

Thank you.

Regards,
-- 
Nicolas Goaziou


^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite)
  2021-10-06 14:13               ` Nicolas Goaziou
@ 2021-10-08 13:33                 ` Elias Bounatirou
  0 siblings, 0 replies; 10+ messages in thread
From: Elias Bounatirou @ 2021-10-08 13:33 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: org-mode-email, Bruce D'Arcus

[-- Attachment #1: Type: text/plain, Size: 1503 bytes --]

 Many thanks, Nicolas !!!
I've just tested. It looks good now. I should rather say it's excellent.

Am Mi., 6. Okt. 2021 um 16:13 Uhr schrieb Nicolas Goaziou <
mail@nicolasgoaziou.fr>:

> Hello,
>
> Elias Bounatirou <elias.bounatirou@gmail.com> writes:
>
> > However, it appears Nicolas' MWE unfortunately does not  reproduce the
> > issue. It's not the footnote that is omitted/ not exported, it's the
> > citation in the footnote that is left out (when the footnote follows two
> or
> > more citations, of which one has a suffix). In Nicolas' MWE, there is no
> > citation in the footnote. What seems to me (being no export on LaTeX)
> > strange about Bruce's LaTeX output is that there is no command
> > \footnote{...} or the like. So is the footnote-part of the LaTeX output
> > real LaTeX? (Sorry for this naïve question.)
>
> I noticed my ECM was not right. It took me a while to figure out the
> issue.
>
> > I've tested again.
> > With verbose I get the same erroneous result: the citation in the
> footnote
> > is not rendered (using the development version of org-mode, see below):
> > INPUT:
> >
>
> [...]
>
> > Body text [cite: @ravlic2021; @saric2010 with a SUFFIX][fn:1]
>
> [...]
>
> > [fn:1]Test [cite: @senker1987]
> >
> > LaTeX OUTPUT (shortened):
> >
> > Body text \autocites{ravlic2021}[][with a
> SUFFIX]{saric2010}\footnote{Test}
>
> I think I fixed it. Could you confirm it?
>
> Thank you.
>
> Regards,
> --
> Nicolas Goaziou
>

[-- Attachment #2: Type: text/html, Size: 2051 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2021-10-08 13:34 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-06 10:03 Citation in footnote not expanded/exported to LaTeX (using Org-ref-cite) Elias Bounatirou
2021-09-06 11:50 ` Bruce D'Arcus
2021-09-06 15:45   ` Bruce D'Arcus
2021-09-07  8:21     ` Elias Bounatirou
2021-10-03 22:23       ` Nicolas Goaziou
2021-10-04 14:11         ` Bruce D'Arcus
2021-10-04 14:26           ` Bruce D'Arcus
2021-10-05 21:08             ` Elias Bounatirou
2021-10-06 14:13               ` Nicolas Goaziou
2021-10-08 13:33                 ` Elias Bounatirou

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).