emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Fritz Kunze <fkunze@gmail.com>
To: Mike McLean <mike.mclean@pobox.com>
Cc: Bastien <bzg@gnu.org>, emacs-orgmode@gnu.org
Subject: Re: error on opening org-file with #+startup: indent
Date: Tue, 24 Apr 2012 07:22:53 -0700	[thread overview]
Message-ID: <CAKWchL_PNrtSF-afkarKRQOo9ndim2UcMK-o3AyTj-jugViRBg@mail.gmail.com> (raw)
In-Reply-To: <933A277B-281C-40C0-B647-4616C31E67DB@pobox.com>

[-- Attachment #1: Type: text/plain, Size: 2525 bytes --]

Hi Guys,
  Thanks for trying to help  me with this.

   I re-did the installation:

     I ran M-x load-library org followed by M-x org-version - which
returned 7.8.09.
          (Incidentally, and for the sake of completeness in this report, I
built the compiled version of this upgrade by using

            M-x cd ~/.emacs.d/org-7.8.09/ followed by C-u 0 M-x

     I renamed the org-6.36 folder. I started up emacs and the error still

     Prior to the attempted upgrade, my load-path contained:
           (add-to-list 'load-path "~/.emacs.d/org-6.36/lisp")
           (add-to-list 'load-path "~/.emacs.d/org-6.36/contrib/lisp")

      And after the attempted upgrade my load-path contained:
           (add-to-list 'load-path "~/.emacs.d/org-7.8.09/lisp")
           (add-to-list 'load-path "~/.emacs.d/org-7.8.09/contrib/lisp")

As an experiment, I modified the load-path to consist only of one statement:
     (add-to-list 'load-path "~/.emacs.d/org-7.8.09/")
     ; (add-to-list 'load-path "~/.emacs.d/org-7.8.09/contrib/lisp")
And suddenly the "bug" vanished.  What's going on - do you have any idea?
 I thought I would certainly need this
directory "~/.emacs.d/org-7.8.09/contrib/lisp" in my load-path.

I also tried some of the steps listed in:
http://orgmode.org/worg/org-contrib/org-track.html    but when I execute
the command (listed there): M-x customize-variable RET org-track-directory
RET, I get the message [No Match] - so there apparently is not
org-track-directory variable (at least on windows)

Any ideas? Thanks in advance for your help.

-Fritz Kunze

On Tue, Apr 24, 2012 at 4:45 AM, Mike McLean <mike.mclean@pobox.com> wrote:

> On Apr 23, 2012, at 7:15 PM, Bastien wrote:
> > fkunze <fkunze@gmail.com> writes:
> >
> >>  When I open an org file with  #+startup: indent in the header, the
> cursor
> >> immediately goes to the bottom of the buffer and can not be moved
> upward.
> >
> > I can't reproduce this error...
> >
> >> This behavior does not occur in Org 6.36.
> >
> > ... and that's surely why.
> Actually he/she said that he had just upgraded to Org 7.8.09 (the test on
> 6.36 was his/her regression test) -- so I don't think the absolute version
> of Org is the problem.
> Fkunze - I am suspecting that you have mis-matched org-mode installs, i.e.
> pieces and parts of both. What does =M-x org-version= say when you are
> experiencing the problem?
> Can you completely clean/remove the old Org 6.36 version to ensure no
> conflict?

[-- Attachment #2: Type: text/html, Size: 4387 bytes --]

  parent reply	other threads:[~2012-04-24 14:23 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-04-22 21:21 error on opening org-file with #+startup: indent fkunze
2012-04-23 23:15 ` Bastien
2012-04-24 11:45   ` Mike McLean
2012-04-24 12:45     ` Bastien
2012-04-24 14:22     ` Fritz Kunze [this message]
2012-04-24 19:18       ` Achim Gratz
2012-04-24 21:45         ` Martyn Jago
2012-04-25 16:47           ` Achim Gratz
2012-04-25 18:56             ` Achim Gratz
2012-04-25 21:01           ` fkunze
2012-04-25  1:41         ` Mike McLean
2012-04-25 21:29           ` fkunze
2012-04-25 20:53         ` fkunze
2012-04-26  4:29           ` Achim Gratz
2012-04-26  7:03           ` Bastien
2012-04-26 17:08             ` fkunze
2012-04-27 21:31               ` Bastien

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAKWchL_PNrtSF-afkarKRQOo9ndim2UcMK-o3AyTj-jugViRBg@mail.gmail.com \
    --to=fkunze@gmail.com \
    --cc=bzg@gnu.org \
    --cc=emacs-orgmode@gnu.org \
    --cc=mike.mclean@pobox.com \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).