emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Jonathan Leech-Pepin <jonathan.leechpepin@gmail.com>
To: John Hendy <jw.hendy@gmail.com>
Cc: bjvilfan@gmail.com, emacs-orgmode@gnu.org,
	Bostjan Vilfan <bostjanv@alum.mit.edu>
Subject: Re: makefile for v. 7.9.1 on Windows 7 doesn't work
Date: Fri, 7 Sep 2012 09:32:38 -0400	[thread overview]
Message-ID: <CAHRqSkR2zEONA-VftLYseGJ8-RckncS_S3vkcEaTwW-Eau-83g@mail.gmail.com> (raw)
In-Reply-To: <CA+M2ft84SvpsP+fAr4dnndJ+xBK5H4RrnphVkVfGV_1EspxPqg@mail.gmail.com>

Hello,

On Fri, Sep 7, 2012 at 9:05 AM, John Hendy <jw.hendy@gmail.com> wrote:
> On Fri, Sep 7, 2012 at 7:45 AM, Jonathan Leech-Pepin
> <jonathan.leechpepin@gmail.com> wrote:
>> Hello,
>>
>> On Fri, Sep 7, 2012 at 8:33 AM, John Hendy <jw.hendy@gmail.com> wrote:
>>> On Fri, Sep 7, 2012 at 2:13 AM, Bostjan Vilfan <bostjanv@alum.mit.edu> wrote:
>>>> Hello,
>>>> I notice that the makefile in version 7.9.1 has been changed (with regard to v. 7.8.11). When I tried to run it under Windows7, it didn't work (the makefile for 7.8.11 ran OK). Can anyone provide some information?
>>>
>>> Can you provide more information? The error, what you were doing, etc?
>>> The last time I git pulled perhaps a week or so ago, I tried following
>>> Worg like so:[1]
>>> ,---
>>> | emacs -batch -Q -L lisp -l ../UTILITIES/org-fixup -f
>>> org-make-autoloads-compile
>>> `---
>>>
>>> It failed. I inspected the dit directory and noticed that it's  not
>>> ../UTILITIES anymore; all of the make stuff is in ../mk. Could that be
>>> the problem if you're following Worg?
>>>
>>
>> If the problem is related to the missing =UTILITIES= directory, the
>> solution would seem to be just re-run the update.  I had that issue on
>> several machines, all of which complained the first time about the
>> missing =UTILITIES= directory and then ran successfullly on the
>> subsequent updates.
>
> Can someone else confirm? I'm just pulled again and have no UTILITIES dir.
>

=UTILITIES/= was renamed =util/=, and then has since been moved to
=mk/=.  The results I had seen seemed to indicate that it couldn't
find a script in UTILITIES/ so it could not continue (because it had
been renamed but was being looked for in the old location).

Running it a second time simply removed the confusion as to the
location of the files and permitted the update to continue without
issues.

> John
>
>>
>>> As an aside, I just tried re-compiling to check and I noticed that if
>>> I follow Worg and cd into /path/to/org.git/mk and then run =emace
>>> -batch ... ../mk/org-fixup.el ...=, I get the error:
>>> ,---
>>> | Symbol's function definition is void: org-find-library-dir
>>> `---
>>>
>>> If I cd to /path/to/org.git and run the command with only one perios
>>> (=emacs ... ./mk/org-fixup.el ...=), then it works. But =M-x
>>> org-version= spits out something related to org-fixup and isn't a real
>>> version number.
>>>
>>> In any case, I can still compile as far as I know. Sorry if this
>>> wasn't your issue, but with the lack of details no one will be able to
>>> help you diagnose the problem.
>>>
>>>
>>> Best regards,
>>> John
>>>
>>> [1] http://orgmode.org/worg/org-hacks.html#compiling-org-without-make
>>>
>>>> Regards,
>>>> bostjanv

Regards,

--
Jon

  parent reply	other threads:[~2012-09-07 13:32 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-09-07  7:13 makefile for v. 7.9.1 on Windows 7 doesn't work Bostjan Vilfan
2012-09-07 12:33 ` John Hendy
2012-09-07 12:45   ` Jonathan Leech-Pepin
2012-09-07 13:05     ` John Hendy
2012-09-07 13:14       ` Bastien
2012-09-07 13:27         ` John Hendy
2012-09-07 13:32       ` Jonathan Leech-Pepin [this message]
2012-09-07 19:00   ` Achim Gratz
2012-09-10 17:59     ` John Hendy
2012-09-10 19:24       ` Achim Gratz
2012-09-10 19:48         ` John Hendy
2012-09-10 19:58           ` Achim Gratz
2012-09-10 20:01           ` Nick Dokos
2012-09-07 16:42 Bostjan Vilfan
2012-09-08  6:56 ` Bastien

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAHRqSkR2zEONA-VftLYseGJ8-RckncS_S3vkcEaTwW-Eau-83g@mail.gmail.com \
    --to=jonathan.leechpepin@gmail.com \
    --cc=bjvilfan@gmail.com \
    --cc=bostjanv@alum.mit.edu \
    --cc=emacs-orgmode@gnu.org \
    --cc=jw.hendy@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).