emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Problems syncing from MobileOrg 0.8.5 (Android) via SD card
@ 2012-04-04 22:28 Brian van den Broek
  0 siblings, 0 replies; only message in thread
From: Brian van den Broek @ 2012-04-04 22:28 UTC (permalink / raw)
  To: emacs-orgmode

Hi all,

I have an Android phone and I am taking another go at setting up
MobileOrg for android (the matburt version at
<https://github.com/matburt/mobileorg-android> and

I don't want to use dropbox and at present cannot set up my own SSH or
WebDAV server; I'm happy to use the SD card for syncing.

Following the directions at
https://github.com/matburt/mobileorg-android/wiki/Documentation I have
the desired org files on my desktop syncing to MobileOrg on the phone
just fine. I also have items syncing with my phone's calendar. This is
all most excellent.

I have created some captured items with MobileOrg, have used it to
change the TODO state of extant items, and have created new child
nodes with it, too. (So, I've been able to create changes on the phone
in multiple ways that I would expect to be brought over to the desktop
by syncing.) However, when I mount the phone's SD card and run M-x
org-mobile-pull, I get the message "No new items."

As far as I can figure out, I've done what I ought to do to bring
changes from MobileOrg to my desktop. I by no means, however, exclude
the possibility that I am doing something daft. Any pointers for how I
can further investigate the issue?

Some relevant details:

My phone is a Samsung GT-B7510 running Android 2.2.2. I have MobileOrg
version 0.8.5 installed.

M-x emacs-version yields: GNU Emacs 23.2.1 (x86_64-pc-linux-gnu, GTK+
Version 2.20.1) of 2010-12-11 on brahms, modified by Debian
M-x org-version yields: Org-mode version 7.8.08

My .emacs contains the following:
(setq org-mobile-inbox-for-pull "/home/brian/docs/org/from-mobile.org")
(setq org-mobile-directory "/media/ANDROIDSD/mobileorg")

All other values revealed by M-x customize-group org-mobile are at
their default settings.

Relevant MobileOrg settings on the phone are:
Synchronizarion Mode: SDCard
Index Path: /sdcard/mobileorg/index.org
Background Sync is disabled

I have tried running org-mobile-pull both with and without an empty
file /home/brian/docs/org/from-mobile.org (with read and write
permissions) present. I have also tried with a filename lacking the
`-' character.

For sake of completeness, I did try enabling background sync and
waiting for it to run before mounting the SD card and running M-x

One other possibly relevant fact: I've put the MobilOrg TODO widget on
my phone's desktop. On rebooting the phone, it displays something like
`Widget text' (it flashes by pretty quick), and otherwise never
displays anything. Clicking on it serves only to take me directly to
the MobileOrg capture interface.

Thanks for any suggestions,

Brian vdB

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2012-04-04 22:29 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-04-04 22:28 Problems syncing from MobileOrg 0.8.5 (Android) via SD card Brian van den Broek

Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).