emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Unable to install from elpa
@ 2021-11-13  5:39 Carlos Pita
  2021-11-13  6:11 ` Carlos Pita
  0 siblings, 1 reply; 2+ messages in thread
From: Carlos Pita @ 2021-11-13  5:39 UTC (permalink / raw)
  To: emacs-orgmode

Hi all,

in a clean emacs-28 install I do:

    M-x package-install <Enter> org<Enter>

I get:

    Possible completions are:
        org-contrib org-edna org-real org-translate orgalist

package-archives has:

    (("gnu" . "https://elpa.gnu.org/packages/")
     ("nongnu" . "https://elpa.nongnu.org/nongnu/"))

I do list-packages, org is now listed as available in gnu archive, I
install it from there, relaunch emacs (again with -Q), do
(package-initialize) and:

- check org-version: it's still the builtin one.

- check load-path: doesn't include my ~/.emacs.d/elpa/org-9.5
directory (although it exists and installing other packages works as
expected)

So many things are not working properly:

1. I'm unable to install org using package-install.

2. I can install it from the package list but then it's not added to load-path.

3. Of course the builtin version gets loaded instead of the elpa one.

All this is in a recent build from emacs-28 with default configure
options (including native compilation).

Best regards,
Carlos


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-11-13  6:12 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-11-13  5:39 Unable to install from elpa Carlos Pita
2021-11-13  6:11 ` Carlos Pita

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).