emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Beamer export: can't get frame level right
@ 2014-07-12 12:50 Gabor Retvari
  2014-07-14 15:29 ` Josiah Schwab
  0 siblings, 1 reply; 8+ messages in thread
From: Gabor Retvari @ 2014-07-12 12:50 UTC (permalink / raw)
  To: emacs-orgmode

Hi,

I guess this should be easy but I just can't get frame levels right in my 
beamer exports. 

So as far as I understand, this should get my first level headlines (`* 
headline 1' and stuff) into separate frames in my beamer export.

=== ORG MODE TEXT: ===

#+LaTeX_CLASS: beamer
#+LaTeX_CLASS_OPTIONS: [presentation,bigger]
#+OPTIONS: H:1

* headline 1

- stuff

- stuff too

* headline 2

- list 1

- list 2

- ...

* headline 3

- no stuff

I expected the headlines top level headlines (`* headline 1'...) to appear 
inside separate `\begin{frame}...\end{frame}' environments.  Problem is that 
they do not, intead every headline goes into LaTeX `\section' sections.

=== LATEX EXPORT: ===
\documentclass[presentation,bigger]{beamer}
[..]

\section{headline 1}
\label{sec-1}

\begin{itemize}
\item stuff

\item stuff too
\end{itemize}

\section{headline 2}
\label{sec-2}

\begin{itemize}
\item list 1

\item list 2

\item \ldots{}
\end{itemize}

\section{headline 3}
\label{sec-3}

\begin{itemize}
\item no stuff
\end{itemize}
% Emacs 24.3.1 (Org mode 8.2.7b)
\end{document}

No `OPTIONS: H:n' setting seems to solve this problem. So how do I get this 
right? 

This is Org mode 8.2.7b by the way, as of the `org-mode' package version 
8.2.7b-1 in Debian testing.

Thanks a lot,
Gabor

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Beamer export: can't get frame level right
  2014-07-12 12:50 Beamer export: can't get frame level right Gabor Retvari
@ 2014-07-14 15:29 ` Josiah Schwab
  2014-07-14 18:38   ` John Hendy
  2014-07-16  9:58   ` Gabor Retvari
  0 siblings, 2 replies; 8+ messages in thread
From: Josiah Schwab @ 2014-07-14 15:29 UTC (permalink / raw)
  To: Gabor Retvari; +Cc: emacs-orgmode

Hi Gabor,

> I guess this should be easy but I just can't get frame levels right in my 
> beamer exports. 
>
> So as far as I understand, this should get my first level headlines (`* 
> headline 1' and stuff) into separate frames in my beamer export.
>
> ... snipped 61 lines ...
>
> No `OPTIONS: H:n' setting seems to solve this problem. So how do I get this 
> right? 

Which export command are you using?

I think you may be using the regular LaTeX exporter.  Adding beamer to
your LaTeX_CLASS is not sufficient (or necessary).  Rather, you want to
use the Beamer export commands.

http://orgmode.org/manual/Beamer-export.html

Hope that helps,
Josiah

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Beamer export: can't get frame level right
  2014-07-14 15:29 ` Josiah Schwab
@ 2014-07-14 18:38   ` John Hendy
  2014-07-16  9:58   ` Gabor Retvari
  1 sibling, 0 replies; 8+ messages in thread
From: John Hendy @ 2014-07-14 18:38 UTC (permalink / raw)
  To: Josiah Schwab; +Cc: emacs-orgmode, Gabor Retvari

[-- Attachment #1: Type: text/plain, Size: 1024 bytes --]

On Mon, Jul 14, 2014 at 10:29 AM, Josiah Schwab <jschwab@gmail.com> wrote:
> Hi Gabor,
>
>> I guess this should be easy but I just can't get frame levels right in my
>> beamer exports.
>>
>> So as far as I understand, this should get my first level headlines (`*
>> headline 1' and stuff) into separate frames in my beamer export.
>>
>> ... snipped 61 lines ...
>>
>> No `OPTIONS: H:n' setting seems to solve this problem. So how do I get this
>> right?
>
> Which export command are you using?
>
> I think you may be using the regular LaTeX exporter.  Adding beamer to
> your LaTeX_CLASS is not sufficient (or necessary).  Rather, you want to
> use the Beamer export commands.

Tend to agree. Make sure you're doing C-c C-e l P (capital P).

Attached my result of running your example, which I think is what
you're looking for?

John

P.S. Don't feel bad. I've done the exact same thing multiple times
wondering what the hell was going on :)

>
> http://orgmode.org/manual/Beamer-export.html
>
> Hope that helps,
> Josiah
>

[-- Attachment #2: test.pdf --]
[-- Type: application/pdf, Size: 31663 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Beamer export: can't get frame level right
  2014-07-14 15:29 ` Josiah Schwab
  2014-07-14 18:38   ` John Hendy
@ 2014-07-16  9:58   ` Gabor Retvari
  2014-07-16 14:45     ` Josiah Schwab
  2014-07-16 14:54     ` John Hendy
  1 sibling, 2 replies; 8+ messages in thread
From: Gabor Retvari @ 2014-07-16  9:58 UTC (permalink / raw)
  To: Josiah Schwab; +Cc: emacs-orgmode

Hi,

On Monday 14 July 2014 08:29:40 Josiah Schwab wrote:
> Which export command are you using?
> 
> I think you may be using the regular LaTeX exporter.  Adding beamer to
> your LaTeX_CLASS is not sufficient (or necessary).  Rather, you want to
> use the Beamer export commands.
> 
> http://orgmode.org/manual/Beamer-export.html

Thanks a lot, org-beamer-export-to-pdf seems to solve this issue. 

Interestingly, C-c C-e l P (thank you John for the tip) does not work by 
default as org-export-dispatch does not seem to know about beamer specific 
export commands initially. Only after running org-beamer-export-to-pdf once the 
beamer specific export options show up in the dispatcher's list. Strange.

Anyways, it would be nice to have this behavior better documented. Maybe a huge 
warning in the tutorial saying "Use beamer export options, standard LaTeX 
export will screw up your slide structure!" or somesuch. I see now that the 
tutorial mentions that "tutorials and references available for both org-mode 
itself, for LaTeX exporting, and for Beamer Class Export", but the link to the 
"Beamer Class Export" document does not quite work.

http://orgmode.org/worg/exporters/beamer/tutorial.html

Again, thank you for the help, it really is appreciated.

Regards,
Gabor

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Beamer export: can't get frame level right
  2014-07-16  9:58   ` Gabor Retvari
@ 2014-07-16 14:45     ` Josiah Schwab
  2014-07-16 14:54     ` John Hendy
  1 sibling, 0 replies; 8+ messages in thread
From: Josiah Schwab @ 2014-07-16 14:45 UTC (permalink / raw)
  To: Gabor Retvari; +Cc: emacs-orgmode


On 16 July 2014 at 02:58 PDT, Gabor Retvari wrote:

>> I think you may be using the regular LaTeX exporter.  Adding beamer to
>> your LaTeX_CLASS is not sufficient (or necessary).  Rather, you want to
>> use the Beamer export commands.
>> 
>> http://orgmode.org/manual/Beamer-export.html
>
> Thanks a lot, org-beamer-export-to-pdf seems to solve this issue. 
>
> Interestingly, C-c C-e l P (thank you John for the tip) does not work by 
> default as org-export-dispatch does not seem to know about beamer specific 
> export commands initially. Only after running org-beamer-export-to-pdf once the 
> beamer specific export options show up in the dispatcher's
> list. Strange.

Not all exporters are loaded by default.
http://orgmode.org/manual/Export-back_002dends.html#Export-back_002dends

Have you done something like

,----
| (require 'ox-beamer)
`----

in your .emacs?  Or customized  `org-export-backends' ?


> Anyways, it would be nice to have this behavior better documented. Maybe a huge 
> warning in the tutorial saying "Use beamer export options, standard LaTeX 
> export will screw up your slide structure!" or somesuch. I see now that the 
> tutorial mentions that "tutorials and references available for both org-mode 
> itself, for LaTeX exporting, and for Beamer Class Export", but the link to the 
> "Beamer Class Export" document does not quite work.
>
> http://orgmode.org/worg/exporters/beamer/tutorial.html

I have fixed the link you mention.

Best,
Josiah

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Beamer export: can't get frame level right
  2014-07-16  9:58   ` Gabor Retvari
  2014-07-16 14:45     ` Josiah Schwab
@ 2014-07-16 14:54     ` John Hendy
  2014-07-18 11:56       ` Gabor Retvari
  1 sibling, 1 reply; 8+ messages in thread
From: John Hendy @ 2014-07-16 14:54 UTC (permalink / raw)
  To: Gabor Retvari; +Cc: Josiah Schwab, emacs-orgmode

On Wed, Jul 16, 2014 at 4:58 AM, Gabor Retvari <retvari@tmit.bme.hu> wrote:
> Hi,
>
> On Monday 14 July 2014 08:29:40 Josiah Schwab wrote:
>> Which export command are you using?
>>
>> I think you may be using the regular LaTeX exporter.  Adding beamer to
>> your LaTeX_CLASS is not sufficient (or necessary).  Rather, you want to
>> use the Beamer export commands.
>>
>> http://orgmode.org/manual/Beamer-export.html
>
> Thanks a lot, org-beamer-export-to-pdf seems to solve this issue.
>
> Interestingly, C-c C-e l P (thank you John for the tip) does not work by
> default as org-export-dispatch does not seem to know about beamer specific
> export commands initially. Only after running org-beamer-export-to-pdf once the
> beamer specific export options show up in the dispatcher's list. Strange.
>
> Anyways, it would be nice to have this behavior better documented. Maybe a huge
> warning in the tutorial saying "Use beamer export options, standard LaTeX
> export will screw up your slide structure!" or somesuch. I see now that the
> tutorial mentions that "tutorials and references available for both org-mode
> itself, for LaTeX exporting, and for Beamer Class Export", but the link to the
> "Beamer Class Export" document does not quite work.
>
> http://orgmode.org/worg/exporters/beamer/tutorial.html

Sorry... looks like a by-product of still being pretty recent on the
new export engine and thus we have some instances of both new/old
instruction sets being out there in the wild. Can you see if this
works properly?
- http://orgmode.org/worg/exporters/beamer/ox-beamer.html

Aka, simply having this in .emacs:

(require 'ox-latex)
(add-to-list 'org-latex-classes
             '("beamer"
               "\\documentclass\[presentation\]\{beamer\}"
               ("\\section\{%s\}" . "\\section*\{%s\}")
               ("\\subsection\{%s\}" . "\\subsection*\{%s\}")
               ("\\subsubsection\{%s\}" . "\\subsubsection*\{%s\}")))


Good luck,
John


> Again, thank you for the help, it really is appreciated.
>
> Regards,
> Gabor
>
>

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Beamer export: can't get frame level right
  2014-07-16 14:54     ` John Hendy
@ 2014-07-18 11:56       ` Gabor Retvari
  2014-07-18 14:19         ` John Hendy
  0 siblings, 1 reply; 8+ messages in thread
From: Gabor Retvari @ 2014-07-18 11:56 UTC (permalink / raw)
  To: John Hendy; +Cc: Josiah Schwab, emacs-orgmode

Hi,

On Wednesday 16 July 2014 09:54:13 John Hendy wrote:
> Can you see if this works properly?
> - http://orgmode.org/worg/exporters/beamer/ox-beamer.html
> 
> Aka, simply having this in .emacs:
> 
> (require 'ox-latex)
> (add-to-list 'org-latex-classes
>              '("beamer"
>                "\\documentclass\[presentation\]\{beamer\}"
>                ("\\section\{%s\}" . "\\section*\{%s\}")
>                ("\\subsection\{%s\}" . "\\subsection*\{%s\}")
>                ("\\subsubsection\{%s\}" . "\\subsubsection*\{%s\}")))

No, this does not seem to be enough for the beamer-specific export options to 
show up with org-export-dispatch. This, however, is OK (by Josiah's 
suggestion):

(require 'ox-beamer)

Regards,
Gabor

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Beamer export: can't get frame level right
  2014-07-18 11:56       ` Gabor Retvari
@ 2014-07-18 14:19         ` John Hendy
  0 siblings, 0 replies; 8+ messages in thread
From: John Hendy @ 2014-07-18 14:19 UTC (permalink / raw)
  To: Gabor Retvari; +Cc: Josiah Schwab, emacs-orgmode

On Fri, Jul 18, 2014 at 6:56 AM, Gabor Retvari <retvari@tmit.bme.hu> wrote:
> Hi,
>
> On Wednesday 16 July 2014 09:54:13 John Hendy wrote:
>> Can you see if this works properly?
>> - http://orgmode.org/worg/exporters/beamer/ox-beamer.html
>>
>> Aka, simply having this in .emacs:
>>
>> (require 'ox-latex)
>> (add-to-list 'org-latex-classes
>>              '("beamer"
>>                "\\documentclass\[presentation\]\{beamer\}"
>>                ("\\section\{%s\}" . "\\section*\{%s\}")
>>                ("\\subsection\{%s\}" . "\\subsection*\{%s\}")
>>                ("\\subsubsection\{%s\}" . "\\subsubsection*\{%s\}")))
>
> No, this does not seem to be enough for the beamer-specific export options to
> show up with org-export-dispatch. This, however, is OK (by Josiah's
> suggestion):
>
> (require 'ox-beamer)
>

Oops. Yes, you're completely correct and I missed that. Right before
the beamer definition I pasted above above, Worg says:

"You can use the following minimal setup to start exporting to the
beamer documentclass. As of the latest Org mode version (8.0.3), this
setup is not necessary anymore. If you want to customise this
variable, you should **do it before loading ox-beamer.**"

So, Worg mentions loading ox-beamer (not sure why it's not right after
the definition to make it clear...), but I was also wrong again. If
your version is recent enough, you also don't need that definition,
just to require ox-beamer (which is, indeed, in my setup).


Sorry about that!
John

> Regards,
> Gabor

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2014-07-18 14:19 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-07-12 12:50 Beamer export: can't get frame level right Gabor Retvari
2014-07-14 15:29 ` Josiah Schwab
2014-07-14 18:38   ` John Hendy
2014-07-16  9:58   ` Gabor Retvari
2014-07-16 14:45     ` Josiah Schwab
2014-07-16 14:54     ` John Hendy
2014-07-18 11:56       ` Gabor Retvari
2014-07-18 14:19         ` John Hendy

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).