emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: John Hendy <jw.hendy@gmail.com>
To: "Julian M. Burgos" <julian@hafro.is>
Cc: emacs-orgmode <emacs-orgmode@gnu.org>
Subject: Re: Saving within a source code block... a bug?
Date: Mon, 22 Apr 2013 10:55:35 -0500	[thread overview]
Message-ID: <CA+M2ft8CaMh03fSni6+VV_WZ50j67jHXrq47r1sjkyofw7KYTQ@mail.gmail.com> (raw)
In-Reply-To: <xgzy5cafucp.fsf@hafnfirdingur.hafro.is>

On Mon, Apr 22, 2013 at 10:39 AM, Julian M. Burgos <julian@hafro.is> wrote:
>
> Hello fellow "org-moders":
>
> I just switch to org-mode 8.0.1 and noticed a regression to a
> missbehaviour (a bug?) that happened at some point in a previous version and
> was later fixed.  This is the issue: I am working in an org-mode file
> with R code blocks, and I do C-c' to edit one of them.  I do some
> changes, and press C-s to save the changes.  At this point, I get a
> request to choose a file to save the changes into (this should not
> happen, the changes should just be saved into my org file).  Then I
> choose a file name, press RET, and the filename is not created, but
> instead the changes are saved into my org mode file.  Then, if I do more
> changes and do C-s save again, now org-mode behaves the way it should: I
> do not get asked for a filename and the changes are saved in my org mode
> file.

Do you have any special settings regarding key bindings? I've not used
this, but tried to reproduce with a simple example in a file I was
already working on. Here was my block:

#+begin_src R :session r :results output :exports results

  a <- 1 + 2
  a

#+end_src

- Edit with =C-c '= (single quote, not backtick like I first tried as
I edit tables this way!)
- Code is highlighted in original buffer in yellow; new buffer opens
with contents
- Add line =b <- 3 + 4=
- C-x C-s to save, minibuffer reports that it's saving/wrote my file
- The additional line above appears in file
- =C-c '= to close minibuffer

I can't reproduce. C-s, for me, is bound to isearch-forward.

Org-mode version 8.0 (release_8.0-2-g77476c)

Thought I'd see if this was release dependent, so I pulled and did
=make clean && make && make doc= just now and I get the same
[successful]  behavior.

Org-mode version 8.0.1 (release_8.0.1-14-g2e6769)


Best regards,
John


> Hopefully this is clear.  Let me know if you have questions.
> Thanks!!
>
> Julian
>
> --
> Julian Mariano Burgos, PhD
> Hafrannsóknastofnunin/Marine Research Institute
> Skúlagata 4, 121 Reykjavík, Iceland
> Sími/Telephone : +354-5752037
> Bréfsími/Telefax:  +354-5752001
> Netfang/Email: julian@hafro.is
>

  reply	other threads:[~2013-04-22 15:55 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-04-22 15:39 Julian M. Burgos
2013-04-22 15:55 ` John Hendy [this message]
2013-04-23  8:54   ` Julian M. Burgos

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CA+M2ft8CaMh03fSni6+VV_WZ50j67jHXrq47r1sjkyofw7KYTQ@mail.gmail.com \
    --to=jw.hendy@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --cc=julian@hafro.is \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).