emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: John Hendy <jw.hendy@gmail.com>
To: emacs-orgmode <emacs-orgmode@gnu.org>
Subject: Re: Problem with babel and R + lattice
Date: Thu, 8 Mar 2012 14:52:41 -0600	[thread overview]
Message-ID: <CA+M2ft-BQhpCRQ2f6MOd0rDGkyvm+thu8rx53QsEitAdUxYOFg@mail.gmail.com> (raw)
In-Reply-To: <CA+M2ft8KhDNWsA5CyyrtZFrcC0nENXbo+5u30QyWDBOc8crwZg@mail.gmail.com>

Drat. I meant to add that when I run the code exactly as I have it
from R directly, it works. I literally copy and paste my org-mode
babel block code line by line into a terminal and obtain the proper
output via tikz. *That's* the perplexing part. What would be working
directly from R and not from Org-mode?

For reference, I've generated plenty of stuff just like this via
org-mode/babel. Come to think of it, even another lattice plot.

Not sure how to pinpoint what's goofy about this specific plot.

John

On Thu, Mar 8, 2012 at 2:40 PM, John Hendy <jw.hendy@gmail.com> wrote:
> I have an R block like so:
>
> #+begin_src R
>
> library(lattice)
> library(tikzDevice)
>
> =bunch of code=
>
> barchart(side$name~side$x2,groups=side$type,horiz=T,
>         xlim=c(0,0.75),col=c("lightblue","yellow"),xlab="Product
> Performance (2-box)")
>
> dev.off()
> tools::texi2dvi("bar-2b.tex",pdf=T)
>
> #+end_src
>
> The resultant tex file is empty where the tikz code should be and
> texi2dvi fails. Any suggestions? If I change my plot to base graphics
> with barplot, it works. I'm thinking this is a lattice/babel issue?
>
>
> Thanks for any input,
> John

  reply	other threads:[~2012-03-08 20:52 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-03-08 20:40 John Hendy
2012-03-08 20:52 ` John Hendy [this message]
2012-03-09  8:41   ` Rainer M Krug
2012-03-09 14:04     ` John Hendy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CA+M2ft-BQhpCRQ2f6MOd0rDGkyvm+thu8rx53QsEitAdUxYOFg@mail.gmail.com \
    --to=jw.hendy@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --subject='Re: Problem with babel and R + lattice' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).