emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* htmlize doesn't work in --batch mode
@ 2012-09-14  9:38 Dmitri Makarov
  2012-09-19 17:03 ` Bastien
  0 siblings, 1 reply; 5+ messages in thread
From: Dmitri Makarov @ 2012-09-14  9:38 UTC (permalink / raw)
  To: emacs-orgmode

If anyone interested, it's easy to explicitly load the required ELPA packages in batch mode.  For example, the following command loads htmlize for publishing org files in batch mode

emacs --batch -l ~/.emacs.d/init.el --eval "(progn (add-to-list 'load-path \"~/.emacs.d/elpa/htmlize-20120616.1716\") (require 'htmlize))" -f org-publish-all

It should be easy to include such a command in a makefile or build.xml and automatically locate the latest installation of necessary packages rather than explicitly specifying the path.

Still I wonder why ELPA packages are not loaded by default in --batch mode even though (package-initialize) is being evaluated.



^ permalink raw reply	[flat|nested] 5+ messages in thread
* htmlize doesn't work in --batch mode
@ 2012-09-11 13:16 Dmitri Makarov
  0 siblings, 0 replies; 5+ messages in thread
From: Dmitri Makarov @ 2012-09-11 13:16 UTC (permalink / raw)
  To: emacs-orgmode

Hi all,

I'm having a problem with offline exports.
If I run emacs in --batch mode like this

emacs -batch -l ~/.emacs.d/init.el -eval '(org-publish-all)'

it doesn't seem to load the packages installed by the ELPA package manager.
In particular it doesn't load htmlize package and also loads the bundled org
version 7.8.11 whereas I have newer version 7.9.1 installed in packages.

Also, it seems for the new version of org to take over the bundled org
package when I run emacs in normal window mode I have to invoke
(require 'org-install) from after-init-hook like this

(add-hook 'after-init-hook
          (lambda ()
            (load-file "~/.emacs.d/org.el")))

org.el among other things includes (require 'org-install)

If I place (require 'org-install) directly in my init.el,
emacs loads the org package bundled with the emacs installation,
not the one installed by the package manager, probably because
package-initialize is evaluated after init.el has been loaded.

Is this normal?  Did anyone have the same problem?
My emacs version is GNU Emacs 24.2.1.

I hope my questions make sense, as I don't really have much experience with emacs package management, and it seems difficult to describe the problem clearly.
I apologize for this is not being an org-mode question, but since many org users
use htmlize, I figure some of them probably want to export their org files
in batch mode, and perhaps they've faced the same issues with packages
in batch mode that I'm having.



^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2012-09-19 18:41 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-09-14  9:38 htmlize doesn't work in --batch mode Dmitri Makarov
2012-09-19 17:03 ` Bastien
2012-09-19 18:29   ` Achim Gratz
2012-09-19 18:40   ` Dmitri Makarov
  -- strict thread matches above, loose matches on Subject: below --
2012-09-11 13:16 Dmitri Makarov

Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).