emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [BUG] LaTeX Export hangs
@ 2009-01-08 12:30 Christian Egli
  2009-01-08 13:26 ` Carsten Dominik
  0 siblings, 1 reply; 4+ messages in thread
From: Christian Egli @ 2009-01-08 12:30 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 654 bytes --]

Hi

I have the latest git repo from a few minutes ago and I use the attached
test file. When I do C-c C-e l Emacs sits there saying "Exporting to
LaTeX...". I have to stop it with C-g. The debugger tells me the
following:

Debugger entered--Lisp error: (quit)
  replace-match("\\\\texttt{}" t)
  org-export-latex-keywords()
  org-export-latex-content(#("\n" 0 1 (fontified nil)))
  org-export-latex-first-lines(nil)
  org-export-as-latex(nil)
  call-interactively(org-export-as-latex)
  org-export(nil)
  call-interactively(org-export nil nil)

If I first do a export as html (C-c C-e h) followed by a export to LaTeX
(C-c C-e l) it works like a charm.


[-- Attachment #2: Test org file --]
[-- Type: text/plain, Size: 132 bytes --]

#+OPTIONS:   ^:nil TeX:nil toc:nil

* Title
** Subtitle
[[http://wiki.dspace.org/index.php/Configure_media_filters][media filters]]

[-- Attachment #3: Type: text/plain, Size: 204 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [BUG] LaTeX Export hangs
  2009-01-08 12:30 [BUG] LaTeX Export hangs Christian Egli
@ 2009-01-08 13:26 ` Carsten Dominik
  2009-01-08 13:45   ` Christian Egli
  0 siblings, 1 reply; 4+ messages in thread
From: Carsten Dominik @ 2009-01-08 13:26 UTC (permalink / raw)
  To: Christian Egli; +Cc: emacs-orgmode

Fixed, thanks.

I think this must also have been Sergio's bug.....

- Carsten

On Jan 8, 2009, at 1:30 PM, Christian Egli wrote:

> Hi
>
> I have the latest git repo from a few minutes ago and I use the  
> attached
> test file. When I do C-c C-e l Emacs sits there saying "Exporting to
> LaTeX...". I have to stop it with C-g. The debugger tells me the
> following:
>
> Debugger entered--Lisp error: (quit)
>  replace-match("\\\\texttt{}" t)
>  org-export-latex-keywords()
>  org-export-latex-content(#("\n" 0 1 (fontified nil)))
>  org-export-latex-first-lines(nil)
>  org-export-as-latex(nil)
>  call-interactively(org-export-as-latex)
>  org-export(nil)
>  call-interactively(org-export nil nil)
>
> If I first do a export as html (C-c C-e h) followed by a export to  
> LaTeX
> (C-c C-e l) it works like a charm.
>
> #+OPTIONS:   ^:nil TeX:nil toc:nil
>
> * Title
> ** Subtitle
> [[http://wiki.dspace.org/index.php/Configure_media_filters][media  
> filters]]
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [BUG] LaTeX Export hangs
  2009-01-08 13:26 ` Carsten Dominik
@ 2009-01-08 13:45   ` Christian Egli
  2009-01-08 14:09     ` Carsten Dominik
  0 siblings, 1 reply; 4+ messages in thread
From: Christian Egli @ 2009-01-08 13:45 UTC (permalink / raw)
  To: emacs-orgmode

Carsten Dominik <dominik@science.uva.nl> writes:

> Fixed, thanks.
>
> I think this must also have been Sergio's bug.....

Man Carsten, you're a machine! Within minutes from reporting the issue I
can do a git pull and both issues are fixed. Thank you very much!

Thanks
Christian

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Re: [BUG] LaTeX Export hangs
  2009-01-08 13:45   ` Christian Egli
@ 2009-01-08 14:09     ` Carsten Dominik
  0 siblings, 0 replies; 4+ messages in thread
From: Carsten Dominik @ 2009-01-08 14:09 UTC (permalink / raw)
  To: Christian Egli; +Cc: emacs-orgmode Mailinglist


On Jan 8, 2009, at 2:45 PM, Christian Egli wrote:

> Carsten Dominik <dominik@science.uva.nl> writes:
>
>> Fixed, thanks.
>>
>> I think this must also have been Sergio's bug.....
>
> Man Carsten, you're a machine! Within minutes from reporting the  
> issue I
> can do a git pull and both issues are fixed. Thank you very much!

Hi Christian,

bugs in Org-mode is something I can live with very badly.  So I have
the choice to be bugged with it a whole day, or just taking the 2  
minutes
it need, in particular when you have done your homework and already  
shown
approximately where things go wrong.

Of course it helps too that "git push" is all it
needs to get the stuff back to the world.

Basically:  David Allens 2 Minute rule, plus the wonders of GIT.

Happy new year!

- Carsten

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2009-01-08 14:09 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-01-08 12:30 [BUG] LaTeX Export hangs Christian Egli
2009-01-08 13:26 ` Carsten Dominik
2009-01-08 13:45   ` Christian Egli
2009-01-08 14:09     ` Carsten Dominik

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).