emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Nick Dokos <nicholas.dokos@hp.com>
To: Bill Wishon <bill@wishon.org>
Cc: eric.schulte@gmail.com, emacs-orgmode@gnu.org
Subject: Re: Question about adding to inherited properties
Date: Fri, 20 Apr 2012 00:08:09 -0400	[thread overview]
Message-ID: <9494.1334894889@alphaville> (raw)
In-Reply-To: Message from Bill Wishon <bill@wishon.org> of "Thu\, 19 Apr 2012 17\:06\:40 PDT." <CAP2uJAvcUAV2FtZf+TiGwAMVQnbhTe5WP6JvJ3kf+gwpKJGnvw@mail.gmail.com>

Bill Wishon <bill@wishon.org> wrote:

> First, let me say that I'm only a novice elisp hacker...  That said
> after spending some time debugging I think there may be a disconnect
> between the example in the org-manual and the function
> org-entry-get-with-inheritance.  The manual shows an example in
> section 7.1 where a GENRES+ adds to a GENRES property statement in a
> parent heading.   But the docs and code in the
> org-entry-get-with-inheritance function seem to implement a model that
> only looks up the outline if you don't find anything on the current
> heading, even if it's a "+" property.

> (defun org-entry-get-with-inheritance (property &optional literal-nil)
>   "Get entry property, and search higher levels if not present.  The
> search will stop at the first ancestor which has the property defined.
> If the value found is \"nil\", return nil to show that the property
> should be considered as undefined (this is the meaning of nil here).
> However, if LITERAL-NIL is set, return the string value \"nil\"
> instead."

>   (move-marker org-entry-property-inherited-from nil)
>   (let (tmp)
>     (unless (org-before-first-heading-p)
>       (save-excursion
>     (save-restriction
>       (widen)
>       (catch 'ex
>         (while t
>           (when (setq tmp (org-entry-get nil property nil 'literal-nil))

> >>> In my previous example when we get here org-entry-get returns the
> value of the property GENRES which is "Baroque" and executes the
> following three functions including the throw, which stops the loop.

> >>> Based on the documentation I would think that this function should
> check to see if the current property is a "GENRES+" vs. a "GENRES"
> property and continue up the outline looking for more GENRES+
> properties and only stop when we find a plain GENRES or reach the
> top.  This looks like what the (org-up-heading-safe) below is trying
> to do, but never gets executed because org-entry-get returned a
> positive value of "Baroque" when searching for GENRES on the current
> entry.

>         (org-back-to-heading t)
>         (move-marker org-entry-property-inherited-from (point))
>         (throw 'ex tmp))
>           (or (org-up-heading-safe) (throw 'ex nil)))))))
>     (setq tmp (or tmp
>           (cdr (assoc property org-file-properties))
>           (cdr (assoc property org-global-properties))
>           (cdr (assoc property org-global-properties-fixed))))
>     (if literal-nil tmp (org-not-nil tmp))))
> Thoughts?

Eric Schulte (cc:ed) implemented accumulating properties with commit
3af89e696a32afcc39f2e3bdb6132ac588d530ae. The commit adds a function
org-update-property-plist which takes care of the '+' case in property
names. But as you observed, it does not seem to work. I don't really
understand what should be happening: what I do know is that when
org-entry-get calls the above function, the props parameter is nil,
whereas the function expects it to contain the inherited sestting. So it
may be that the function is expecting something that is not going to
happen or org-entry-get passes it the wrong thing somehow. I don't know which
one of these two is correct (or perhaps some other thing is wrong), but
in any case there does seem to be a disconnect.


> ~>Bill
> On Wed, Apr 18, 2012 at 4:05 PM, Bill Wishon <bill@wishon.org> wrote:
>     Hi Org-mode Community,
>     I can't get the example in section 7.1 of the org-mode manual to work as I expect.  Perhaps
>     someone can help me see what I'm doing wrong. 
>     I tried creating this buffer:
>     * CD collection
>     ** Classic
>      :GENRES: Classic
>      :END:
>     *** Goldberg Variations
>      :Title:    Goldberg Variations
>      :Composer: J.S. Bach
>      :Artist:   Glen Gould
>      :Publisher: Deutsche Grammophon
>      :NDisks:   1
>      :GENRES+:   Baroque
>      :END:
>     Then I set the org-use-property-inheritance variable to include GENRES.
>     Then I wrote the following function
>     (defun bill-test (property)
>       "print all inheirited properties"
>       (interactive "MProperty: ")
>       (message (concat property " = " (org-entry-get (point) property t))))
>     Which prints "GENRES = Baroque" when I run it with the point on Goldberg Variations, based on
>     the manual I expected this to print "GENRES = Classic Baroque”.
>     While I think they should all do the same thing, I also tried the following ways of calling
>     org-entry-get just in case all with the same result.
>     (org-entry-get (point) property 'selective)
>     (org-entry-get nil property t)
>     (org-entry-get nil property 'selective)
>     I'm using org-version 7.8.09 on Windows with emacs "GNU Emacs 23.3.1 (i386-mingw-nt6.1.7601) of
>     2011-03-10 on 3249CTO".
>     Any pointers about what I'm doing wrong would be great.
>     Thanks,
>     ~>Bill
> ----------------------------------------------------
> Alternatives:
> ----------------------------------------------------

  reply	other threads:[~2012-04-20  4:08 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-04-18 23:05 Question about adding to inherited properties Bill Wishon
2012-04-20  0:06 ` Bill Wishon
2012-04-20  4:08   ` Nick Dokos [this message]
2012-04-25  2:13     ` Bill Wishon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=9494.1334894889@alphaville \
    --to=nicholas.dokos@hp.com \
    --cc=bill@wishon.org \
    --cc=emacs-orgmode@gnu.org \
    --cc=eric.schulte@gmail.com \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).