emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* version-to-list: Invalid version syntax: ‘9.5-dev’
@ 2021-09-20  8:06 Axel Kielhorn
  2021-09-27  8:25 ` Bastien
  0 siblings, 1 reply; 4+ messages in thread
From: Axel Kielhorn @ 2021-09-20  8:06 UTC (permalink / raw)
  To: Org-Mode Mailing List

Hello,

I moved to the new repo and rebuild org.

Now I get the following error message:

version-to-list: Invalid version syntax: ‘9.5-dev’

It seems someone checks for the version number and can’t handle the ´-dev´.

When I change org-version.el to ’9.5’ (which I shouldn’t do) the problem is gone.

I’m using Emacs 26.3 and 27.2 with scimax (which requires lots of packages from ELPA), both have this problem.

Should I investigate to find the culprit?

And if yes, how?

Greetings Axel




^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: version-to-list: Invalid version syntax: ‘9.5-dev’
  2021-09-20  8:06 version-to-list: Invalid version syntax: ‘9.5-dev’ Axel Kielhorn
@ 2021-09-27  8:25 ` Bastien
  2021-09-27  9:04   ` version-to-list: Invalid version syntax: ‘9.5-orgdev’ Axel Kielhorn
  0 siblings, 1 reply; 4+ messages in thread
From: Bastien @ 2021-09-27  8:25 UTC (permalink / raw)
  To: Axel Kielhorn; +Cc: Org-Mode Mailing List

Hi Axel,

Axel Kielhorn <org-mode@axelkielhorn.de> writes:

> Now I get the following error message:
>
> version-to-list: Invalid version syntax: ‘9.5-dev’

Can you pull again and check if you still have this error?

Thanks,

-- 
 Bastien


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: version-to-list: Invalid version syntax: ‘9.5-orgdev’
  2021-09-27  8:25 ` Bastien
@ 2021-09-27  9:04   ` Axel Kielhorn
  2021-09-27  9:42     ` Bastien
  0 siblings, 1 reply; 4+ messages in thread
From: Axel Kielhorn @ 2021-09-27  9:04 UTC (permalink / raw)
  To: Org-Mode Mailing List



> Am 27.09.2021 um 10:25 schrieb Bastien <bzg@gnu.org>:
> 
> Hi Axel,
> 
> Axel Kielhorn <org-mode@axelkielhorn.de> writes:
> 
>> Now I get the following error message:
>> 
>> version-to-list: Invalid version syntax: ‘9.5-dev’
> 
> Can you pull again and check if you still have this error?
> 

org-version says 9.4.6 now, since the version is taken from the git tag.

Thus it was fixed by adding tags to the repo.

Thanks for the fix.
Axel

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: version-to-list: Invalid version syntax: ‘9.5-orgdev’
  2021-09-27  9:04   ` version-to-list: Invalid version syntax: ‘9.5-orgdev’ Axel Kielhorn
@ 2021-09-27  9:42     ` Bastien
  0 siblings, 0 replies; 4+ messages in thread
From: Bastien @ 2021-09-27  9:42 UTC (permalink / raw)
  To: Axel Kielhorn; +Cc: Org-Mode Mailing List

Thanks for confirming!

-- 
 Bastien


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-09-27  9:43 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-20  8:06 version-to-list: Invalid version syntax: ‘9.5-dev’ Axel Kielhorn
2021-09-27  8:25 ` Bastien
2021-09-27  9:04   ` version-to-list: Invalid version syntax: ‘9.5-orgdev’ Axel Kielhorn
2021-09-27  9:42     ` Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).