emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Ihor Radchenko <yantar92@gmail.com>
To: Timothy <tecosaur@gmail.com>, ian martins <ianxm@jhu.edu>
Cc: emacs-orgmode@gnu.org
Subject: Re: Bug: org-plot gives Invalid function error
Date: Tue, 27 Apr 2021 11:33:19 +0800	[thread overview]
Message-ID: <87zgxkmmf4.fsf@localhost> (raw)
In-Reply-To: <87r1ix565x.fsf@gmail.com>

Timothy <tecosaur@gmail.com> writes:

> From a quick test myself, this appears reproducible, though I have no
> idea what's going on (yet). Please let me know if you find anything.

I remember seeing similar gnuplot errors using ob-gnuplot. They tend to
disappear upon restarting gnuplot process (M-x gnuplot-kill-gunplot-buffer),
probably because ob-gnuplot does not refresh gnuplot session.

A quick look through org-plot code shows that gnuplot session is also
preserved:

(when (get-buffer "*gnuplot*") ; reset *gnuplot* if it already running
      (with-current-buffer "*gnuplot*"
	(goto-char (point-max))))

So, I suspect that the problem I encountered may also be relevant in
org-plot.

Hope it helps.

Best,
Ihor


  reply	other threads:[~2021-04-27  3:29 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-04-26 16:49 ian martins
2021-04-26 17:04 ` Timothy
2021-04-27  3:33   ` Ihor Radchenko [this message]
2021-04-27  3:50     ` Timothy
2021-04-27  4:47       ` Ihor Radchenko
2021-05-01 17:13         ` Bastien
2021-05-01 17:18           ` Timothy
2021-05-01 17:24             ` Bastien
2021-05-09 15:54         ` Timothy
2021-05-12 14:07           ` Ihor Radchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87zgxkmmf4.fsf@localhost \
    --to=yantar92@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --cc=ianxm@jhu.edu \
    --cc=tecosaur@gmail.com \
    --subject='Re: Bug: org-plot gives Invalid function error' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).