emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [Bug] org-persist.el: xdg.el is unavailable in emacs-25.2
@ 2021-10-27 12:35 Max Nikulin
  2021-10-27 13:55 ` Ihor Radchenko
  0 siblings, 1 reply; 2+ messages in thread
From: Max Nikulin @ 2021-10-27 12:35 UTC (permalink / raw)
  To: orgmode, Ihor Radchenko

Org-mode compilation fails with the following errors if emacs-25.2.2 is 
used (Ubuntu-18.04 LTS bionic)

> Compiling /home/ubuntu/org-mode/lisp/ox-ascii.el...
> 
> In toplevel form:
> ox-ascii.el:31:1:Error: Cannot open load file: No such file or directory, xdg
> Compiling /home/ubuntu/org-mode/lisp/ox-beamer.el...
> 
> In toplevel form:
> ox-beamer.el:34:1:Error: Cannot open load file: No such file or directory, xdg
 >
 > ...

org.el in the main branch still declares

> ;; Package-Requires: ((emacs "25.1"))

but it seems xdg.el used by org-persist.el was added in emacs-26.0.

I do not actually use emacs-25.2, but it happened that I have a test 
container for Org based on Ubuntu-18.04.

Either org-persist and org-compat should be updated with some 
compatibility code or required emacs version should be updated once more.


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [Bug] org-persist.el: xdg.el is unavailable in emacs-25.2
  2021-10-27 12:35 [Bug] org-persist.el: xdg.el is unavailable in emacs-25.2 Max Nikulin
@ 2021-10-27 13:55 ` Ihor Radchenko
  0 siblings, 0 replies; 2+ messages in thread
From: Ihor Radchenko @ 2021-10-27 13:55 UTC (permalink / raw)
  To: Max Nikulin; +Cc: orgmode

Max Nikulin <manikulin@gmail.com> writes:

>> In toplevel form:
>> ox-beamer.el:34:1:Error: Cannot open load file: No such file or directory, xdg
>  >
>  > ...
>
> org.el in the main branch still declares
>
>> ;; Package-Requires: ((emacs "25.1"))
>
> but it seems xdg.el used by org-persist.el was added in emacs-26.0.
>
> I do not actually use emacs-25.2, but it happened that I have a test 
> container for Org based on Ubuntu-18.04.
>
> Either org-persist and org-compat should be updated with some 
> compatibility code or required emacs version should be updated once more.

Technically, the current Emacs version is Emacs 27. So, following our
maintenance convention [1], we should support everything down to Emacs
25 (e.g. 27-2). However, Emacs 28 is going to be out soon-ish and the
problem is not on bugfix branch, but only on main. I am not sure if we
need to follow version-2 convention for main as well. Maybe better
require only version-1? Weaker back-compatibility requirement can allow
us to implement more advanced features relying on more recent Emacs
versions.

[1] https://orgmode.org/worg/org-maintenance.html

Also, org-src.el from bugfix may not run on Emacs 25:

In end of data:
org-src.el:1312:1:Warning: the function ‘replace-buffer-contents’ is not known
    to be defined.

Best,
Ihor


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-10-27 14:27 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-10-27 12:35 [Bug] org-persist.el: xdg.el is unavailable in emacs-25.2 Max Nikulin
2021-10-27 13:55 ` Ihor Radchenko

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).