emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [Patch] org-capture.el
@ 2010-08-12  4:02 Mark Scala
  2010-08-12  8:53 ` Bastien
  0 siblings, 1 reply; 6+ messages in thread
From: Mark Scala @ 2010-08-12  4:02 UTC (permalink / raw)
  To: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 680 bytes --]

When capture templates with tags are finalized, those tags are not
realigned.  I think this fixes it (does in the cases I've tested).

diff --git a/lisp/org-capture.el b/lisp/org-capture.el
index ece5006..03911da 100644
--- a/lisp/org-capture.el
+++ b/lisp/org-capture.el
@@ -500,7 +500,8 @@ bypassed."
 	(save-excursion
 	  (when (ignore-errors (org-back-to-heading))
 	    (org-update-parent-todo-statistics)
-	    (org-update-checkbox-count)))
+	    (org-update-checkbox-count)
+	    (org-set-tags nil t)))
 	;; FIXME Here we should do the sorting
 	;; If we have added a table line, maybe recompute?
 	(when (and (eq (org-capture-get :type 'local) 'table-line)

--
Mark Scala

[-- Attachment #1.2: Type: text/html, Size: 777 bytes --]

[-- Attachment #2: Type: text/plain, Size: 201 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [Patch] org-capture.el
  2010-08-12  4:02 [Patch] org-capture.el Mark Scala
@ 2010-08-12  8:53 ` Bastien
  2010-08-12 11:03   ` Mark Scala
  0 siblings, 1 reply; 6+ messages in thread
From: Bastien @ 2010-08-12  8:53 UTC (permalink / raw)
  To: Mark Scala; +Cc: emacs-orgmode

Hi Mark,

Mark Scala <markscala@gmail.com> writes:

> When capture templates with tags are finalized, those tags are not realigned. 
> I think this fixes it (does in the cases I've tested).

Thanks for the patch -- I have (setq org-auto-align-tags t) here and
tags are aligned when capturing.

Would that solve your issue as well?

-- 
 Bastien

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [Patch] org-capture.el
  2010-08-12  8:53 ` Bastien
@ 2010-08-12 11:03   ` Mark Scala
  2010-08-12 14:02     ` Bastien
  0 siblings, 1 reply; 6+ messages in thread
From: Mark Scala @ 2010-08-12 11:03 UTC (permalink / raw)
  To: Bastien; +Cc: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 866 bytes --]

Bastien,

Thanks, I hadn't checked the value of org-auto-realign-tags before looking
at org-capture.  But unfortunately that doeesn't solve the problem for me,
the tags just aren't realigning.  (org-auto-realign-tags is set true by
default in my reference branch.)  My capture output still looks like this:

* Headline :tag:
stuff here

Tags align normally for only after adding that line to org-capture.

Best,
Mark

On Thu, Aug 12, 2010 at 3:53 AM, Bastien <bastien.guerry@wikimedia.fr>wrote:

> Hi Mark,
>
> Mark Scala <markscala@gmail.com> writes:
>
> > When capture templates with tags are finalized, those tags are not
> realigned.
> > I think this fixes it (does in the cases I've tested).
>
> Thanks for the patch -- I have (setq org-auto-align-tags t) here and
> tags are aligned when capturing.
>
> Would that solve your issue as well?
>
> --
>  Bastien
>

[-- Attachment #1.2: Type: text/html, Size: 1332 bytes --]

[-- Attachment #2: Type: text/plain, Size: 201 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [Patch] org-capture.el
  2010-08-12 11:03   ` Mark Scala
@ 2010-08-12 14:02     ` Bastien
  2010-08-25 14:54       ` Mark Scala
  0 siblings, 1 reply; 6+ messages in thread
From: Bastien @ 2010-08-12 14:02 UTC (permalink / raw)
  To: Mark Scala; +Cc: emacs-orgmode

Hi Mark,

Mark Scala <markscala@gmail.com> writes:

> Thanks, I hadn't checked the value of org-auto-realign-tags before looking at
> org-capture.

(Please note this is `org-auto-align-tags' -- not
`org-auto-REalign-tags'.)

> But unfortunately that doeesn't solve the problem for me, the
> tags just aren't realigning.  (org-auto-realign-tags is set true by default in
> my reference branch.)  My capture output still looks like this:
>
> * Headline :tag:
> stuff here
>
> Tags align normally for only after adding that line to org-capture.

Yes, but it should work without that line since `org-set-tags' is called
beforehand in the process of creating the captured entry.  

I'm digging into this to see what's wrong.

Thanks,

-- 
 Bastien

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [Patch] org-capture.el
  2010-08-12 14:02     ` Bastien
@ 2010-08-25 14:54       ` Mark Scala
  2010-08-30 11:51         ` Carsten Dominik
  0 siblings, 1 reply; 6+ messages in thread
From: Mark Scala @ 2010-08-25 14:54 UTC (permalink / raw)
  To: Bastien; +Cc: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 1495 bytes --]

Bastien,

I've had a chance to look into this again today, and I've found something
that might help you track down the bug (if it is a bug).

I've found that when I use this capture template:

("L" "reference" entry (*file+headline* "~/code/org/reference.org" "Test")
"* %^{Description} %^G \n%? \n %U" :prepend)

tags get aligned properly.  However, not so with this one, which differs
only with respect to the target parameter (file+headline vs. file):

("L" "reference" entry (*file* "~/code/org/reference.org")
"* %^{Description} %^G \n%? \n %U" :prepend)

Hope this is helpful and not just distracting.

Best,
Mark



On Thu, Aug 12, 2010 at 9:02 AM, Bastien <bastien.guerry@wikimedia.fr>wrote:

> Hi Mark,
>
> Mark Scala <markscala@gmail.com> writes:
>
> > Thanks, I hadn't checked the value of org-auto-realign-tags before
> looking at
> > org-capture.
>
> (Please note this is `org-auto-align-tags' -- not
> `org-auto-REalign-tags'.)
>
> > But unfortunately that doeesn't solve the problem for me, the
> > tags just aren't realigning.  (org-auto-realign-tags is set true by
> default in
> > my reference branch.)  My capture output still looks like this:
> >
> > * Headline :tag:
> > stuff here
> >
> > Tags align normally for only after adding that line to org-capture.
>
> Yes, but it should work without that line since `org-set-tags' is called
> beforehand in the process of creating the captured entry.
>
> I'm digging into this to see what's wrong.
>
> Thanks,
>
> --
>  Bastien
>

[-- Attachment #1.2: Type: text/html, Size: 2296 bytes --]

[-- Attachment #2: Type: text/plain, Size: 201 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [Patch] org-capture.el
  2010-08-25 14:54       ` Mark Scala
@ 2010-08-30 11:51         ` Carsten Dominik
  0 siblings, 0 replies; 6+ messages in thread
From: Carsten Dominik @ 2010-08-30 11:51 UTC (permalink / raw)
  To: Mark Scala; +Cc: emacs-orgmode, Bastien


On Aug 25, 2010, at 4:54 PM, Mark Scala wrote:

> Bastien,
>
> I've had a chance to look into this again today, and I've found  
> something that might help you track down the bug (if it is a bug).
>
> I've found that when I use this capture template:
>
> ("L" "reference" entry (file+headline "~/code/org/reference.org"  
> "Test") "* %^{Description} %^G \n%? \n %U" :prepend)
>
> tags get aligned properly.  However, not so with this one, which  
> differs only with respect to the target parameter (file+headline vs.  
> file):
>
> ("L" "reference" entry (file "~/code/org/reference.org")
> "* %^{Description} %^G \n%? \n %U" :prepend)
>
> Hope this is helpful and not just distracting.

Hi Mark, hi Bastien,

this should be fixed now.

- Carsten


>
> Best,
> Mark
>
>
>
> On Thu, Aug 12, 2010 at 9:02 AM, Bastien  
> <bastien.guerry@wikimedia.fr> wrote:
> Hi Mark,
>
> Mark Scala <markscala@gmail.com> writes:
>
> > Thanks, I hadn't checked the value of org-auto-realign-tags before  
> looking at
> > org-capture.
>
> (Please note this is `org-auto-align-tags' -- not
> `org-auto-REalign-tags'.)
>
> > But unfortunately that doeesn't solve the problem for me, the
> > tags just aren't realigning.  (org-auto-realign-tags is set true  
> by default in
> > my reference branch.)  My capture output still looks like this:
> >
> > * Headline :tag:
> > stuff here
> >
> > Tags align normally for only after adding that line to org-capture.
>
> Yes, but it should work without that line since `org-set-tags' is  
> called
> beforehand in the process of creating the captured entry.
>
> I'm digging into this to see what's wrong.
>
> Thanks,
>
> --
>  Bastien
>
> _______________________________________________
> Emacs-orgmode mailing list
> Please use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

- Carsten

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2010-08-30 11:52 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-08-12  4:02 [Patch] org-capture.el Mark Scala
2010-08-12  8:53 ` Bastien
2010-08-12 11:03   ` Mark Scala
2010-08-12 14:02     ` Bastien
2010-08-25 14:54       ` Mark Scala
2010-08-30 11:51         ` Carsten Dominik

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).