emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* beamer code and auctex
@ 2011-03-22 13:08 Andrea Crotti
  2011-03-23  8:46 ` Eric S Fraga
  0 siblings, 1 reply; 2+ messages in thread
From: Andrea Crotti @ 2011-03-22 13:08 UTC (permalink / raw)
  To: emacs-orgmode

I'm trying to put some nicely colored code in my org-beamer
presentation.

On one machine I have minted but it's not found and the other is not
installed, but I guess that's a latex problem.
With lstlisting it kind of work but the font is way too big and not very
nice, but I'll try again maybe to see if I can get it better...

The problem is that I use auctex for latex files, and the first time it
asks a value for the tex-master file.

Isn't it possible to disable this and why does it asks since I'm using
pdflatex directly, right?

Thanks,
Andrea

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: beamer code and auctex
  2011-03-22 13:08 beamer code and auctex Andrea Crotti
@ 2011-03-23  8:46 ` Eric S Fraga
  0 siblings, 0 replies; 2+ messages in thread
From: Eric S Fraga @ 2011-03-23  8:46 UTC (permalink / raw)
  To: Andrea Crotti; +Cc: emacs-orgmode

Andrea Crotti <andrea.crotti.0@gmail.com> writes:

> I'm trying to put some nicely colored code in my org-beamer
> presentation.
>
> On one machine I have minted but it's not found and the other is not
> installed, but I guess that's a latex problem.
> With lstlisting it kind of work but the font is way too big and not very
> nice, but I'll try again maybe to see if I can get it better...
>
> The problem is that I use auctex for latex files, and the first time it
> asks a value for the tex-master file.
>
> Isn't it possible to disable this and why does it asks since I'm using
> pdflatex directly, right?
>
> Thanks,
> Andrea

You can customise auctex to do what you want.  From
[[info:auctex#Multifile]],

,----
|    When you, for example, ask AUCTeX to run a command on the master
| file, it has no way of knowing the name of the master file.  By default,
| it will assume that the current file is the master file.  If you insert
| the following in your `.emacs' file AUCTeX will use a more advanced
| algorithm.
| 
|      (setq-default TeX-master nil) ; Query for master file.
`----

Set this variable to t to indicate that all files are "masters" by
default, I believe.  Even though you are using pdflatex directly, you
are prompted because the tex file is being loaded in the process of
creating that pdf.

-- 
: Eric S Fraga (GnuPG: 0xC89193D8FFFCF67D) in Emacs 24.0.50.1
: using Org-mode version 7.5 (release_7.5.97.g078c0)

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2011-03-23  9:59 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-03-22 13:08 beamer code and auctex Andrea Crotti
2011-03-23  8:46 ` Eric S Fraga

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).