emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Maxima code blocks does not work in windows revisited
@ 2014-07-10 19:48 Juan Alvaro Fuentes
  2014-07-27 23:07 ` Bastien
  0 siblings, 1 reply; 2+ messages in thread
From: Juan Alvaro Fuentes @ 2014-07-10 19:48 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 1688 bytes --]

Dear all,

It seems that maxima code blocks still does not work in windows as the
following code did not work when I tried to run it:

#+begin_src maxima
 a: 1+1;
 print(a);
#+end_src

This is an old issue already emailed to this emacs org-mode list in an
email dating from june 2011.

The conversation ended up with a final reflection which I copy next:

>* Okay, it definitely is a Windows problem. If I run the following command*
>* in a cygwin shell, everything works as expected:*
>
>* maxima --very-quiet -r*
>* 'batchload("c:/Users/weiss/AppData/Local/Temp/babel-17716aLH/maxima-17716hCp")$'*
>* nil*
>
>* However, it does not work in a Windows shell. But this is no longer an*
>* org issue.*
>
>* Bernd*


Trying to find the correct string that makes maxima execute the batch
file in windows I found that this command does work:

maxima --very-quiet -r
"batchload(\"c:/Users/alvaro/AppData/Local/Temp/babel-7740OHt/maxima-7740OpY.max\")$"

maxima --very-quiet -r
"batchload(\"c:/Users/alvaro/AppData/Local/Temp/babel-7740OHt/maxima-7740OpY.max\")$"

2


I tried to make this string when maxima is executed in the shell and
modifying ob-maxima.el found that this seems to work for windows 8,
emacs 24.4 and org 8.2.7b:


 (let* ((cmdline (or (cdr (assoc :cmdline params)) ""))
          (in-file (org-babel-temp-file "maxima-" ".max"))
		(cmd (format "%s --very-quiet -r \"batchload(\\\"%s\\\")$\" %s"
			     org-babel-maxima-command in-file cmdline)))


The problem is that my lisp skills are not very good, to say the
least, and sending a patch is one more problem so I write this email
if this can help anybody to makemaxima code blocks work in windows.


Thanks,

Juan Alvaro

[-- Attachment #2: Type: text/html, Size: 2920 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Maxima code blocks does not work in windows revisited
  2014-07-10 19:48 Maxima code blocks does not work in windows revisited Juan Alvaro Fuentes
@ 2014-07-27 23:07 ` Bastien
  0 siblings, 0 replies; 2+ messages in thread
From: Bastien @ 2014-07-27 23:07 UTC (permalink / raw)
  To: Juan Alvaro Fuentes; +Cc: emacs-orgmode

Hi Juan,

Juan Alvaro Fuentes <juanalvaro.fuentes@upct.es> writes:

> It seems that maxima code blocks still does not work in windows as
> the following code did not work when I tried to run it:

I don't have a machine with Windows so I can't really help here, but I
hope an Org/Maxima/Windows user can help debugging this further.

Best,

-- 
 Bastien

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2014-07-28 17:25 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-07-10 19:48 Maxima code blocks does not work in windows revisited Juan Alvaro Fuentes
2014-07-27 23:07 ` Bastien

Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).