emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Robert Eckl <eckl.robert@arcor.de>
To: hdweiss@gmail.com
Cc: emacs-orgmode@gnu.org
Subject: Re: Differences between MobileOrg and MobileOrgNG
Date: Thu, 27 Sep 2012 01:46:25 +0200	[thread overview]
Message-ID: <87vcf0jqjy.fsf@REWINDWIN.i-did-not-set--mail-host-address--so-tickle-me> (raw)


Hi, 

Henning Weiss wrote:

> On Wed, Sep 19, 2012 at 12:53 AM, <eckl.robert@arcor.de> wrote:
> Henning Weiss wrote:
>
>>> On Mon, Sep 17, 2012 at 9:20 PM, Robert Eckl wrote:
>
>>> If i Push the org-files under Windows with MobileOrg the different
>>> org-files are not synced, but with MobileOrgNG they are. If i push
>>> the org-files under Mac OS, the org-files are synced even with
>>> MobileOrg.
>
>> This sounds like a known bug with org-mode on Windows, as it does not
>> generate a complete checksum file. See the discussion here. It seems
>> that changing from sha1sum.exe to md5sum.exe for the generation of the
>> checksum file fixes that issue.
> Thank you very much for the hint. Changing sha1sum.exe to md5sum.exe did
> not change anything for me, but changing from Gnuwin sha1sum/md5sum to
> the one from ftp://ftp.gnupg.org/gcrypt/binary/sha1sum.exe seems to fix
> the issue for me.
>
> Does that mean that the default checksum generation utility of cygwin
> that is used by org-mode is broken? 

I don't think so.
> Will upgrading cygwin to a newer
> version fix this, or did you need to change your setup?

I'm using an emacs version from http://alpha.gnu.org/gnu/emacs/windows/.
At first there were no md5sum binary found. So i installed the coreutils
(and diffutils) from gnuwin32. Seems that these utils don't work
fine with emacs.

> I hope, other issues are fixed too. Sometimes org-mobile-push crashes
> because of IIRC unexpected hashes. If I remove the related
> agenda-file(s), do the push, and then add the files to the agenda-files
> the push sometimes is succesfull. I have no idea, how to fix it.
>
> Could you try to produce a minimal setup that produces this problem? I'm
> sure more people on windows have this problem. I would at least like to
> post a workaround for this issue on the mobileorg-android web page.
>
I can try this, but seems to be difficult, because removing the file
from the agende-file-list and adding it another time sometimes solves
the issue.

Invoking C-c C-x RET p from one file which begins with
# Time-stamp: "2012-09-27 Do 01:17:19 (re)"
#+LAST_MOBILE_CHANGE: 2012-03-12 21:40:01
#TAGS: PHONE(p) URGENT(u) MAIL(e) Anwesenheit (a) Musik (m) Orgel (o) Cello (i)

I got an error, then I deleted line 2  
#+LAST_MOBILE_CHANGE: 2012-03-1221:40:01
the error no more occured.

After this i copied the line in another agenda-file from wich invoking
org-mobile-push does not result in an error.

The error did not occur with this changed file.
Then I copied the line in the first file and started org-mobile-push:

The error didn't occur further. So i am confused.

I'll play with this, but i think this will take much time. 

Do you speak german? Im thinking, you can better understand me, if i
could write in german.

Thanks,

Robert

             reply	other threads:[~2012-09-26 23:46 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-09-26 23:46 Robert Eckl [this message]
2012-09-27 13:13 ` Henning Weiss
  -- strict thread matches above, loose matches on Subject: below --
2012-09-18 22:53 eckl.robert
2012-09-25 19:00 ` Henning Weiss
2012-09-17 19:20 Robert Eckl
2012-09-17 22:30 ` Henning Weiss
2012-09-16 16:15 Laurent Hoeltgen
2012-09-16 16:57 ` Moritz Ulrich

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87vcf0jqjy.fsf@REWINDWIN.i-did-not-set--mail-host-address--so-tickle-me \
    --to=eckl.robert@arcor.de \
    --cc=emacs-orgmode@gnu.org \
    --cc=hdweiss@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).