emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Trey Darley <trey@treyka.net>
To: Org Mode <emacs-orgmode@gnu.org>
Subject: Help! org-insert-heading doesn't work anymore and I'm losing my mind!
Date: Mon, 30 Apr 2012 10:31:59 +0200	[thread overview]
Message-ID: <87ty01sjr4.wl%trey@kingfisherops.com> (raw)

Hash: SHA1

Hi, everyone -

First post to the list. Guess I should start out by saying, Carsten et al, you
guys rock! Thanks for org-mode!

* Problem: I can no longer insert new outline headings via the usual M-RET

Here's an overview of my setup:

** os: debian (wheezy/sid amd64)
** emacs: gnu emacs (23.4.1 - plain-vanilla distro)
** window manager: xmonad 0.10
** terminal: xfce4-terminal + tmux 1.6
** org-mode: development (via git) 

* What have I tested?

** running emacs under a different terminal (urxvt and xterm)
** running outside tmux in a normal session
** disabling all my ~/.emacs.d/ modifications apart from setting my load-path
   and the bare minimal [0] to instantiate org-mode
** running org-7.8.09 (stable) and org-7.8.06 (distro)

None of that fixed it.

* C-h C-b indicates the binding is in place.

| M-RET           org-insert-heading

* output of xev / xmodmap looks normal

M-x org-insert-heading works just fine. At this point I think I've tried
looking at all the complicated things. Past experience leads me to believe
there's something completely stupid and obvious that I'm not thinking of,
which is why I'm turning to you lot. Please, someone make me feel stupid and
save my sanity!!! ;-)

[0]: http://orgmode.org/guide/Activation.html#Activation

Trey Darley - Brussels
twitter: @treyka
gpg fingerprint: C2AD E2A8 440C 8785 1958 B6DA 4176 9233 8F6D 8AF0
Quis custodiet ipsos custodes?
Version: GnuPG v1.4.12 (GNU/Linux)


             reply	other threads:[~2012-04-30  8:32 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-04-30  8:31 Trey Darley [this message]
2012-04-30  8:36 ` Help! org-insert-heading doesn't work anymore and I'm losing my mind! Bastien
2012-04-30  8:43   ` Trey Darley
2012-04-30 14:59     ` Nick Dokos
2012-04-30 12:34 ` Bastien
2012-04-30 12:43   ` suvayu ali
2012-04-30 14:38   ` Nick Dokos
2012-04-30 18:23 ` Achim Gratz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87ty01sjr4.wl%trey@kingfisherops.com \
    --to=trey@treyka.net \
    --cc=emacs-orgmode@gnu.org \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).