emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* list re-numbering not working in odt export
@ 2021-06-24 16:45 Rob Sargent
  2021-06-24 16:54 ` Eric S Fraga
  2021-09-26 11:29 ` Bastien
  0 siblings, 2 replies; 3+ messages in thread
From: Rob Sargent @ 2021-06-24 16:45 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 435 bytes --]

It appears to me that explicitly setting list order number is not 
honoured by the odt export mechanism.  The following works on latex 
(list numbering starts at 7) but not on odt (list numbering starts at 
one though the [@7] is stripped from the output (as expect)):

    1. [@7](/facilities/) The tangible compute infrastructure employed
    by SGSaaS is entirely ...

I am using org version 9.1.9 and libre office version 6.4.7.2

[-- Attachment #2: Type: text/html, Size: 811 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: list re-numbering not working in odt export
  2021-06-24 16:45 list re-numbering not working in odt export Rob Sargent
@ 2021-06-24 16:54 ` Eric S Fraga
  2021-09-26 11:29 ` Bastien
  1 sibling, 0 replies; 3+ messages in thread
From: Eric S Fraga @ 2021-06-24 16:54 UTC (permalink / raw)
  To: Rob Sargent; +Cc: emacs-orgmode

On Thursday, 24 Jun 2021 at 10:45, Rob Sargent wrote:
> I am using org version 9.1.9 and libre office version 6.4.7.2

Confirmed with very recent version, as shown in signature.

-- 
: Eric S Fraga via Emacs 28.0.50, Org release_9.4.6-571-gc591be
: Latest paper written in org: https://arxiv.org/abs/2106.05096


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: list re-numbering not working in odt export
  2021-06-24 16:45 list re-numbering not working in odt export Rob Sargent
  2021-06-24 16:54 ` Eric S Fraga
@ 2021-09-26 11:29 ` Bastien
  1 sibling, 0 replies; 3+ messages in thread
From: Bastien @ 2021-09-26 11:29 UTC (permalink / raw)
  To: Rob Sargent; +Cc: emacs-orgmode

Hi Rob,

Rob Sargent <robjsargent@gmail.com> writes:

> It appears to me that explicitly setting list order number is not
> honoured by the odt export mechanism.  The following works on latex
> (list numbering starts at 7) but not on odt (list numbering starts at
> one though the [@7] is stripped from the output (as expect)):
>
>     1. [@7](/facilities/) The tangible compute infrastructure
>     employed by SGSaaS is entirely ...
>
> I am using org version 9.1.9 and libre office version 6.4.7.2

What happens if you manually fix the list numbering *within* your Org
buffer before exporting it?

It works fine here, and ox-odt.el honors the in-buffer numbers.

I think it's fine to expect the buffer to be up to date before it is
exported.

Thanks,

-- 
 Bastien


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-09-26 11:30 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-24 16:45 list re-numbering not working in odt export Rob Sargent
2021-06-24 16:54 ` Eric S Fraga
2021-09-26 11:29 ` Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).