emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [beamer] source code in two column
@ 2011-09-22  8:52 zwz
  2011-09-22  9:19 ` Eric S Fraga
  0 siblings, 1 reply; 4+ messages in thread
From: zwz @ 2011-09-22  8:52 UTC (permalink / raw)
  To: emacs-orgmode

I use org to make presentations for C class.
Sometimes the code is quite long. And I want to arrange it in two column
so that it will be presented in one slide.

I wonder how to do it easily using org-export. 
My current setting just hides the code that beyond the page in one
column.

Best regards,
zwz 

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [beamer] source code in two column
  2011-09-22  8:52 [beamer] source code in two column zwz
@ 2011-09-22  9:19 ` Eric S Fraga
  2011-09-22 11:15   ` zwz
  0 siblings, 1 reply; 4+ messages in thread
From: Eric S Fraga @ 2011-09-22  9:19 UTC (permalink / raw)
  To: zwz; +Cc: emacs-orgmode

zwz <zhangweize@gmail.com> writes:

> I use org to make presentations for C class.
> Sometimes the code is quite long. And I want to arrange it in two column
> so that it will be presented in one slide.
>
> I wonder how to do it easily using org-export. 
> My current setting just hides the code that beyond the page in one
> column.
>
> Best regards,
> zwz 

I cannot help you directly in that I don't know how to /flow/ text (or
code) from one column to the next.  I don't think it is actually
possible in beamer.

However, it *is* straightforward to flow text from one slide to the next
by simply adding =allowframebreaks= to the beamer environment
arguments.  For instance,

#+begin_src org
*** Code example
    :PROPERTIES:
    :BEAMER_envargs: [allowframebreaks]
    :END:
#+LATEX: {\scriptsize
#+begin_example
   <code goes here>
#+end_example
#+LATEX: }
#+end_src

The slides will automatically be numbered using roman numerals should
more than one slide (aka frame in beamer speak) be required.

I use latex directives to make the font a little smaller to ensure that
lines with within the slide width-wise.

HTH,
eric
-- 
: Eric S Fraga (GnuPG: 0xC89193D8FFFCF67D) in Emacs 24.0.50.1
: using Org-mode version 7.7 (release_7.7.315.g20e6)

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [beamer] source code in two column
  2011-09-22  9:19 ` Eric S Fraga
@ 2011-09-22 11:15   ` zwz
  2011-09-22 11:33     ` Eric S Fraga
  0 siblings, 1 reply; 4+ messages in thread
From: zwz @ 2011-09-22 11:15 UTC (permalink / raw)
  To: emacs-orgmode

Eric S Fraga <e.fraga@ucl.ac.uk> writes:

> zwz <zhangweize@gmail.com> writes:
>
>> I use org to make presentations for C class.
>> Sometimes the code is quite long. And I want to arrange it in two
> column
>> so that it will be presented in one slide.
>>
>> I wonder how to do it easily using org-export. 
>> My current setting just hides the code that beyond the page in one
>> column.
>>
>> Best regards,
>> zwz 
>
> I cannot help you directly in that I don't know how to /flow/ text (or
> code) from one column to the next.  I don't think it is actually
> possible in beamer.
>
> However, it *is* straightforward to flow text from one slide to the next
> by simply adding =allowframebreaks= to the beamer environment
> arguments.  For instance,
>
> #+begin_src org
> *** Code example
>     :PROPERTIES:
>     :BEAMER_envargs: [allowframebreaks]
>     :END:
> #+LATEX: {\scriptsize
> #+begin_example
>    <code goes here>
> #+end_example
> #+LATEX: }
> #+end_src
>
> The slides will automatically be numbered using roman numerals should
> more than one slide (aka frame in beamer speak) be required.
>
> I use latex directives to make the font a little smaller to ensure that
> lines with within the slide width-wise.
>
> HTH,
> eric
It is a nice workaround.
But here in my org file, I have to put the "allowframebreaks" in level
two headlines (probably because of my setting #+BEAMER_FRAME_LEVEL: 2), 
otherwise it does not take effect.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [beamer] source code in two column
  2011-09-22 11:15   ` zwz
@ 2011-09-22 11:33     ` Eric S Fraga
  0 siblings, 0 replies; 4+ messages in thread
From: Eric S Fraga @ 2011-09-22 11:33 UTC (permalink / raw)
  To: zwz; +Cc: emacs-orgmode

zwz <zhangweize@gmail.com> writes:
> It is a nice workaround.
> But here in my org file, I have to put the "allowframebreaks" in level
> two headlines (probably because of my setting #+BEAMER_FRAME_LEVEL: 2), 
> otherwise it does not take effect.

Ah, sorry, I forgot that I have =oddlevelsonly= set so =***= means a
second level heading for me, not a third level.  Apologies for the confusion!

But glad that the workaround is useful.

-- 
: Eric S Fraga (GnuPG: 0xC89193D8FFFCF67D) in Emacs 24.0.50.1
: using Org-mode version 7.7 (release_7.7.315.g20e6)

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2011-09-22 11:33 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-09-22  8:52 [beamer] source code in two column zwz
2011-09-22  9:19 ` Eric S Fraga
2011-09-22 11:15   ` zwz
2011-09-22 11:33     ` Eric S Fraga

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).