emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Daniel Clemente <n142857@gmail.com>
To: Eric Schulte <schulte.eric@gmail.com>
Cc: org-mode Mailinglist <emacs-orgmode@gnu.org>
Subject: Re: results from Python block not visible
Date: Fri, 27 Jun 2014 00:19:51 +0700	[thread overview]
Message-ID: <87pphvh9l4.wl%n142857@gmail.com> (raw)
In-Reply-To: <87vbrntyow.fsf@gmail.com>


El Thu, 26 Jun 2014 12:36:47 -0400 Eric Schulte va escriure:
> > #+BEGIN_SRC python :results output
> > print "x"
> > #+END_SRC
> >
> > It prints:
> >
> > #+RESULTS:
> > : None
> >
> > I expected to see "x". This worked some days ago.
> >
> 
> This works for me using the latest version of Org-mode with an Emacs
> launched by running "make vanilla" from the base of the Org-mode repo.
>
  I didn't know "make vanilla". It worked fine from there, I don't know why from „emacs -Q“ it didn't.
  
> Maybe the problem is in your configuration?

  Exactly, it is from my configuration, because after loading my full configuration, I see the problem again and code highlighting suddenly disappears.
  
  I identified the exact lines that cause org-babel to stop failing. Bewonder:

  (autoload 'tramp "tramp" "Remotely access files." t)
  (require 'tramp-cache)

  Yes! After C-x C-e on the first line, org-babel still works. After C-x C-e on the second line, it doesn't work anymore.
  There were some Tramp changes in latest Emacs, maybe they are bad. I'm using:  GNU Emacs 24.4.50.1 (x86_64-unknown-linux-gnu, X toolkit, Xaw scroll bars) of 2014-06-20 on la4
  

  What a strange bug…

  reply	other threads:[~2014-06-26 17:20 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-06-26 16:16 Daniel Clemente
2014-06-26 16:36 ` Eric Schulte
2014-06-26 17:19   ` Daniel Clemente [this message]
2014-06-27  9:50     ` Daniel Clemente
2014-07-02 16:51       ` Daniel Clemente
2014-07-24  7:18         ` Daniel Clemente
2014-07-24 10:07           ` Michael Albinus

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87pphvh9l4.wl%n142857@gmail.com \
    --to=n142857@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --cc=schulte.eric@gmail.com \
    --subject='Re: results from Python block not visible' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).