emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: torys.anderson@gmail.com (Tory S. Anderson)
To: "orgmode list" <emacs-orgmode@gnu.org>
Subject: Big problem: org agenda freezes my process
Date: Fri, 30 Apr 2021 11:59:53 -0600	[thread overview]
Message-ID: <87mttf1wme.fsf@byu.edu> (raw)

I've been trying to debug a nearly show-stopping issue for a few weeks now; the next step is a more thorough bisection of my setup, but I wanted to send this in case anyone else experiences this or already knows the solution.

Lately, when I try to view an orgmode agenda it seems that two things make it cause my emacs CPU threat to spin to max and freeze up, which is a huge problem since I'm an exwm user and live in my agenda view. As far as I've been able to tell, when an item from today is clocked into multiple times in the same day, it prompts most agenda actions to result in a freeze and some kind of loop that is binding up my system. It has some gaps, so if I spam C-g I will eventually, usually, escape given 30 seconds to 2 minutes.

I first ran into this problem thinking it was because I had an entry with a "+1d" note on it, so it would always show up; but inconsistent results led me to the more precise discovery that it's apparently when it is logged in to multiple times in the day AND when it is shown with =(org-agenda-show-log t)=, which I had on my default. At its worst, even moving the cursor in the agenda buffer would trigger the freezing, let alone actually clocking in/out of anything. However, when I am not showing the log, it seems like it's ok. I've tried =toggle-debug-on-quit" but I don't recognize anything in the stack trace that actually tells me what it is doing when it spins to a halt.

I'm currently on org mode version 9.3.7. I've tried with different versions but without a change in behavior. This, combined with the fact that the issues seem to have begun in the past month, indicates that it probably isn't orgmode itself causing this issue, but I haven't located what it IS yet. If anyone has ideas on how to debug this without a bisection, or an has dealt with this before, I'm more than eager to hear it; in the meanwhile, I'll perform a more thorough bisection of my init file as time permits.

- Tory


             reply	other threads:[~2021-04-30 18:02 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-04-30 17:59 Tory S. Anderson [this message]
2021-04-30 20:46 ` Tim Cross
2021-05-01  4:15 ` Ihor Radchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87mttf1wme.fsf@byu.edu \
    --to=torys.anderson@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --subject='Re: Big problem: org agenda freezes my process' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).