emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* TODO keyword completion bug
@ 2012-08-21  4:23 Aidan Gauland
  2012-08-21 13:02 ` Bastien
  0 siblings, 1 reply; 4+ messages in thread
From: Aidan Gauland @ 2012-08-21  4:23 UTC (permalink / raw)
  To: emacs-orgmode

I have some (buffer-local) keywords defined that contain dashes to
separate words (because I couldn't think of a single word that would be
clear).  M-<TAB> completion does not appear to work for these keywords.

This has made me reconsider my choice of keywords, but since they're
valid keywords, shouldn't they be valid candidates for completion
(i.e. is this a bug)?

--Aidan

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: TODO keyword completion bug
  2012-08-21  4:23 TODO keyword completion bug Aidan Gauland
@ 2012-08-21 13:02 ` Bastien
  2012-08-21 19:43   ` Aidan Gauland
  0 siblings, 1 reply; 4+ messages in thread
From: Bastien @ 2012-08-21 13:02 UTC (permalink / raw)
  To: Aidan Gauland; +Cc: emacs-orgmode

Hi Aidan,

Aidan Gauland <aidalgol@no8wireless.co.nz> writes:

> I have some (buffer-local) keywords defined that contain dashes to
> separate words (because I couldn't think of a single word that would be
> clear).  M-<TAB> completion does not appear to work for these keywords.
>
> This has made me reconsider my choice of keywords, but since they're
> valid keywords, shouldn't they be valid candidates for completion
> (i.e. is this a bug)?

"Keywords" is ambiguous here.

TODO keywords like "MY-TODO" complete fine with M-TAB.

#+MY_KEYWORD does not complete fine with M-TAB, but since this keyword
appears in the buffer anyway, you can simply use M-/.

HTH,

-- 
 Bastien

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: TODO keyword completion bug
  2012-08-21 13:02 ` Bastien
@ 2012-08-21 19:43   ` Aidan Gauland
  2012-08-21 22:22     ` Bastien
  0 siblings, 1 reply; 4+ messages in thread
From: Aidan Gauland @ 2012-08-21 19:43 UTC (permalink / raw)
  To: emacs-orgmode

Bastien <bzg@altern.org> writes:
> Hi Aidan,
> Aidan Gauland <aidalgol@no8wireless.co.nz> writes:
>> I have some (buffer-local) keywords defined that contain dashes to
>> separate words (because I couldn't think of a single word that would be
>> clear).  M-<TAB> completion does not appear to work for these keywords.
>>
>> This has made me reconsider my choice of keywords, but since they're
>> valid keywords, shouldn't they be valid candidates for completion
>> (i.e. is this a bug)?
>
> "Keywords" is ambiguous here.
>
> TODO keywords like "MY-TODO" complete fine with M-TAB.
>
> #+MY_KEYWORD does not complete fine with M-TAB, but since this keyword
> appears in the buffer anyway, you can simply use M-/.

OK, so I'll just use M-/.

I have the keywords defined with #+TODO:.  I just tried playing around
with them a bit, and I have found that the "problem" is not exactly as I
thought: keywords with dashes, such as MY-TODO, do not complete with
M-TAB if I try to complete from after the dash, i.e. M-TAB on MY- does
not complete.  TODO keyword completion does not work at all if there is
already a headline, e.g. * TO[M-TAB here] Buy bread

So, if this is a bug, I now have a workaround; if it's not a bug, then I
now know how to properly use TODO completion.  I'll leave it to you (the
Org-mode devs) to decide whether to treat this as a bug.

Thanks,
Aidan Gauland

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: TODO keyword completion bug
  2012-08-21 19:43   ` Aidan Gauland
@ 2012-08-21 22:22     ` Bastien
  0 siblings, 0 replies; 4+ messages in thread
From: Bastien @ 2012-08-21 22:22 UTC (permalink / raw)
  To: Aidan Gauland; +Cc: emacs-orgmode

Aidan Gauland <aidalgol@no8wireless.co.nz> writes:

> I have the keywords defined with #+TODO:.  I just tried playing around
> with them a bit, and I have found that the "problem" is not exactly as I
> thought: keywords with dashes, such as MY-TODO, do not complete with
> M-TAB if I try to complete from after the dash, i.e. M-TAB on MY- does
> not complete.  TODO keyword completion does not work at all if there is
> already a headline, e.g. * TO[M-TAB here] Buy bread
>
> So, if this is a bug, I now have a workaround; if it's not a bug, then I
> now know how to properly use TODO completion.  I'll leave it to you (the
> Org-mode devs) to decide whether to treat this as a bug.

Indeed, this was a bug.  Fixed now.

Thanks!

-- 
 Bastien

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2012-08-21 22:22 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-08-21  4:23 TODO keyword completion bug Aidan Gauland
2012-08-21 13:02 ` Bastien
2012-08-21 19:43   ` Aidan Gauland
2012-08-21 22:22     ` Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).