emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Filling bug with alphabetical lists
@ 2013-04-24 15:11 Bernt Hansen
  2013-04-24 21:14 ` Nicolas Goaziou
  0 siblings, 1 reply; 6+ messages in thread
From: Bernt Hansen @ 2013-04-24 15:11 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: emacs-orgmode

Hi Nicolas,

I found the following filling bug with alphabetical lists.

I have 

(setq org-alphabetical-lists t)

and when I do M-q on the first line of the lists below (without a blank
separating line) the alphabetical lists are wrapped into the previous
list.

The regular lists behave properly - just the alphabetical ones have this
issue.

--8<---------------cut here---------------start------------->8---
*** TODO Report filling bug for lists with alphabetic characters

  - This is a really long list line that needs to be filled appropriately and wrapped onto multiple lines
    A) This is a really long list line that needs to be filled appropriately and wrapped onto multiple lines
       a) This is a really long list line that needs to be filled appropriately and wrapped onto multiple lines
          A. This is a really long list line that needs to be filled appropriately and wrapped onto multiple lines
             a. This is a really long list line that needs to be filled appropriately and wrapped onto multiple lines
                1) This is a really long list line that needs to be filled appropriately and wrapped onto multiple lines
                   1. This is a really long list line that needs to be filled appropriately and wrapped onto multiple lines
                      * This is a really long list line that needs to be filled appropriately and wrapped onto multiple lines
                        + This is a really long list line that needs to be filled appropriately and wrapped onto multiple lines


--8<---------------cut here---------------end--------------->8---

Regards,
Bernt

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Filling bug with alphabetical lists
  2013-04-24 15:11 Filling bug with alphabetical lists Bernt Hansen
@ 2013-04-24 21:14 ` Nicolas Goaziou
  2013-04-24 22:06   ` Bernt Hansen
  0 siblings, 1 reply; 6+ messages in thread
From: Nicolas Goaziou @ 2013-04-24 21:14 UTC (permalink / raw)
  To: Bernt Hansen; +Cc: emacs-orgmode

Hello,

Bernt Hansen <bernt@norang.ca> writes:
>
> I found the following filling bug with alphabetical lists.
>
> I have 
>
> (setq org-alphabetical-lists t)

This is now `org-list-allow-alphabetical'. I think you need to reload
Org when this variable is changed.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Filling bug with alphabetical lists
  2013-04-24 21:14 ` Nicolas Goaziou
@ 2013-04-24 22:06   ` Bernt Hansen
  2013-04-25  5:28     ` Nicolas Goaziou
  0 siblings, 1 reply; 6+ messages in thread
From: Bernt Hansen @ 2013-04-24 22:06 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: emacs-orgmode

Nicolas Goaziou <n.goaziou@gmail.com> writes:

> Hello,
>
> Bernt Hansen <bernt@norang.ca> writes:
>>
>> I found the following filling bug with alphabetical lists.
>>
>> I have 
>>
>> (setq org-alphabetical-lists t)
>
> This is now `org-list-allow-alphabetical'. I think you need to reload
> Org when this variable is changed.

Thanks, I wasn't aware of this rename but it is already set to t here.
I'll rename the variable in my .emacs.

Do you get the same filling behaviour as me?

GNU Emacs 23.2.1 (i486-pc-linux-gnu, GTK+ Version 2.20.1) of 2013-01-08
on murphy, modified by Debian

Org-mode version 8.0.1 (release_8.0.1 @ /home/bernt/git/org-mode/lisp/)

Regards,
Bernt

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Filling bug with alphabetical lists
  2013-04-24 22:06   ` Bernt Hansen
@ 2013-04-25  5:28     ` Nicolas Goaziou
  2013-04-26  2:53       ` Bernt Hansen
  0 siblings, 1 reply; 6+ messages in thread
From: Nicolas Goaziou @ 2013-04-25  5:28 UTC (permalink / raw)
  To: Bernt Hansen; +Cc: emacs-orgmode

Hello,

Bernt Hansen <bernt@norang.ca> writes:

> Nicolas Goaziou <n.goaziou@gmail.com> writes:
>
>> Hello,
>>
>> Bernt Hansen <bernt@norang.ca> writes:
>>>
>>> I found the following filling bug with alphabetical lists.
>>>
>>> I have 
>>>
>>> (setq org-alphabetical-lists t)
>>
>> This is now `org-list-allow-alphabetical'. I think you need to reload
>> Org when this variable is changed.
>
> Thanks, I wasn't aware of this rename but it is already set to t here.
> I'll rename the variable in my .emacs.
>
> Do you get the same filling behaviour as me?

Not anymore after I reload Org.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Filling bug with alphabetical lists
  2013-04-25  5:28     ` Nicolas Goaziou
@ 2013-04-26  2:53       ` Bernt Hansen
  2013-04-26 12:17         ` Nicolas Goaziou
  0 siblings, 1 reply; 6+ messages in thread
From: Bernt Hansen @ 2013-04-26  2:53 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: emacs-orgmode

Nicolas Goaziou <n.goaziou@gmail.com> writes:

> Hello,
>
> Bernt Hansen <bernt@norang.ca> writes:
>
>> Nicolas Goaziou <n.goaziou@gmail.com> writes:
>>
>>> Hello,
>>>
>>> Bernt Hansen <bernt@norang.ca> writes:
>>>>
>>>> I found the following filling bug with alphabetical lists.
>>>>
>>>> I have 
>>>>
>>>> (setq org-alphabetical-lists t)
>>>
>>> This is now `org-list-allow-alphabetical'. I think you need to reload
>>> Org when this variable is changed.
>>
>> Thanks, I wasn't aware of this rename but it is already set to t here.
>> I'll rename the variable in my .emacs.
>>
>> Do you get the same filling behaviour as me?
>
> Not anymore after I reload Org.

Thanks Nicolas,

My problem was I had org-alphabetical-lists defined _after_ the requires
for the exporter back ends in my .emacs so this didn't work for me.

Putting it before 

--8<---------------cut here---------------start------------->8---
;; Explicitly load required exporters
(require 'ox-html)
(require 'ox-latex)
(require 'ox-ascii)
--8<---------------cut here---------------end--------------->8---

and restarting Emacs fixed it for me.

Regards,
Bernt

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Filling bug with alphabetical lists
  2013-04-26  2:53       ` Bernt Hansen
@ 2013-04-26 12:17         ` Nicolas Goaziou
  0 siblings, 0 replies; 6+ messages in thread
From: Nicolas Goaziou @ 2013-04-26 12:17 UTC (permalink / raw)
  To: Bernt Hansen; +Cc: emacs-orgmode

Hello,

Bernt Hansen <bernt@norang.ca> writes:

> My problem was I had org-alphabetical-lists defined _after_ the requires
> for the exporter back ends in my .emacs so this didn't work for me.
>
> Putting it before 
>
> ;; Explicitly load required exporters
> (require 'ox-html)
> (require 'ox-latex)
> (require 'ox-ascii)
>
> and restarting Emacs fixed it for me.

I have updated `org-list-allow-alphabetical' docstring so it is less
surprising.

Thanks for bringing this up.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2013-04-26 12:53 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-04-24 15:11 Filling bug with alphabetical lists Bernt Hansen
2013-04-24 21:14 ` Nicolas Goaziou
2013-04-24 22:06   ` Bernt Hansen
2013-04-25  5:28     ` Nicolas Goaziou
2013-04-26  2:53       ` Bernt Hansen
2013-04-26 12:17         ` Nicolas Goaziou

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).