emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [beamer] Italic in overlay text
@ 2012-02-03 14:24 Sebastien Vauban
  2012-02-03 16:34 ` Eric S Fraga
  0 siblings, 1 reply; 6+ messages in thread
From: Sebastien Vauban @ 2012-02-03 14:24 UTC (permalink / raw)
  To: emacs-orgmode-mXXj517/zsQ

Hello,

When trying to have italic text inside some paragraph that must only be
displayed in some overlays, the text inside `/' is not converted into italic.

ECM:

--8<---------------cut here---------------start------------->8---
#+TITLE:     ECM
#+DATE:      2012-02-03
#+LANGUAGE:  en
#+OPTIONS:   H:3 num:t toc:t

#+startup: beamer
#+LaTeX_CLASS: beamer
#+LaTeX_CLASS_OPTIONS: [presentation,t]
#+BEAMER_HEADER_EXTRA: \usetheme{Madrid}\usecolortheme{default}
#+BEAMER_FRAME_LEVEL: 1
#+COLUMNS: %40ITEM %10BEAMER_env(Env) %10BEAMER_envargs(Env Args) %4BEAMER_col(Col) %8BEAMER_extra(Extra)

* Italic in overlay text

#+LaTeX: \only<1-2>{

- On overlay 1 and 2

  /This quoted text should be in italic./

  #+LaTeX: \textit{
  This is in italic, but only in PDF LaTeX, because of the workaround.
  #+LaTeX: }

#+LaTeX: }\pause

- Always there

#+LaTeX: \pause

- Idem

--8<---------------cut here---------------end--------------->8---

Best regards,
  Seb

-- 
Sebastien Vauban

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [beamer] Italic in overlay text
  2012-02-03 14:24 [beamer] Italic in overlay text Sebastien Vauban
@ 2012-02-03 16:34 ` Eric S Fraga
  2012-02-06 10:17   ` Sebastien Vauban
  0 siblings, 1 reply; 6+ messages in thread
From: Eric S Fraga @ 2012-02-03 16:34 UTC (permalink / raw)
  To: Sebastien Vauban; +Cc: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 511 bytes --]

Sebastien Vauban <wxhgmqzgwmuf@spammotel.com> writes:

> Hello,
>
> When trying to have italic text inside some paragraph that must only be
> displayed in some overlays, the text inside `/' is not converted into
> italic.

This does seem to highlight a bug in the exporter.  I cannot help you
directly with that.

However, I can suggest a more org-appropriate approach: lists understand
<1-2> type of syntax so you can change your input file to something like
the attached.  More concise and easier to read...


[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: t.org --]
[-- Type: text/org, Size: 593 bytes --]

#+TITLE:     ECM
#+DATE:      2012-02-03
#+LANGUAGE:  en
#+OPTIONS:   H:3 num:t toc:t

#+startup: beamer
#+LaTeX_CLASS: beamer
#+LaTeX_CLASS_OPTIONS: [presentation,t]
#+BEAMER_HEADER_EXTRA: \usetheme{Madrid}\usecolortheme{default}
#+BEAMER_FRAME_LEVEL: 1
#+COLUMNS: %40ITEM %10BEAMER_env(Env) %10BEAMER_envargs(Env Args)
%4BEAMER_col(Col) %8BEAMER_extra(Extra)

* Italic in overlay text

- <1-2> On overlay 1 and 2

  /This quoted text should be in italic./

  #+LaTeX: \textit{
  This is in italic, but only in PDF LaTeX, because of the workaround.
  #+LaTeX: }

- Always there

- <3-> Idem


[-- Attachment #3: Type: text/plain, Size: 153 bytes --]


Give it a try.

HTH,
eric
-- 
: Eric S Fraga (GnuPG: 0xC89193D8FFFCF67D) in Emacs 24.0.92.1
: using Org-mode version 7.8.03 (release_7.8.03.300.g9b820)

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [beamer] Italic in overlay text
  2012-02-03 16:34 ` Eric S Fraga
@ 2012-02-06 10:17   ` Sebastien Vauban
  2012-02-06 10:36     ` Eric S Fraga
  2012-02-06 10:40     ` Nicolas Goaziou
  0 siblings, 2 replies; 6+ messages in thread
From: Sebastien Vauban @ 2012-02-06 10:17 UTC (permalink / raw)
  To: emacs-orgmode-mXXj517/zsQ

Hi Eric,

Eric S Fraga wrote:
> Sebastien Vauban <wxhgmqzgwmuf-geNee64TY+gS+FvcfC7Uqw@public.gmane.org> writes:
>> When trying to have italic text inside some paragraph that must only be
>> displayed in some overlays, the text inside `/' is not converted into
>> italic.
>
> This does seem to highlight a bug in the exporter. I cannot help you
> directly with that.

I will try with Nicolas' new exporter to see if that's the same or not.

> However, I can suggest a more org-appropriate approach: lists understand
> <1-2> type of syntax so you can change your input file to something like the
> attached. More concise and easier to read...

You're absolutely right on the clarity level. Thanks for this workaround.

> - <1-2> On overlay 1 and 2
>
>   /This quoted text should be in italic./
>
>   #+LaTeX: \textit{
>   This is in italic, but only in PDF LaTeX, because of the workaround.
>   #+LaTeX: }
>
> - Always there
>
> - <3-> Idem

However, it does not work in the intended way: here, the text which has to
appear on the 2 first slides is simply made transparent on the 3^rd... It
still occupies its place.

I used `only' so that the text would be dropped, as (in my practice example,
not in this ECM) there is not enough space for showing the 3 bullets at the
same time.

I've tried the above within multiple different themes (Antibes, Bergen,
Madrid, ...) but that does not change anything: the space of the 1^st bullet
is still there, not reusable for the last 2 bullets.

Is this due to some configurable parameter?  Is there a way to make the above
Org writing behave as `only' (versus `uncover')?

Best regards,
  Seb

-- 
Sebastien Vauban

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [beamer] Italic in overlay text
  2012-02-06 10:17   ` Sebastien Vauban
@ 2012-02-06 10:36     ` Eric S Fraga
  2012-02-06 13:02       ` Sebastien Vauban
  2012-02-06 10:40     ` Nicolas Goaziou
  1 sibling, 1 reply; 6+ messages in thread
From: Eric S Fraga @ 2012-02-06 10:36 UTC (permalink / raw)
  To: Sebastien Vauban; +Cc: emacs-orgmode

Sebastien Vauban <wxhgmqzgwmuf@spammotel.com> writes:

> Hi Eric,
>
> Eric S Fraga wrote:
>> Sebastien Vauban <wxhgmqzgwmuf@spammotel.com> writes:
>>> When trying to have italic text inside some paragraph that must only be
>>> displayed in some overlays, the text inside `/' is not converted into
>>> italic.
>>
>> This does seem to highlight a bug in the exporter. I cannot help you
>> directly with that.
>
> I will try with Nicolas' new exporter to see if that's the same or not.
>
>> However, I can suggest a more org-appropriate approach: lists understand
>> <1-2> type of syntax so you can change your input file to something like the
>> attached. More concise and easier to read...
>
> You're absolutely right on the clarity level. Thanks for this workaround.
>
>> - <1-2> On overlay 1 and 2
>>
>>   /This quoted text should be in italic./
>>
>>   #+LaTeX: \textit{
>>   This is in italic, but only in PDF LaTeX, because of the workaround.
>>   #+LaTeX: }
>>
>> - Always there
>>
>> - <3-> Idem
>
> However, it does not work in the intended way: here, the text which has to
> appear on the 2 first slides is simply made transparent on the 3^rd... It
> still occupies its place.

Ah, yes, sorry.  The <...> goes directly to the \item latex construct
and that does an uncover, not an only operation.

I have little experience with \only other than with tikz diagrams as I
prefer my slides to not jump about; purely subjective opinion of what
works and what doesn't work for me!

Sorry I couldn't help much here.
-- 
: Eric S Fraga (GnuPG: 0xC89193D8FFFCF67D) in Emacs 24.0.92.1
: using Org-mode version 7.8.03 (release_7.8.03.319.g223b6)

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [beamer] Italic in overlay text
  2012-02-06 10:17   ` Sebastien Vauban
  2012-02-06 10:36     ` Eric S Fraga
@ 2012-02-06 10:40     ` Nicolas Goaziou
  1 sibling, 0 replies; 6+ messages in thread
From: Nicolas Goaziou @ 2012-02-06 10:40 UTC (permalink / raw)
  To: Sebastien Vauban; +Cc: public-emacs-orgmode-mXXj517/zsQ



"Sebastien Vauban"
<wxhgmqzgwmuf-geNee64TY+gS+FvcfC7Uqw@public.gmane.org> writes:

> Hi Eric,
>
> Eric S Fraga wrote:
>> Sebastien Vauban <wxhgmqzgwmuf-geNee64TY+gS+FvcfC7Uqw@public.gmane.org> writes:
>>> When trying to have italic text inside some paragraph that must only be
>>> displayed in some overlays, the text inside `/' is not converted into
>>> italic.
>>
>> This does seem to highlight a bug in the exporter. I cannot help you
>> directly with that.
>
> I will try with Nicolas' new exporter to see if that's the same or
> not.

I haven't followed closely the thread, but there is no Beamer back-end
for new exporter so far.

Speaking about it, I think it may be better to write it as a new
back-end instead of building it on top of the LaTeX one. It could re-use
existing functions with (defalias 'org-e-beamer-emphasis
'org-e-latex-emphasis), though.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [beamer] Italic in overlay text
  2012-02-06 10:36     ` Eric S Fraga
@ 2012-02-06 13:02       ` Sebastien Vauban
  0 siblings, 0 replies; 6+ messages in thread
From: Sebastien Vauban @ 2012-02-06 13:02 UTC (permalink / raw)
  To: emacs-orgmode-mXXj517/zsQ

Hi Eric,

Eric S Fraga wrote:
> Sebastien Vauban <wxhgmqzgwmuf-geNee64TY+gS+FvcfC7Uqw@public.gmane.org> writes:
>> Eric S Fraga wrote:
>>> Sebastien Vauban <wxhgmqzgwmuf-geNee64TY+gS+FvcfC7Uqw@public.gmane.org> writes:
>>>> When trying to have italic text inside some paragraph that must only be
>>>> displayed in some overlays, the text inside `/' is not converted into
>>>> italic.
>>>
>>> I can suggest a more org-appropriate approach: lists understand <1-2> type
>>> of syntax so you can change your input file to something like the
>>> attached. More concise and easier to read...
>>>
>>> - <1-2> On overlay 1 and 2
>>>
>>>   /This quoted text should be in italic./
>>>
>>>   #+LaTeX: \textit{
>>>   This is in italic, but only in PDF LaTeX, because of the workaround.
>>>   #+LaTeX: }
>>>
>>> - Always there
>>>
>>> - <3-> Idem
>>
>> However, it does not work in the intended way: here, the text which has to
>> appear on the 2 first slides is simply made transparent on the 3^rd... It
>> still occupies its place.
>
> Ah, yes, sorry.  The <...> goes directly to the \item latex construct
> and that does an uncover, not an only operation.

Maybe there should be some possibility to customize the itemize environment,
something extra to those lines:

--8<---------------cut here---------------start------------->8---
** Overlays
   :PROPERTIES:
   :BEAMER_envargs: [<+->]
   :END:

- One item
- Another one, after one click
- Last one, after another click
--8<---------------cut here---------------end--------------->8---

> I have little experience with \only other than with tikz diagrams as I
> prefer my slides to not jump about; purely subjective opinion of what
> works and what doesn't work for me!
>
> Sorry I couldn't help much here.

Thanks for having tried!

Best regards,
  Seb

-- 
Sebastien Vauban

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2012-02-06 13:02 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-02-03 14:24 [beamer] Italic in overlay text Sebastien Vauban
2012-02-03 16:34 ` Eric S Fraga
2012-02-06 10:17   ` Sebastien Vauban
2012-02-06 10:36     ` Eric S Fraga
2012-02-06 13:02       ` Sebastien Vauban
2012-02-06 10:40     ` Nicolas Goaziou

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).