emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Bug? in latex export of cross-references in footnotes
@ 2011-09-26 19:26 Robert Goldman
  2011-09-26 19:31 ` Robert Goldman
  0 siblings, 1 reply; 3+ messages in thread
From: Robert Goldman @ 2011-09-26 19:26 UTC (permalink / raw)
  To: Org Mode

[-- Attachment #1: Type: text/plain, Size: 578 bytes --]

Here is a simple footnote in a test file:

Footnotes:
[1]  The footnote contains a cross-reference to [[Heading]].

When I export this using org-export-as-pdf, the cross-reference to
Heading doesn't get exported properly.  In particular, what I see in the
emitted latex file is:

Inside the text there is a footnote.\protect\footnote{The footnote
contains a cross-reference to \hyperref[Heading]{Heading}. }

But the only latex \label associated with \section{Heading} is
\label{sec-1}.

I am attaching the sample org file and latex output.

Thanks for any suggestions!

Robert

[-- Attachment #2: footnote-crossref.org --]
[-- Type: text/plain, Size: 155 bytes --]

* Heading
* Another heading
* Some text
Inside the text there is a footnote.[1]

Footnotes: 
[1]  The footnote contains a cross-reference to [[Heading]].


[-- Attachment #3: footnote-crossref.tex --]
[-- Type: application/x-tex, Size: 830 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Bug? in latex export of cross-references in footnotes
  2011-09-26 19:26 Bug? in latex export of cross-references in footnotes Robert Goldman
@ 2011-09-26 19:31 ` Robert Goldman
  2011-10-09 12:11   ` Nicolas Goaziou
  0 siblings, 1 reply; 3+ messages in thread
From: Robert Goldman @ 2011-09-26 19:31 UTC (permalink / raw)
  To: Org Mode

[-- Attachment #1: Type: text/plain, Size: 953 bytes --]

On 9/26/11 Sep 26 -2:26 PM, Robert Goldman wrote:
> Here is a simple footnote in a test file:
> 
> Footnotes:
> [1]  The footnote contains a cross-reference to [[Heading]].
> 
> When I export this using org-export-as-pdf, the cross-reference to
> Heading doesn't get exported properly.  In particular, what I see in the
> emitted latex file is:
> 
> Inside the text there is a footnote.\protect\footnote{The footnote
> contains a cross-reference to \hyperref[Heading]{Heading}. }
> 
> But the only latex \label associated with \section{Heading} is
> \label{sec-1}.
> 
> I am attaching the sample org file and latex output.
> 
> Thanks for any suggestions!
> 
> Robert

I tweaked the example a little (see attachment), and this is a bona fide
bug.  A corresponding link in the body text (I have modified the link to
use the "restricted to headers" syntax, just in case that was the
problem), works properly.  It's only in the footnote that it's broken.


[-- Attachment #2: footnote-crossref.org --]
[-- Type: text/plain, Size: 224 bytes --]

* Heading
* Another heading
* Some text
Inside the text there is a footnote.[1]
* Some more text
Here's text with a link in the body: [[*Heading]].

Footnotes: 
[1]  The footnote contains a cross-reference to [[*Heading]].


[-- Attachment #3: footnote-crossref.tex --]
[-- Type: application/x-tex, Size: 936 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Bug? in latex export of cross-references in footnotes
  2011-09-26 19:31 ` Robert Goldman
@ 2011-10-09 12:11   ` Nicolas Goaziou
  0 siblings, 0 replies; 3+ messages in thread
From: Nicolas Goaziou @ 2011-10-09 12:11 UTC (permalink / raw)
  To: rpgoldman; +Cc: Org Mode

Hello,

Robert Goldman <rpgoldman@sift.info> writes:

> On 9/26/11 Sep 26 -2:26 PM, Robert Goldman wrote:
>> Here is a simple footnote in a test file:
>> 
>> Footnotes:
>> [1]  The footnote contains a cross-reference to [[Heading]].
>> 
>> When I export this using org-export-as-pdf, the cross-reference to
>> Heading doesn't get exported properly.  In particular, what I see in the
>> emitted latex file is:
>> 
>> Inside the text there is a footnote.\protect\footnote{The footnote
>> contains a cross-reference to \hyperref[Heading]{Heading}. }
>> 
>> But the only latex \label associated with \section{Heading} is
>> \label{sec-1}.
>> 
>> I am attaching the sample org file and latex output.
>> 
>> Thanks for any suggestions!
>> 
>> Robert
>
> I tweaked the example a little (see attachment), and this is a bona fide
> bug.  A corresponding link in the body text (I have modified the link to
> use the "restricted to headers" syntax, just in case that was the
> problem), works properly.  It's only in the footnote that it's broken.

Yes, managing internal links within a footnote is a non-trivial task in
the LaTeX exporter. I'm working on a different approach.

Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2011-10-09 12:12 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-09-26 19:26 Bug? in latex export of cross-references in footnotes Robert Goldman
2011-09-26 19:31 ` Robert Goldman
2011-10-09 12:11   ` Nicolas Goaziou

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).