emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Ihor Radchenko <yantar92@gmail.com>
To: Michael Dauer <mick.dauer@gmail.com>
Cc: emacs-orgmode@gnu.org
Subject: Re: BUG?: Link to inline-task not working
Date: Fri, 03 Dec 2021 18:51:44 +0800	[thread overview]
Message-ID: <875ys6m05b.fsf@localhost> (raw)
In-Reply-To: <CAP7OBx+XotYiRLVACMYgqv5iBHOEgsHi08wD7=E6umvArRyoLg@mail.gmail.com>

Michael Dauer <mick.dauer@gmail.com> writes:

> Before (require 'org-inlinetask) all is fine. But after executing (require
> 'org-inlinetask) the following happens:
> 1. With point on/in t1 (org-store-link) stores *h2.
> 2. The manually created link below h1 works in the buffer. But it is
> exported as BROKEN LINK.

Confirmed.

> Any ideas how to get fully working links to inline-tasks?

I have the following in my config to mitigate this problem:

(defun org-inlinetask-store-link (oldfun &rest args)
  "Store link to inlinetask at point."
  (if (and (derived-mode-p 'org-mode)
	   (org-inlinetask-in-task-p))
      (let ((org-inlinetask-min-level 1000))
	(apply oldfun args))
    (apply oldfun args)))

(advice-add 'org-store-link :around #'org-inlinetask-store-link)

Best,
Ihor


  reply	other threads:[~2021-12-03 10:51 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-12-03  8:30 Michael Dauer
2021-12-03 10:51 ` Ihor Radchenko [this message]
2021-12-03 14:20   ` Michael Dauer
2021-12-04  3:19     ` Ihor Radchenko
2021-12-06 13:14       ` Michael Dauer
2021-12-06 13:47         ` Ihor Radchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=875ys6m05b.fsf@localhost \
    --to=yantar92@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --cc=mick.dauer@gmail.com \
    --subject='Re: BUG?: Link to inline-task not working' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).