emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Eric S Fraga <e.fraga@ucl.ac.uk>
To: "Levy, Roger" <rlevy@ucsd.edu>
Cc: "emacs-orgmode@gnu.org" <emacs-orgmode@gnu.org>
Subject: Re: "No definition for class" error in export to latex
Date: Wed, 15 Jun 2011 20:08:09 +0100	[thread overview]
Message-ID: <874o3qq5eu.fsf@ucl.ac.uk> (raw)
In-Reply-To: <3134F11C-4D50-42A7-B160-7C8C921D5798@ucsd.edu> (Roger Levy's message of "Sat, 11 Jun 2011 13:11:14 -0700")

"Levy, Roger" <rlevy@ucsd.edu> writes:

> Hi,
>
> I am an org-mode newbie and trying to learn how to export to latex and
> html from the command line, and have encountered a difficulty when I
> include a custom class in the latex header.  Here's a sample file
> ("test-file.org") I'm using:
>
> ***
>
> #+TITLE: Test
> #+LaTeX_CLASS: apa
>
> file contents
>
> ***
>
> and here is the command I'm using:
>
> /Applications/Aquamacs.app/Contents/MacOS/Aquamacs -batch \
>     --visit=test-file.org \
>     --funcall org-export-as-latex-batch
>
> which gives me the output
>
> OVERVIEW
> Exporting to LaTeX...
> No definition for class `apa' in `org-export-latex-classes'
>
> and no .tex file output.  From within Aquamacs, I don't get this error, presumably because I have the following in my .emacs file:
>
> (add-to-list 'org-export-latex-classes
> 	     '("apa"
> 	       "\\documentclass{apa}
>                [NO-DEFAULT-PACKAGES]
>                \\usepackage{graphicx}
>                \\usepackage{apacite}"
> 	       ("\\section{%s}" . "\\section*{%s}")
> 	       ("\\subsection{%s}" . "\\subsection*{%s}")
> 	       ("\\subsubsection{%s}" . "\\subsubsection*{%s}")
> ))
>
> How can I make this modification of org-export-latex-classes from the command line?  I have tried putting the above content in a file ("$HOME/tmp/add.el") and making the call
>
> /Applications/Aquamacs.app/Contents/MacOS/Aquamacs -batch \
>     --load $HOME/tmp/add.el \
>     --visit=test-file.org \
>     --funcall org-export-as-latex-batch
>
> but this gives me the error
>
>   Symbol's value as variable is void: org-export-latex-classes
>
> I would be very grateful for any suggestions!  This is GNU Emacs
> 23.3.1 (Aquamacs 2.2) and Org mode 7.5.

I don't use this version of Emacs (not on a Mac) so cannot guarantee
anything I say will be relevant... but have you tried adding

   (require 'org-latex)

before you set the org-export-latex-classes variable?  I'm assuming that
org mode is actually already loaded by default.

HTH.

-- 
: Eric S Fraga (GnuPG: 0xC89193D8FFFCF67D) in Emacs 24.0.50.1
: using Org-mode version 7.5 (release_7.5.391.gfaccb.dirty)

      parent reply	other threads:[~2011-06-15 19:08 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-06-11 20:11 Levy, Roger
2011-06-11 23:37 ` Nick Dokos
2011-06-12  2:10   ` Levy, Roger
2011-06-15 19:08 ` Eric S Fraga [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=874o3qq5eu.fsf@ucl.ac.uk \
    --to=e.fraga@ucl.ac.uk \
    --cc=emacs-orgmode@gnu.org \
    --cc=rlevy@ucsd.edu \
    --subject='Re: "No definition for class" error in export to latex' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).