emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Can not export to LaTeX anymore
@ 2011-09-27  6:50 Henri-Paul Indiogine
  2011-09-27  7:31 ` Henri-Paul Indiogine
  0 siblings, 1 reply; 5+ messages in thread
From: Henri-Paul Indiogine @ 2011-09-27  6:50 UTC (permalink / raw)
  To: emacs-org

Greetings!

I had to change computer.  I have Ubuntu Linux 10.10, fully updated,
emacs snapshot updated and AucTeX and org-mode fully updated.

I get the following in my *Messages* buffer the following after
running C-c C-e l (for LaTeX export)

(fontified nil font-lock-fontified t) 73 74 (fontified nil
font-lock-fontified t) 74 115 (fontified nil font-lock-fontified t)
115 116 (fontified nil font-lock-fontified t) 116 117 (fontified nil
font-lock-fontified t) 117 358 (fontified nil font-lock-fontified t)
358 66238 (fontified nil font-lock-fontified t) 66238 66239 (fontified
nil font-lock-fontified t) 66239 66248 (fontified nil
font-lock-fontified t) 66248 66249 (fontified nil) 66249 66250
(fontified nil) 66250 66252 (fontified nil) 66252 66256 (fontified
nil) 66256 66294 (fontified nil) 66294 66300 (fontified nil) 66300
66322 (fontified nil) 66322 66326 (fontified nil) 66326 66327
(fontified nil rear-nonsticky (mouse-face
........


This has never occurred to me before and I am at a loss here.   No tex
file is created.


Thanks,
Henri-Paul


-- 
Henri-Paul Indiogine

Curriculum & Instruction
Texas A&M University
TutorFind Learning Centre

Email: hindiogine@gmail.com
Skype: hindiogine
Website: http://people.cehd.tamu.edu/~sindiogine

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Can not export to LaTeX anymore
  2011-09-27  6:50 Can not export to LaTeX anymore Henri-Paul Indiogine
@ 2011-09-27  7:31 ` Henri-Paul Indiogine
  2011-09-27  7:42   ` Sebastien Vauban
  0 siblings, 1 reply; 5+ messages in thread
From: Henri-Paul Indiogine @ 2011-09-27  7:31 UTC (permalink / raw)
  To: emacs-org

The situation is more complicated.  I can not even export to plain
text.  I obtain the same error messages.

I uninstalled Emacs-snapshot = 24 and installed the 'stable' version,
23.   I get the same error messages.

Then I tried to make a simple test org file for export to plain text.
 That also fails with the following error message:


Wrong type argument: stringp, |



Thanks for your feedback,
Henri-Paul


2011/9/26 Henri-Paul Indiogine <hindiogine@gmail.com>:
> (fontified nil font-lock-fontified t) 73 74 (fontified nil
> font-lock-fontified t) 74 115 (fontified nil font-lock-fontified t)
> 115 116 (fontified nil font-lock-fontified t) 116 117 (fontified nil
> font-lock-fontified t) 117 358 (fontified nil font-lock-fontified t)
> 358 66238 (fontified nil font-lock-fontified t) 66238 66239 (fontified
> nil font-lock-fontified t) 66239 66248 (fontified nil
> font-lock-fontified t) 66248 66249 (fontified nil) 66249 66250
> (fontified nil) 66250 66252 (fontified nil) 66252 66256 (fontified
> nil) 66256 66294 (fontified nil) 66294 66300 (fontified nil) 66300
> 66322 (fontified nil) 66322 66326 (fontified nil) 66326 66327
> (fontified nil rear-nonsticky (mouse-face
> ........
>
>
> This has never occurred to me before and I am at a loss here.   No tex
> file is created.
>
>
> Thanks,
> Henri-Paul
>
>
> --
> Henri-Paul Indiogine
>
> Curriculum & Instruction
> Texas A&M University
> TutorFind Learning Centre
>
> Email: hindiogine@gmail.com
> Skype: hindiogine
> Website: http://people.cehd.tamu.edu/~sindiogine
>



-- 
Henri-Paul Indiogine

Curriculum & Instruction
Texas A&M University
TutorFind Learning Centre

Email: hindiogine@gmail.com
Skype: hindiogine
Website: http://people.cehd.tamu.edu/~sindiogine

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Can not export to LaTeX anymore
  2011-09-27  7:31 ` Henri-Paul Indiogine
@ 2011-09-27  7:42   ` Sebastien Vauban
  2011-10-14  8:47     ` daniel
  0 siblings, 1 reply; 5+ messages in thread
From: Sebastien Vauban @ 2011-09-27  7:42 UTC (permalink / raw)
  To: emacs-orgmode-mXXj517/zsQ

Hi Henri-Paul,

Henri-Paul Indiogine wrote:
> The situation is more complicated.  I can not even export to plain
> text.  I obtain the same error messages.
>
> I uninstalled Emacs-snapshot = 24 and installed the 'stable' version,
> 23.   I get the same error messages.
>
> Then I tried to make a simple test org file for export to plain text.
>  That also fails with the following error message:
>
>
> Wrong type argument: stringp, |

Could you:

- tell which Org version you're using (M-x org-version)?
- (setq debug-on-error t)?
- give us a small ECM?

Best regards,
  Seb

-- 
Sebastien Vauban

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Can not export to LaTeX anymore
  2011-09-27  7:42   ` Sebastien Vauban
@ 2011-10-14  8:47     ` daniel
  2011-10-15 10:47       ` Daniel Brunner
  0 siblings, 1 reply; 5+ messages in thread
From: daniel @ 2011-10-14  8:47 UTC (permalink / raw)
  To: public-emacs-orgmode-mXXj517/zsQ




Hi, 

I face a similar problem with my org-mode. So several months my
org-mode installation won't export to LaTeX and as I noticed today the
export of a project with org-jekyll etc. doesn't work either (but I do
not cover that error in this post):

- GNU Emacs 23.1.1 (x86_64-pc-linux-gnu, GTK+ Version 2.20.1)\n of 2011-03-04 on allspice, modified by Debian

- I installed org-mode via a git repository in my home directory and put
  the following lines in my .emacs file:

  (setq load-path (cons "/home/dbr/sw/org-mode/lisp" load-path))
  (setq load-path (cons "/home/dbr/sw/org-mode/contrib/lisp" load-path))
  (require 'org-install)

- Therefore org-version is: Org-mode version 7.7 (release_7.7.380.g54d7df.dirty)

I then created a file "a.org":

--8<--
#+TITLE:     a.org
#+AUTHOR:    Daniel 
#+EMAIL:     daniel@monkey
#+DATE:      2011-10-14 Fr
#+DESCRIPTION:
#+KEYWORDS:
#+LANGUAGE:  en
#+OPTIONS:   H:3 num:t toc:t \n:nil @:t ::t |:t ^:t -:t f:t *:t <:t
#+OPTIONS:   TeX:t LaTeX:t skip:nil d:nil todo:t pri:nil tags:not-in-toc
#+INFOJS_OPT: view:nil toc:nil ltoc:t mouse:underline buttons:0 path:http://orgmode.org/org-info.js
#+EXPORT_SELECT_TAGS: export
#+EXPORT_EXCLUDE_TAGS: noexport
#+LINK_UP:   
#+LINK_HOME: 
#+XSLT:

* Heading 

Export me !
--8<--
The options have been included with C-c C-e t.

After a org-export-as-latex I got the message: 

org-export-preprocess-string: Cannot open load file: org-nil

The *Backtrace* is:

--8<--
Debugger entered--Lisp error: (file-error "Cannot open load file" "org-nil")
  require(org-nil nil)
  org-export-preprocess-string(#("#+TITLE:     a.org\n#+AUTHOR:    Daniel\n#+EMAIL:     daniel@monkey\n#+DATE:      2011-10-14 Fr\n#+DESCRIPTION:\n#+KEYWORDS:\n#+LANGUAGE:  en\n#+OPTIONS:   H:3 num:t toc:t \\n:nil @:t ::t |:t ^:t -:t f:t *:t <:t\n#+OPTIONS:   TeX:t LaTeX:t skip:nil d:nil todo:t pri:nil tags:not-in-toc\n#+INFOJS_OPT: view:nil toc:nil ltoc:t mouse:underline buttons:0 path:http://orgmode.org/org-info.js\n#+EXPORT_SELECT_TAGS: export\n#+EXPORT_EXCLUDE_TAGS: noexport\n#+LINK_UP:   \n#+LINK_HOME: \n#+XSLT:\n\n" 0 8 (fontified nil font-lock-fontified t) 8 13 (fontified nil) 13 18 (fontified nil font-lock-fontified t) 18 19 (fontified nil font-lock-fontified t) 19 28 (fontified nil font-lock-fontified t) 28 32 (fontified nil font-lock-fontified t) 32 38 (fontified nil font-lock-fontified t) 38 39 (fontified nil) 39 47 (fontified nil font-lock-fontified t) 47 52 (fontified nil) 52 65 (fontified nil font-lock-fontified t) 65 66 (fontified nil) 66 73 (fontified nil font-lock-fontified t) 73 79 (fontified nil) 79 92 (fontified nil font-lock-fontified t) 92 93 (fontified nil) 93 107 (fontified nil font-lock-fontified t) 107 108 (fontified nil font-lock-fontified t) 108 119 (fontified nil font-lock-fontified t) 119 120 (fontified nil font-lock-fontified t) 120 135 (fontified nil font-lock-fontified t) 135 136 (fontified nil font-lock-fontified t) 136 203 (fontified nil font-lock-fontified t) 203 204 (fontified nil font-lock-fontified t) 204 276 (fontified nil font-lock-fontified t) 276 277 (fontified nil font-lock-fontified t) 277 346 (fontified nil font-lock-fontified t) 346 375 (fontified nil font-lock-fontified t) 375 376 (fontified nil rear-nonsticky (mouse-face highlight keymap invisible intangible help-echo org-linked-text) font-lock-fontified t) 376 377 (fontified nil font-lock-fontified t) 377 405 (fontified nil font-lock-fontified t) 405 406 (fontified nil font-lock-fontified t) 406 437 (fontified nil font-lock-fontified t) 437 438 (fontified nil font-lock-fontified t) 438 451 (fontified nil font-lock-fontified t) 451 452 (fontified nil font-lock-fontified t) 452 465 (fontified nil font-lock-fontified t) 465 466 (fontified nil font-lock-fontified t) 466 473 (fontified nil font-lock-fontified t) 473 474 (fontified nil font-lock-fontified t) 474 475 (fontified nil)) :for-LaTeX t :emph-multiline t :add-text nil :comments nil :skip-before-1st-heading nil :LaTeX-fragments nil :timestamps t :footnotes t)
  org-export-latex-first-lines((:latex-image-options "width=10em" :exclude-tags ("noexport") :select-tags ("export") :publishing-directory nil :timestamp nil :expand-quoted-html t :html-table-tag "<table border=\"2\" cellspacing=\"0\" cellpadding=\"6\" rules=\"groups\" frame=\"hsides\">" :xml-declaration (("html" . "<?xml version=\"1.0\" encoding=\"%s\"?>") ("php" . "<?php echo \"<?xml version=\\\"1.0\\\" encoding=\\\"%s\\\" ?>\"; ?>")) :html-postamble auto :html-preamble t :html-extension "html" :inline-images maybe :convert-org-links t :agenda-style "" :style-extra "" :style "" :style-include-scripts t :style-include-default t :table-auto-headline t :tables t :time-stamp-file t :creator-info t :email-info nil :author-info t :email "daniel@monkey" ...) nil)
  org-export-as-latex(nil)
  call-interactively(org-export-as-latex)
  org-export(nil)
  call-interactively(org-export nil nil)
--8<--

I read in an older post that there may be a problem with parts of the
old installation that is still "somewhere". But I installed the newest
version as written in the manual.


Kind regards,


Daniel 

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Can not export to LaTeX anymore
  2011-10-14  8:47     ` daniel
@ 2011-10-15 10:47       ` Daniel Brunner
  0 siblings, 0 replies; 5+ messages in thread
From: Daniel Brunner @ 2011-10-15 10:47 UTC (permalink / raw)
  To: emacs-orgmode

Hi!

Well, in the meantime I found the error and a workaround. It resulted
from an (require 'org-export-latex) somewhere in my .emacs because I
wanted to add some LaTeX export definitions to
org-export-latex-classes. The effect was the the very old org-latex.el
(v 6.21) from the original Emacs distribution has been loaded and that
didn't work with the rest of the 7.7 org-mode distribution. 

I was thinking, that the new org-mode gets rid of old parts. I changed
the (require 'org-export-latex) to (require 'org-latex) and then it
worked (because the newest org-latex exports org-latex as well as
org-export-latex).

Kind regards, Daniel

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2011-10-15 10:47 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-09-27  6:50 Can not export to LaTeX anymore Henri-Paul Indiogine
2011-09-27  7:31 ` Henri-Paul Indiogine
2011-09-27  7:42   ` Sebastien Vauban
2011-10-14  8:47     ` daniel
2011-10-15 10:47       ` Daniel Brunner

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).