emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Dima Kogan <emacs@dima.secretsauce.net>
To: emacs-orgmode@gnu.org
Subject: Re: Bug: Following a link to a #+NAME causes '(wrong-type-argument stringp nil)' [9.3 (release_9.3 @ /usr/share/emacs/28.0.50/lisp/org/)]
Date: Mon, 30 Nov 2020 21:19:47 -0800	[thread overview]
Message-ID: <874kl6ayrw.fsf@dima.secretsauce.net> (raw)
In-Reply-To: <87mtyyt8e5.fsf@kyleam.com>

Kyle Meyer <kyle@kyleam.com> writes:

> Thanks for the report.  As suggested in Dante's reply, the blank line
> following #+name is invalid syntax.
>
>   https://orgmode.org/worg/dev/org-syntax.html#Affiliated_keywords
>
> On maint (3bb073b63), the type error is now avoided for invalid name
> keywords.  No attempt is made to match these keywords, though, so your
> example won't lead to a match aside from through a fuzzy text search
> when org-link-search-must-match-exact-headline is nil.

Thank you Kyle, Dante. I was using the wrong thing. I should have been
using the CUSTOM_ID property instead of the #+NAME tag. This was my
fault. I guess the fact that #+NAME was ALMOST working the way I wanted
it to increased my confusion. And the unhelpful error message.

Thanks again


      reply	other threads:[~2020-12-01 21:08 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-22 20:44 Dima Kogan
2020-11-27  4:49 ` Dante Catalfamo
2020-12-01  5:14 ` Kyle Meyer
2020-12-01  5:19   ` Dima Kogan [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=874kl6ayrw.fsf@dima.secretsauce.net \
    --to=emacs@dima.secretsauce.net \
    --cc=emacs-orgmode@gnu.org \
    --subject='Re: Bug: Following a link to a #+NAME causes '\''(wrong-type-argument stringp nil)'\'' [9.3 (release_9.3 @ /usr/share/emacs/28.0.50/lisp/org/)]' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).