emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* ?bug in org-fold-core
@ 2022-08-04  8:05 Sharon Kimble
  2022-08-04  8:50 ` Ihor Radchenko
  0 siblings, 1 reply; 7+ messages in thread
From: Sharon Kimble @ 2022-08-04  8:05 UTC (permalink / raw)
  To: emacs-orgmode

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

I've just updated to 'Org mode version 9.5.4 (release_9.5.4-706-g4702a7 @ /home/boudiccas/git/org-mode/lisp/)' and I'm getting this error report from org-fold-core (I think) -

=====
Debugger entered--Lisp error: (error "Calling ‘org-fold-core-region’ with missing SPEC")
  signal(error ("Calling ‘org-fold-core-region’ with missing SPEC"))
  error("Calling `org-fold-core-region' with missing SPEC")
  org-fold-core-region(652018 652093 t outline)
  org-cycle-content--text-properties(2)
  org-content(2)
  eval((org-content 2) t)
  #f(compiled-function (var val) "Set local variable VAR with value VAL.\nIf VAR is `mode', call `VAL-mode' as a function unless it's\nalready the major mode." #<bytecode 0x18c3ed15a476992f>)(eval (org-content 2))
  apply(#f(compiled-function (var val) "Set local variable VAR with value VAL.\nIf VAR is `mode', call `VAL-mode' as a function unless it's\nalready the major mode." #<bytecode 0x18c3ed15a476992f>) (eval (org-content 2)))
  hack-one-local-variable(eval (org-content 2))
  hack-local-variables-apply()
  hack-local-variables(ignore-mode-settings)
  org-mode()
  set-auto-mode-0(org-mode nil)
  set-auto-mode()
  normal-mode(t)
  after-find-file(nil t)
  find-file-noselect-1(#<buffer instructions.org> "~/.emacs.d/org/instructions.org" nil nil "~/.emacs.d/org/instructions.org" (34277755 2068))
  find-file-noselect("/home/boudiccas/.emacs.d/org/instructions.org")
  desktop-restore-file-buffer("/home/boudiccas/.emacs.d/org/instructions.org" "instructions.org" nil)
  byte-code("\10\11\236A\206\10\0\305\n\13\f#\207" [desktop-buffer-major-mode desktop-buffer-mode-handlers desktop-buffer-file-name desktop-buffer-name desktop-buffer-misc desktop-restore-file-buffer] 4)
  desktop-create-buffer(206 "/home/boudiccas/.emacs.d/org/instructions.org" "instructions.org" org-mode (auto-fill-mode abbrev-mode visual-line-mode override-global-mode anzu-mode auto-complete-mode TeX-PDF-mode highlight-symbol-mode global-auto-revert-mode org-indent-mode flyspell-mode yas-minor-mode undo-tree-mode hi-lock-mode guide-key-mode hungry-delete-mode which-key-mode flx-ido-mode ivy-mode wrap-region-mode google-this-mode org-autolist-mode project-persist-mode super-save-mode ivy-explorer-mode counsel-mode auto-capitalize) 13221 (13959 nil) nil nil ((indent-tabs-mode) (buffer-display-time 25316 54568 39118 551000) (buffer-file-coding-system . utf-8-unix) (truncate-lines)))
  eval-buffer(#<buffer  *load*-245945> nil "/home/boudiccas/.emacs.d/desktop/emacs.desktop" nil t)  ; Reading at buffer position 24870
  load-with-code-conversion("/home/boudiccas/.emacs.d/desktop/emacs.desktop" "/home/boudiccas/.emacs.d/desktop/emacs.desktop" t t)
  load("/home/boudiccas/.emacs.d/desktop/emacs.desktop" t t t)
  desktop-read()
  eval-buffer(#<buffer  *load*-137324> nil "/home/boudiccas/.emacs.d/config22.el" nil t)  ; Reading at buffer position 478700
  load-with-code-conversion("/home/boudiccas/.emacs.d/config22.el" "/home/boudiccas/.emacs.d/config22.el" nil nil)
  load("/home/boudiccas/.emacs.d/config22.el" nil nil t)
  load-file("~/.emacs.d/config22.el")
  org-babel-load-file("~/.emacs.d/config22.org")
  eval-buffer(#<buffer  *load*> nil "/home/boudiccas/.emacs.d/init.el" nil t)  ; Reading at buffer position 471
  load-with-code-conversion("/home/boudiccas/.emacs.d/init.el" "/home/boudiccas/.emacs.d/init.el" t t)
  load("/home/boudiccas/.emacs.d/init" noerror nomessage)
  startup--load-user-init-file(#f(compiled-function () #<bytecode -0x177562bdbd07ff8b>) #f(compiled-function () #<bytecode -0x1f3c6feddc0abd75>) t)
  command-line()
  normal-top-level()
=====

I've attempted to run bug-hunter-file against it, and its says that there are no problems with it, so I'm puzzled as to what's going on?

Is it a bug against org-fold-core, or something in my file, please?    

Thanks
    Sharon.
- -- 
A taste of linux = http://www.sharons.org.uk
TGmeds = http://www.tgmeds.org.uk
DrugFacts = https://www.drugfacts.org.uk
Debian 11, fluxbox 1.3.7, emacs 29.0.50, org 9.5.4
-----BEGIN PGP SIGNATURE-----

iQJRBAEBCgA7FiEELSc/6QwVBIYugJDbNoGAGQr4g1sFAmLrfdQdHGJvdWRpY2Nh
c0Bza2ltYmxlMDkucGx1cy5jb20ACgkQNoGAGQr4g1vsXg/9ENnsH0lYkYud0xkG
xnPVO8tvhky02beb0vXU8EEnEdz9Kl0xOnh8Jl0x7/Jfc4MG4dWjfEXSq2Axd4Pp
g83CH76gOYZvd+93X8RbzyoSr6QFtfH76o5i/RMh71LD9C1OpBKYasYuGjsKhyQy
lRBnYDL0UCGGbnm4OVI3iHUDhtPZBd248lRfTzDSpSW4Pn1RzjexTgRuyXwa7s01
Nqd/9u1/ihyZaxkRAuUA8eR2tpFSP/AyHdtf8U/7cy5afBhNj+mgrT3G8s1NjPAM
3ChowAt9ZgxVmQaTrxbSVHsh0HONJuOZtUARCJoOu7HAyb5imTSG5XqSZbALD6yF
OmrfA5c8VywXw738oiYCc3el8AvC3gVI6lrLDcQWGy7GFVUV+t7PjSf3MixeWY7p
9wLlthpMl3g6mL9On7+cZx4HTdeu+032PpsvaPdjvQLC3btnDBi3qf+/b/ym6bOs
mjI/T4YilYTbZQYSPILPX94j4MDWrb6U4N5iWbLFrZjAqsURJiIi5OG99nsRfcau
pY8bJDfJWDs9C5UrdYvMQxj0L2z0dAfmaufFi6thuhf5bG64QvE/37UwihxYczT8
YsXI7H2GtjIxzKQBLYy1NJRTI8l7b0NaoP8oa/P9jAT3ZLcn5EcUIiX3fgYUiDjW
ckOssPZPNISplNF3IARIOEAhfrs=
=O87p
-----END PGP SIGNATURE-----


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: ?bug in org-fold-core
  2022-08-04  8:05 ?bug in org-fold-core Sharon Kimble
@ 2022-08-04  8:50 ` Ihor Radchenko
  2022-08-04  9:38   ` Sharon Kimble
  0 siblings, 1 reply; 7+ messages in thread
From: Ihor Radchenko @ 2022-08-04  8:50 UTC (permalink / raw)
  To: Sharon Kimble; +Cc: emacs-orgmode

Sharon Kimble <boudiccas@skimble09.plus.com> writes:

> I've just updated to 'Org mode version 9.5.4 (release_9.5.4-706-g4702a7 @ /home/boudiccas/git/org-mode/lisp/)' and I'm getting this error report from org-fold-core (I think) -
>
> =====
> Debugger entered--Lisp error: (error "Calling ‘org-fold-core-region’ with missing SPEC")
>   signal(error ("Calling ‘org-fold-core-region’ with missing SPEC"))
>   error("Calling `org-fold-core-region' with missing SPEC")
>   org-fold-core-region(652018 652093 t outline)
>   org-cycle-content--text-properties(2)
>   org-content(2)
>   eval((org-content 2) t)
>   #f(compiled-function (var val) "Set local variable VAR with value VAL.\nIf VAR is `mode', call `VAL-mode' as a function unless it's\nalready the major mode." #<bytecode 0x18c3ed15a476992f>)(eval (org-content 2))
>   apply(#f(compiled-function (var val) "Set local variable VAR with value VAL.\nIf VAR is `mode', call `VAL-mode' as a function unless it's\nalready the major mode." #<bytecode 0x18c3ed15a476992f>) (eval (org-content 2)))
>   hack-one-local-variable(eval (org-content 2))
>   hack-local-variables-apply()
>   hack-local-variables(ignore-mode-settings)
>   org-mode()

This is not a bug. This is a changed behaviour of file-local variables.
Now, they are loaded early before most of the Org setup is done in the
buffer; before folding is configured. Hence, the error.

Note that a proper setting of startup visibility should be done via
#+startup keyword:

#+STARTUP: show2levels

Best,
Ihor


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: ?bug in org-fold-core
  2022-08-04  8:50 ` Ihor Radchenko
@ 2022-08-04  9:38   ` Sharon Kimble
  2022-08-04  9:48     ` Ihor Radchenko
  0 siblings, 1 reply; 7+ messages in thread
From: Sharon Kimble @ 2022-08-04  9:38 UTC (permalink / raw)
  To: Ihor Radchenko; +Cc: emacs-orgmode

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Ihor Radchenko <yantar92@gmail.com> writes:

> Sharon Kimble <boudiccas@skimble09.plus.com> writes:
>
>> I've just updated to 'Org mode version 9.5.4 (release_9.5.4-706-g4702a7 @ /home/boudiccas/git/org-mode/lisp/)' and I'm getting this error report from org-fold-core (I think) -
>>
>> =====
>> Debugger entered--Lisp error: (error "Calling ‘org-fold-core-region’ with missing SPEC")
>>   signal(error ("Calling ‘org-fold-core-region’ with missing SPEC"))
>>   error("Calling `org-fold-core-region' with missing SPEC")
>>   org-fold-core-region(652018 652093 t outline)
>>   org-cycle-content--text-properties(2)
>>   org-content(2)
>>   eval((org-content 2) t)
>>   #f(compiled-function (var val) "Set local variable VAR with value VAL.\nIf VAR is `mode', call `VAL-mode' as a function unless it's\nalready the major mode." #<bytecode 0x18c3ed15a476992f>)(eval (org-content 2))
>>   apply(#f(compiled-function (var val) "Set local variable VAR with value VAL.\nIf VAR is `mode', call `VAL-mode' as a function unless it's\nalready the major mode." #<bytecode 0x18c3ed15a476992f>) (eval (org-content 2)))
>>   hack-one-local-variable(eval (org-content 2))
>>   hack-local-variables-apply()
>>   hack-local-variables(ignore-mode-settings)
>>   org-mode()
>
> This is not a bug. This is a changed behaviour of file-local variables.
> Now, they are loaded early before most of the Org setup is done in the
> buffer; before folding is configured. Hence, the error.
>
> Note that a proper setting of startup visibility should be done via
> #+startup keyword:
>
> #+STARTUP: show2levels
>
Thanks for replying.

I now have this showing in my 'instructions.org'
=====
# -*- coding: utf-8; mode: org -*-
#+STARTUP: show2levels

#     #+STARTUP: overview     
=====

This file seems to be showing most of the problems, and looking at it in 'org-lint' there are many problems. But this file is just some problems that I've found and their solutions, so it shows the wrong way
    to do something and then the correct way. Is it possible for it to have a file-only way of reverting to the old way of 'file-local variables' please? As it currently stands, no org-headings are
    shown in the colours that other org-files are showing them, and its giving the appearance of org-mode not reading and displaying it!

Thanks
    Sharon.    
- -- 
A taste of linux = http://www.sharons.org.uk
TGmeds = http://www.tgmeds.org.uk
DrugFacts = https://www.drugfacts.org.uk
Debian 11, fluxbox 1.3.7, emacs 29.0.50, org 9.5.4
-----BEGIN PGP SIGNATURE-----

iQJRBAEBCgA7FiEELSc/6QwVBIYugJDbNoGAGQr4g1sFAmLrk6kdHGJvdWRpY2Nh
c0Bza2ltYmxlMDkucGx1cy5jb20ACgkQNoGAGQr4g1sVEg/+P8SaFo8ahnpmiaIX
5Ckv5gS8KFIQOPE3cEX0pHs5d9RTHPJiHhGQ2CodgnqhAExU0ppvK3z4uIkmw6ln
YJoHhd/eLWAt2BpnktJ6TDHDIohdtG8ih8U1re5DqZMASSTPRBgsKhvadYMGHCU3
q5nYgfd26A0TB3i6qRgVPrlaUzGfMTM4TozI0KnuAoOa8IDh7dSRHMusZDsjNpuN
Z8TJN79rXxAkz6lSL5C1cgkykJqm1nG7zPdq09tdPIwuartBrnPsrHmAA6EFDOv2
hYpSh91AORaAV8/sSffyy7IX58DWDL6AQ+HBvWGtuR5f3xLV4mP3MnP3YF44DpTr
HeTdZt4KjPlpZSqcuv36Zko9k2idX1BNWHZCc0e7ZpTAGVP0j+s7qqycejrerZfR
R8L07O4uJ1sSZJJ8tupp9NnQMVpznvF5xxjfq7uG8pbIvM7eKbqpbJWMzea8949P
YM2zxcLa08fk6SeV27riK0Bm4R37ERuaPfZefFyxxsIWD4xH4elQqDQSvxQr7TZl
bv3R9Jm72jM+tEcWzh4dr1re/lErpvKJuWiTcuf5TtUwujY7wOIBSH8oPDxReeWE
GMMrybHjO7dk5TArCMkSGfYrDvgW6M8MB2BFeMeqJxZa8WJFnRkq3/Va1FQkLhGt
eDJF7uaJkx9e2t+OmcWxsI9MT5U=
=4yAA
-----END PGP SIGNATURE-----


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: ?bug in org-fold-core
  2022-08-04  9:38   ` Sharon Kimble
@ 2022-08-04  9:48     ` Ihor Radchenko
  2022-08-04 10:41       ` Sharon Kimble
  0 siblings, 1 reply; 7+ messages in thread
From: Ihor Radchenko @ 2022-08-04  9:48 UTC (permalink / raw)
  To: Sharon Kimble; +Cc: emacs-orgmode

Sharon Kimble <boudiccas@skimble09.plus.com> writes:

> I now have this showing in my 'instructions.org'
> =====
> # -*- coding: utf-8; mode: org -*-
> #+STARTUP: show2levels
>
> #     #+STARTUP: overview     
> =====
>
> This file seems to be showing most of the problems, and looking at it in 'org-lint' there are many problems. But this file is just some problems that I've found and their solutions, so it shows the wrong way
>     to do something and then the correct way.

I am not sure if I understand what you mean. Can you explain in more details?

> Is it possible for it to have a file-only way of reverting to the old way of 'file-local variables' please? As it currently stands, no org-headings are
>     shown in the colours that other org-files are showing them, and its giving the appearance of org-mode not reading and displaying it!

If you have no fontification, please update Org. This issue has been
fixed in a yesterday's commit.

Best,
Ihor


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: ?bug in org-fold-core
  2022-08-04  9:48     ` Ihor Radchenko
@ 2022-08-04 10:41       ` Sharon Kimble
  2022-08-05  2:23         ` Ihor Radchenko
  0 siblings, 1 reply; 7+ messages in thread
From: Sharon Kimble @ 2022-08-04 10:41 UTC (permalink / raw)
  To: Ihor Radchenko; +Cc: emacs-orgmode

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Ihor Radchenko <yantar92@gmail.com> writes:

> Sharon Kimble <boudiccas@skimble09.plus.com> writes:
>
>> I now have this showing in my 'instructions.org'
>> =====
>> # -*- coding: utf-8; mode: org -*-
>> #+STARTUP: show2levels
>>
>> #     #+STARTUP: overview     
>> =====
>>
>> This file seems to be showing most of the problems, and looking at it in 'org-lint' there are many problems. But this file is just some problems that I've found and their solutions, so it shows the wrong way
>>     to do something and then the correct way.
>
> I am not sure if I understand what you mean. Can you explain in more details?

Sure. This is one entry where 'org-lint' shows as '533 Link to non-existent local file ":~/path/to/directory/"'

=====
*** dired
# [[file+emacs:~/path/to/directory/]] ;;; opens dired at that directory
[[file::~/path/to/directory/]] ;;; opens dired at that directory
=====            

This is the full org-lint for my 'instructions.org' file -

=====
   533 low   Link to non-existent local file ":~/path/to/directory/"
  3736 low   Possible incomplete block "#+BEGIN_SRC bash -n   ;; then put in code which will have line numbering done automatically, and end with"
  3737 low   Invalid block closing line "#+END_SRC             ;; use '<s' and TAB it, and it creates the hash line here."
  4686 low   Link to non-existent local file "~/pdf/org.pdf"
  4687 low   Link to non-existent local file "~/pdf/org.txt"
  4871 low   Possible incomplete block "#+END_HTML"
  4989 low   Misplaced planning info line
  4990 nil   Incorrect contents for PROPERTIES drawer
  5836 nil   Unknown fuzzy location "foo"
  6572 nil   Unknown fuzzy location "Glossary-Link::ADHD"
  6610 low   Link to non-existent local file "skull.jpg"
 10556 low   Non-existent file argument in INCLUDE keyword
 10557 low   Non-existent file argument in INCLUDE keyword
 10558 low   Non-existent file argument in INCLUDE keyword
 10559 low   Non-existent file argument in INCLUDE keyword
 10560 low   Non-existent file argument in INCLUDE keyword
 10561 low   Non-existent file argument in INCLUDE keyword
 10964 nil   Missing language in source block
 11031 low   Non-existent file argument in INCLUDE keyword
 11719 nil   Missing language in source block
 12626 low   Deprecated syntax for export block.  Use "BEGIN_EXPORT LaTeX" instead
 12844 low   Link to non-existent local file "./images/number-one.png"
 12846 low   Link to non-existent local file "./images/number-two.png"
 13484 nil   Unknown fuzzy location "wikilink"
 13816 nil   Unknown fuzzy location "link text|pagename"
 13818 nil   Unknown fuzzy location "pagename|link text"
 13905 nil   Unknown fuzzy location "wiki links"
 13909 nil   Unknown fuzzy location "link text|pagename"
 13912 nil   Unknown fuzzy location "pagename|link text"
 13953 nil   Unknown fuzzy location "wiki link"
 14420 nil   Unknown fuzzy location "Glossary-Link::ADHD"
 14488 nil   Unknown custom ID "Anabolic steroids|Anabolic steroids"
 14548 nil   Duplicate target <<FootNote(Brands, B. and Sproule, B. and Marshman, J.; "Drugs & drug abuse"; 1998; 3rd edition; Addiction Research Foundation, Ontario, Canada)>>
 14597 nil   Duplicate target <<FootNote(Brands, B. and Sproule, B. and Marshman, J.; "Drugs & drug abuse"; 1998; 3rd edition; Addiction Research Foundation, Ontario, Canada)>>
 14631 nil   Duplicate target <<FootNote('''Cocaine''', 2013, http://www.cesar.umd.edu/cesar/drugs/cocaine.asp)>>
 14636 nil   Duplicate target <<FootNote('''Cocaine''', 2017, http://www.thegooddrugsguide.com/cocaine/drugtests.htm)>>
 14644 nil   Duplicate target <<FootNote('''Cocaine''', 2017, http://www.thegooddrugsguide.com/cocaine/drugtests.htm)>>
 14652 nil   Duplicate target <<FootNote('''Cocaine''', 2013, http://www.cesar.umd.edu/cesar/drugs/cocaine.asp)>>
 14893 nil   Unknown fuzzy location " $(uname) == 'Darwin' "
 14905 nil   Unknown fuzzy location " -f "$venv/bin/activate" && -z "$VIRTUAL_ENV" "
 14929 nil   Unknown fuzzy location " $2 =~ $re "
=====        


>
>> Is it possible for it to have a file-only way of reverting to the old way of 'file-local variables' please? As it currently stands, no org-headings are
>>     shown in the colours that other org-files are showing them, and its giving the appearance of org-mode not reading and displaying it!
>
> If you have no fontification, please update Org. This issue has been
> fixed in a yesterday's commit.
>
    
I'm now running using 'Org mode version 9.5.4 (release_9.5.4-706-g4702a7 @ /home/boudiccas/git/org-mode/lisp/)'. Is this the most recent version please? Git pull says that its up-to-date.

I'm not sure what you mean by 'no fontification'? The instructions file has the usual org-headings, and the occasional drawer. Can you elucidate please?

Thanks
    Sharon.    
- -- 
A taste of linux = http://www.sharons.org.uk
TGmeds = http://www.tgmeds.org.uk
DrugFacts = https://www.drugfacts.org.uk
Debian 11, fluxbox 1.3.7, emacs 29.0.50, org 9.5.4
-----BEGIN PGP SIGNATURE-----

iQJRBAEBCgA7FiEELSc/6QwVBIYugJDbNoGAGQr4g1sFAmLromkdHGJvdWRpY2Nh
c0Bza2ltYmxlMDkucGx1cy5jb20ACgkQNoGAGQr4g1uNYw//Yw1j9FtpRzQDKd/p
zseXcqZqfsQi6QeOHjtcpV9Mg2lNOa1kU0Ox/AJLS+4GCra3n/wOEJSyrqpHeNBA
TokS4J4FPowazROxCrlWU/PxSUN7y2MMOK++o3K6X6UG/l+m2xcZ0OqTsbQAxKgS
bEwQnvRr7kdD7FNMVtX18WUWjOvL+Ko2o7YylmlmR5W6q7z+J8dIapb7q2wYiD4u
7VQh9SdBQ4MY8rrOVJEhLqQY0hWXyr84fO2mE/jM8KLwQCdQN3fLw8E7d5Gc8gSV
BFMEltCAG5Go0/xxuJyuGZpNjw0Eeyib+J8DhocRoqQ3PIX/cNRIDOu2xe3QjO5A
eH2eDcSDegUvQvzY2CKOrLhfFiNkT3jdz6qnn8mM7j4aqtJc/xqjCIHp5xu37jcn
8EJ3M20rlA6g5lAYi6GeceUhYgqRoJeMZL9SLKODmsZU+zAwFzC7aW11YgCq8S5A
Iq4X1oOBX4Xx58Mzw/m8fRSsnh3wu1rWEgwqrLF0xdY6ctXFO8JKiSsMJ2iD535X
geLVFQV0bOW8YI0WO8WxwpML5jOD4zCl7KnxCk2kqRQmiVm/7vy4pHi87K61kyfp
caASYq96bedKQjdVyzGpf7wtfzMqSO4nQI7d6lh9K7oc9maIxplb7tDP8SQinRBe
OCi1dgS21t2aEEoCCAwS0Hlhbh0=
=uq5L
-----END PGP SIGNATURE-----


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: ?bug in org-fold-core
  2022-08-04 10:41       ` Sharon Kimble
@ 2022-08-05  2:23         ` Ihor Radchenko
  2022-08-05 12:11           ` [SOLVED] " Sharon Kimble
  0 siblings, 1 reply; 7+ messages in thread
From: Ihor Radchenko @ 2022-08-05  2:23 UTC (permalink / raw)
  To: Sharon Kimble; +Cc: emacs-orgmode

Sharon Kimble <boudiccas@skimble09.plus.com> writes:

>> I am not sure if I understand what you mean. Can you explain in more details?
>
> Sure. This is one entry where 'org-lint' shows as '533 Link to non-existent local file ":~/path/to/directory/"'
>
> =====
> *** dired
> # [[file+emacs:~/path/to/directory/]] ;;; opens dired at that directory
> [[file::~/path/to/directory/]] ;;; opens dired at that directory
> =====            
>
> This is the full org-lint for my 'instructions.org' file -
>
> =====
>    533 low   Link to non-existent local file ":~/path/to/directory/"

This is nothing wrong on Org side. Just an indication for you that you
have issues with Org markup in your Org file. I suggest fixing them, for
your own safety - Org may behave incorrectly on incorrect Org documents.

>>> Is it possible for it to have a file-only way of reverting to the old way of 'file-local variables' please? As it currently stands, no org-headings are
>>>     shown in the colours that other org-files are showing them, and its giving the appearance of org-mode not reading and displaying it!
>>
>> If you have no fontification, please update Org. This issue has been
>> fixed in a yesterday's commit.
>>
>     
> I'm now running using 'Org mode version 9.5.4 (release_9.5.4-706-g4702a7 @ /home/boudiccas/git/org-mode/lisp/)'. Is this the most recent version please? Git pull says that its up-to-date.

This is some very strange Org version - we have no commit 4702a7. I
suggest removing your local copy and re-fetch Org from our official
repo. See https://orgmode.org/

> I'm not sure what you mean by 'no fontification'? The instructions file has the usual org-headings, and the occasional drawer. Can you elucidate please?

I probably misunderstood you. I do not understand what you mean by

>>> ... no org-headings are shown in the colours that other org-files
>>> are showing them, and its giving the appearance of org-mode not
>>> reading and displaying it!"

Best,
Ihor


^ permalink raw reply	[flat|nested] 7+ messages in thread

* [SOLVED] Re: ?bug in org-fold-core
  2022-08-05  2:23         ` Ihor Radchenko
@ 2022-08-05 12:11           ` Sharon Kimble
  0 siblings, 0 replies; 7+ messages in thread
From: Sharon Kimble @ 2022-08-05 12:11 UTC (permalink / raw)
  To: Ihor Radchenko; +Cc: emacs-orgmode

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Ihor Radchenko <yantar92@gmail.com> writes:

> Sharon Kimble <boudiccas@skimble09.plus.com> writes:
>
>>> I am not sure if I understand what you mean. Can you explain in more details?
>>
>> Sure. This is one entry where 'org-lint' shows as '533 Link to non-existent local file ":~/path/to/directory/"'
>>
>> =====
>> *** dired
>> # [[file+emacs:~/path/to/directory/]] ;;; opens dired at that directory
>> [[file::~/path/to/directory/]] ;;; opens dired at that directory
>> =====            
>>
>> This is the full org-lint for my 'instructions.org' file -
>>
>> =====
>>    533 low   Link to non-existent local file ":~/path/to/directory/"
>
> This is nothing wrong on Org side. Just an indication for you that you
> have issues with Org markup in your Org file. I suggest fixing them, for
> your own safety - Org may behave incorrectly on incorrect Org documents.
>
>>>> Is it possible for it to have a file-only way of reverting to the old way of 'file-local variables' please? As it currently stands, no org-headings are
>>>>     shown in the colours that other org-files are showing them, and its giving the appearance of org-mode not reading and displaying it!
>>>
>>> If you have no fontification, please update Org. This issue has been
>>> fixed in a yesterday's commit.
>>>
>>     
>> I'm now running using 'Org mode version 9.5.4 (release_9.5.4-706-g4702a7 @ /home/boudiccas/git/org-mode/lisp/)'. Is this the most recent version please? Git pull says that its up-to-date.
>
> This is some very strange Org version - we have no commit 4702a7. I
> suggest removing your local copy and re-fetch Org from our official
> repo. See https://orgmode.org/
>
>> I'm not sure what you mean by 'no fontification'? The instructions file has the usual org-headings, and the occasional drawer. Can you elucidate please?
>
> I probably misunderstood you. I do not understand what you mean by
>
>>>> ... no org-headings are shown in the colours that other org-files
>>>> are showing them, and its giving the appearance of org-mode not
>>>> reading and displaying it!"
>

Thanks Ihor, the reversion of the local variables change has worked through its pipelines and I can confirm that 'Org mode version 9.5.4 (release_9.5.4-707-g215de6 @
    /home/boudiccas/git/org-mode/lisp/)' now works perfectly and my file that I was having problems with is now back to working as before, with no problems. Although I do intend to sort out the
    problems shown in org-lint, in due course.

Thanks
    Sharon.
- -- 
A taste of linux = http://www.sharons.org.uk
TGmeds = http://www.tgmeds.org.uk
DrugFacts = https://www.drugfacts.org.uk
Debian 11, fluxbox 1.3.7, emacs 29.0.50, org 9.5.4
-----BEGIN PGP SIGNATURE-----

iQJRBAEBCgA7FiEELSc/6QwVBIYugJDbNoGAGQr4g1sFAmLtCOcdHGJvdWRpY2Nh
c0Bza2ltYmxlMDkucGx1cy5jb20ACgkQNoGAGQr4g1tTXhAAqj5evrfY2H6iwXRu
TTpFLnSzVMcuCprxFuXY5ozKyFJ17YrN1BSoA9/DOznVedg5/aikr3HtzTBkkOfB
muFN1+c4rqgb5qwvCdhNQmcWKbJeWsxcfFHkq+56a6u/vcjpgyxg+q8jTJDuMDZx
y0WhPeXO535zZ9omXsfyeAHfud+sZvZtF/rBAJtLUxLzN8o4irKH9u8iieZbI55n
+nSIn9XRNjMwrvpHpHbAfXavcRSEALtix+mDrvCMgfMfDntexahvbfkdJ+avT2C/
iAIysxC0T6ObelU6r8pbncj5fyib5hwuGXF/7FjKe0epniBE4h+F9ev6NF2FbyNK
9y/jkPSSCwZ0x5uBAMVhcrr2FPhS/P6SpMqQFpdcOjuWo/lVWqSsJg4MOJWtug7C
NhvbPE5sz1im5pXTreamjL47chU4QXjiU1DBCYL9u0c34woLKn8HFGhY3dpDt1sI
aYbAouY/mjCw6Bcnq5LeAlo8SYXqC9o4NUXr6tIjPjrtv7GSqgdHcK+/OWfVI8/v
eMDkTPcpPGFZsSXyGxOLC8yoPwvSu6oE3yPYJ14n/FYD5FBNVHjXtK1qX6g05atc
ltaSYM0f8FGmN3TaMftq5N+1HOPuA5z3RK9NAHq0yOBgrkAvCVCiy8zS4w04tlMk
HFdcQFl5ZhS/LuuEq+Yw3zDdpSw=
=WJWv
-----END PGP SIGNATURE-----


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2022-08-05 12:12 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-08-04  8:05 ?bug in org-fold-core Sharon Kimble
2022-08-04  8:50 ` Ihor Radchenko
2022-08-04  9:38   ` Sharon Kimble
2022-08-04  9:48     ` Ihor Radchenko
2022-08-04 10:41       ` Sharon Kimble
2022-08-05  2:23         ` Ihor Radchenko
2022-08-05 12:11           ` [SOLVED] " Sharon Kimble

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).