emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org-special-ctrl-a/e induces problems in items
@ 2012-02-03 15:14 François Pinard
  2012-02-04 15:41 ` Nicolas Goaziou
  0 siblings, 1 reply; 3+ messages in thread
From: François Pinard @ 2012-02-03 15:14 UTC (permalink / raw)
  To: emacs-orgmode

Hi, Org mode maintainers.

When org-special-ctrl-a/e is active, and when a list item is a whole
paragraph spanning many visual lines, `C-a' and `C-e' both misbehave.

`C-e' moves to the end of the visual paragraph (that is, the end of the
physical line) instead of moving at the end of the visual line.

`C-a' produces an error if the cursor is after the first visual line in
the visual paragraph, see the traceback below.  My guess is that
(org-list.el) org-at-item-p should return true only when on the first
visual line, while currently, it always return a true value.

François



Debugger entered--Lisp error: (wrong-type-argument number-or-marker-p nil)
  >(11477 nil)
  (or (> pos after-bullet) (= (point) pos))
  (if (or (> pos after-bullet) (= ... pos)) (progn (goto-char after-bullet)))
  (when (or (> pos after-bullet) (= ... pos)) (goto-char after-bullet))
  (if (eq special t) (when (or ... ...) (goto-char after-bullet)) (when (and ... ...) (goto-char after-bullet)))
  (let ((after-bullet ...)) (if (eq special t) (when ... ...) (when ... ...)))
  (cond ((and ... ...) (setq refpos ...) (goto-char ...)) ((org-at-item-p) (let ... ...)))
  (progn (cond (... ... ...) (... ...)))
  (if special (progn (cond ... ...)))
  (when special (cond (... ... ...) (... ...)))
  (let ((pos ...) (special ...) refpos) (if (org-bound-and-true-p line-move-visual) (beginning-of-visual-line 1) (beginning-of-line 1)) (if (and arg ...) (call-interactively ...) (if ... nil ... ...)) (when special (cond ... ...)) (org-no-warnings (and ... ...)))
  org-beginning-of-line(nil)
  call-interactively(org-beginning-of-line nil nil)

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: org-special-ctrl-a/e induces problems in items
  2012-02-03 15:14 org-special-ctrl-a/e induces problems in items François Pinard
@ 2012-02-04 15:41 ` Nicolas Goaziou
  2012-02-04 16:18   ` François Pinard
  0 siblings, 1 reply; 3+ messages in thread
From: Nicolas Goaziou @ 2012-02-04 15:41 UTC (permalink / raw)
  To: François Pinard; +Cc: emacs-orgmode

Hello,

pinard@iro.umontreal.ca (François Pinard) writes:

> When org-special-ctrl-a/e is active, and when a list item is a whole
> paragraph spanning many visual lines, `C-a' and `C-e' both misbehave.

This should be fixed now. Thanks for the report.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: org-special-ctrl-a/e induces problems in items
  2012-02-04 15:41 ` Nicolas Goaziou
@ 2012-02-04 16:18   ` François Pinard
  0 siblings, 0 replies; 3+ messages in thread
From: François Pinard @ 2012-02-04 16:18 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: emacs-orgmode

Nicolas Goaziou <n.goaziou@gmail.com> writes:

>> When org-special-ctrl-a/e is active, and when a list item is a whole
>> paragraph spanning many visual lines, `C-a' and `C-e' both misbehave.

> This should be fixed now. Thanks for the report.

Hi, Nicolas.  And it does work! :-)  Thanks!

François

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2012-02-04 16:18 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-02-03 15:14 org-special-ctrl-a/e induces problems in items François Pinard
2012-02-04 15:41 ` Nicolas Goaziou
2012-02-04 16:18   ` François Pinard

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).