emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Bug: :clock-keep...not kept [7.5 commit-078c01bf3b1742b1015fac9f5bab3a429505f3c6]
@ 2011-03-23  9:25 Giovanni Ridolfi
  0 siblings, 0 replies; 3+ messages in thread
From: Giovanni Ridolfi @ 2011-03-23  9:25 UTC (permalink / raw)
  To: emacs-orgmode


Remember to cover the basics, that is, what you expected to happen and
what in fact did happen.  You don't know how to make a good report?  See

     http://orgmode.org/manual/Feedback.html#Feedback

Your bug report will be posted to the Org-mode mailing list.
------------------------------------------------------------------------

Emacs  : GNU Emacs 23.3.1 (i386-mingw-nt5.1.2600)
 of 2011-03-10 on 3249CTO
Package: Org-mode version 7.5 commit-078c01bf3b1742b1015fac9f5bab3a429505f3c6


The option :clock-keep, in the capture template, is not honoured and 
org clocks out when I close my template buffer.

This is my template:
(setq org-capture-templates
'(("s" "Task" entry (file+headline "c:/Documents and  Settings/user/Documents/test.org" "test") "*** %^{prompt}
   :PROPERTIES:
   :Note:
   :Comment:  %?
   :END: " :clock-in t :clock-keep t)))

---------------------------------- this is the result ----------
** hi
    CLOCK: [2011-03-23 mer 10:07]--[2011-03-23 mer 10:07] =>  0:00
   :PROPERTIES:
   :Note:
   :Comment:  
   :END:
-------------------------------------------------------------------

Another useful information is that, if I customize the
org-capture-template variable  'C-c c C ' the option 
:clock-keep is nil  ?!
This way I do not have the possibility to set it to "clock-keep t"

-------------------------------------template----------------
Org Capture Templates: Hide Value
INS DEL Choice: Value Menu Template entry:
            Keys           : s
            Description    : Task
            Capture Type   : Value Menu Org entry
            Target location: Value Menu File & Headline:
              File    : c:/Documents and Settings/user/Documents/test.org
              Headline: test
            Template: Value Menu String: *** %^{prompt}
   :PROPERTIES:
   :Note:
   :Comment:  %?
   :END: 
            Plist:
            [ ] Key: :prepend t
            [ ] Key: :immediate-finish t
            [ ] Key: :empty-lines 1
            [X] Key: :clock-in t
            [ ] Key: :clock-keep nil
            [ ] Key: :clock-resume t
            [ ] Key: :unnarrowed t
            [ ] Key: :kill-buffer t
                        INS DEL Key: :clock-keep
                        Value: t
            INS

----------------------------------------
If I toggle the :clock-keep nil option [v], and set for current session,
the clock is clocked out.


current state:
==============
(setq
 org-log-done 'time
 org-export-latex-after-initial-vars-hook '(org-beamer-after-initial-vars)
 org-speed-command-hook '(org-speed-command-default-hook org-babel-speed-command-hook)
 org-blocker-hook '(org-block-todo-from-children-or-siblings-or-parent)
 org-metaup-hook '(org-babel-load-in-session-maybe)
 org-capture-templates '(("s" "Task" entry
			  (file+headline "c:/Documents and Settings/user/Documents/test.org"
			   "test")
			  "*** %^{prompt}\n   :PROPERTIES:\n   :Note:\n   :Comment:  %?\n   :END: " :clock-in t :clock-keep
			  t)
			 )
 org-after-todo-state-change-hook '(org-clock-out-if-current)
 org-export-blocks-postblock-hook '(org-exp-res/src-name-cleanup)
 org-export-latex-format-toc-function 'org-export-latex-format-toc-default
 org-tab-first-hook '(org-hide-block-toggle-maybe org-src-native-tab-command-maybe org-babel-hide-result-toggle-maybe)
 org-src-mode-hook '(org-src-babel-configure-edit-buffer org-src-mode-configure-edit-buffer)
 org-finalize-agenda-hook '(my-org-agenda-to-appt)
 org-confirm-shell-link-function 'yes-or-no-p
 org-export-first-hook '(org-beamer-initialize-open-trackers)
 org-agenda-before-write-hook '(org-agenda-add-entry-text)
 org-babel-pre-tangle-hook '(save-buffer)
 org-cycle-hook '(org-cycle-hide-archived-subtrees org-cycle-hide-drawers org-cycle-show-empty-lines
		  org-optimize-window-after-visibility-change)
 org-export-preprocess-before-normalizing-links-hook '(org-remove-file-link-modifiers)
 org-mode-hook '((lambda nil
		  (org-add-hook (quote change-major-mode-hook) (quote org-show-block-all) (quote append) (quote local)))
		 (lambda nil
		  (org-add-hook (quote change-major-mode-hook) (quote org-babel-show-result-all) (quote append)
		   (quote local))
		  )
		 org-babel-result-hide-spec org-babel-hide-all-hashes)
 org-ctrl-c-ctrl-c-hook '(org-babel-hash-at-point org-babel-execute-safely-maybe)
 org-confirm-elisp-link-function 'yes-or-no-p
 org-export-interblocks '((lob org-babel-exp-lob-one-liners) (src org-babel-exp-inline-src-blocks))
 org-enforce-todo-dependencies t
 org-occur-hook '(org-first-headline-recenter)
 org-export-preprocess-before-selecting-backend-code-hook '(org-beamer-select-beamer-code)
 org-export-latex-final-hook '(org-beamer-amend-header org-beamer-fix-toc org-beamer-auto-fragile-frames
			       org-beamer-place-default-actions-for-lists)
 org-metadown-hook '(org-babel-pop-to-session-maybe)
 org-export-blocks '((src org-babel-exp-src-block nil) (comment org-export-blocks-format-comment t)
		     (ditaa org-export-blocks-format-ditaa nil) (dot org-export-blocks-format-dot nil))
 )

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Bug: :clock-keep...not kept [7.5 commit-078c01bf3b1742b1015fac9f5bab3a429505f3c6]
  2011-04-07 11:31 Giovanni Ridolfi
@ 2011-04-08  2:09 ` Bernt Hansen
  0 siblings, 0 replies; 3+ messages in thread
From: Bernt Hansen @ 2011-04-08  2:09 UTC (permalink / raw)
  To: Giovanni Ridolfi; +Cc: Org Mode, Carsten Dominik

Hi Giovanni,

Giovanni Ridolfi <giovanni.ridolfi@yahoo.it> writes:

> I think I found a bug with the option ":clock-keep"
>
> :clock-keep'
>           Keep the clock running when filing the captured entry.
>
> Emacs  : GNU Emacs 23.3.1 (i386-mingw-nt5.1.2600)  of 2011-03-10 on 3249CTO
> Package: Org-mode version 7.5 commit-4168fccdc7eab648d9c4517afe56765aaa1e9664
>

<snip>

> I tried to look at the code to understand it, but it is beyond my skills.
>
> On the other hand I did some tests:
> ** set up  - beware I'm under Windows. 
>    (for Bernt's set up (linuxish) please refer to message
>    http://thread.gmane.org/gmane.emacs.orgmode/38485    )
>
> My minimal.emacs
> (add-to-list 'load-path (expand-file-name "c:/Documents and Settings/my-path/org/lisp"))
> (add-to-list 'auto-mode-alist '("\\.\\(org\\|org_archive\\|txt\\)$" . org-mode))
> (require 'org-install)
>
> (global-set-key "\C-cl" 'org-store-link)
> (global-set-key "\C-ca" 'org-agenda)
> (global-set-key "\C-cb" 'org-iswitchb)
>
> (global-set-key "\C-cc" 'org-capture)
>
> (setq org-capture-templates (quote (("t" "todo" entry (file "c:/Documents and Settings/my-path/a.org") "* TODO %?
> %U
> %a
> " :immediate-finish t :clock-in t :clock-keep t))))  
>
> I run emacs with:
>
> c:\path\>  emacs -q -l ~/minimal.emacs 
>
> C-c c t    to call the template.  
>            Fill it in and 
> C-c C-c    to close.
>
> I have modified the properties in the last row:
>
> ** if :immediate-finish nil :clock-in t :clock-keep t
>    the clock in clocks-in
>     BUT the clock is not kept, it is closed anyway. 

I can reproduce this problem.

I think :immediate-finish never clocks in at all which is
why :clock-keep is not doing anything in this case.

I think this is a bug and the clock should probably be started and kept
in the new capture task.

>
> **    without immediate-finish
> ** if                      :clock-in t :clock-keep t
>     the clock in clocks-in
>     BUT the clock is not kept, it is closed anyway. 

I can reproduce this problem as well.

I don't currently have a use case for :clock-keep so I'm not currently
using this feature in my templates.

I agree the clock should probably be started and kept in the new capture
task.


>
> cheers,
> Giovanni
>
> P.S. Side effect (very emacsish).
>
> While testing I found an unexpected behaviour with :clock-resume
>
> ** if :immediate-finish t :clock-in t :clock-resume t
> *** and If there is no clock to be resumed the clock-in does not
>     clock-in in the capture buffer.
> Is this  a bug?
> Shall be thrown a message: "No clock to be resumed"?
>
> *** If there is clock to be resumed
> the clock is resumed. It works.

I think this is intended behaviour.  If a clock is not already running
before you start the capture then there is no task to resume the clock
on.  In this case the clock stops after the capture is finalized.

Is throwing an error message for this really useful?

GNU Emacs 23.2.1 (i486-pc-linux-gnu, GTK+ Version 2.20.0) of 2010-12-11
on raven, modified by Debian

Regards,
Bernt

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Bug: :clock-keep...not kept [7.5 commit-078c01bf3b1742b1015fac9f5bab3a429505f3c6]
@ 2011-04-07 11:31 Giovanni Ridolfi
  2011-04-08  2:09 ` Bernt Hansen
  0 siblings, 1 reply; 3+ messages in thread
From: Giovanni Ridolfi @ 2011-04-07 11:31 UTC (permalink / raw)
  To: Org Mode; +Cc: Bernt Hansen, Carsten Dominik

Hello everyone,

I think I found a bug with the option ":clock-keep"

:clock-keep'
          Keep the clock running when filing the captured entry.

Emacs  : GNU Emacs 23.3.1 (i386-mingw-nt5.1.2600)  of 2011-03-10 on 3249CTO
Package: Org-mode version 7.5 commit-4168fccdc7eab648d9c4517afe56765aaa1e9664

The option was introduced on 2011-03-07, by Bastien,
in commit:

b969081ebd0da2711f1006fec39e04fe4a90ef71  : org-capture.el: 
                           new :no-clock-out template option.

and, after Carsten chimed in, message:
http://article.gmane.org/gmane.emacs.orgmode/38951
Bastien:
> See my previous message -- I used :no-clock-out to stick to the default
> behavior and avoid users to have to change their config.  Let me know if
> this is okay for you!

I like this decision, because of the templates is asked to clock
in, it seems natural for me that it will clock out when it is done.

This only suggestion I would have is it maybe call the property
:clock-keep-running.  No sure though.
--------------------------------------------------

in commit  

54c638523d4706d955c9d16cb5f499bcfa92bec9   : org-capture.el: 
                                  Rename :no-clock-out to :clock-keep.

The thread with the complete discussion is here:

http://thread.gmane.org/gmane.emacs.orgmode/38485

I tried to look at the code to understand it, but it is beyond my skills.

On the other hand I did some tests:
** set up  - beware I'm under Windows. 
   (for Bernt's set up (linuxish) please refer to message
   http://thread.gmane.org/gmane.emacs.orgmode/38485    )

My minimal.emacs
--8<---------------cut here---------------start------------->8--
(add-to-list 'load-path (expand-file-name "c:/Documents and Settings/my-path/org/lisp"))
(add-to-list 'auto-mode-alist '("\\.\\(org\\|org_archive\\|txt\\)$" . org-mode))
(require 'org-install)

(global-set-key "\C-cl" 'org-store-link)
(global-set-key "\C-ca" 'org-agenda)
(global-set-key "\C-cb" 'org-iswitchb)

(global-set-key "\C-cc" 'org-capture)

(setq org-capture-templates (quote (("t" "todo" entry (file "c:/Documents and Settings/my-path/a.org") "* TODO %?
%U
%a
" :immediate-finish t :clock-in t :clock-keep t))))  
--8<---------------cut here---------------end--------------->8---

I run emacs with:

c:\path\>  emacs -q -l ~/minimal.emacs 

C-c c t    to call the template.  
           Fill it in and 
C-c C-c    to close.

I have modified the properties in the last row:

** if :immediate-finish nil :clock-in t :clock-keep t
   the clock in clocks-in
    BUT the clock is not kept, it is closed anyway. 

**    without immediate-finish
** if                      :clock-in t :clock-keep t
    the clock in clocks-in
    BUT the clock is not kept, it is closed anyway. 


cheers,
Giovanni

P.S. Side effect (very emacsish).

While testing I found an unexpected behaviour with :clock-resume

** if :immediate-finish t :clock-in t :clock-resume t
*** and If there is no clock to be resumed the clock-in does not
    clock-in in the capture buffer.
Is this  a bug?
Shall be thrown a message: "No clock to be resumed"?

*** If there is clock to be resumed
the clock is resumed. It works.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2011-04-08  2:09 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-03-23  9:25 Bug: :clock-keep...not kept [7.5 commit-078c01bf3b1742b1015fac9f5bab3a429505f3c6] Giovanni Ridolfi
2011-04-07 11:31 Giovanni Ridolfi
2011-04-08  2:09 ` Bernt Hansen

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).